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Chapter 1

Introduction

The Dominion KX Il is an enterprise-class, secure, KVM-over-|P switch
that provides 1, 2, 4 or 8 users with remote BIOS-level control of 8 to 64
servers.

KX Ill comes with standard features such as DVI/HDMI/DisplayPort
digital and analog video, audio, virtual media, smart card/CAC, blade
server support, and mobile access.

Deploy KX Il individually, or with Raritan’s CommandCenter Secure
Gateway (CC-SG).

In This Chapter

(O <Y V1= Y R
Package CoNtENES oo s
KX Il Device Photos and Features ...
KX Il Remote/Local Console Interfaces and User Station .........cccceeveeeeeeee.
KX I KVM Client Applications .....cocii i
KX 11l Online Help

Overview
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servers.

KX Ill comes with standard features such as DVI/HDMI/DisplayPort
digital and analog video, audio, virtual media, smart card/CAC, blade
server support, and mobile access.
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Package Contents

Each KX Il ships as a fully-configured stand-alone product in a standard
1U (2U for KX3-864) 19" rackmount chassis. Each KX Il device ships with
the following contents:

1 - KX Il device

1 - KX Il Quick Setup Guide

1 - Rackmount kit

2 - AC power cords

1 - Set of 4 rubber feet (for desktop use)
1 - Application note

1 - Warranty card

KX 11l Device Photos and Features

Hardware

Integrated KYM-over-IP remote access
1U or 2U rack-mountable (brackets included)

Dual power supplies with failover; autoswitching power supply with
power failure warning

Support for the following CIMs:

= Forvirtual media and Absolute Mouse Synchronization, use one
of the following CIMs:

= D2CIM-VUSB

= D2CIM-DVUSB

= D2CIM-DVUSB-DVI

= D2CIM-DVUSB-HDMI

= D2CIM-DVUSB-DP
= Required for PS2 connection:

= DCIM-PS2
DVI monitor support from the DVI local port
= VGA support via a DVI to VGA converter
= DVl support via a standard DVI cable
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e Remote access and power management from an iPhone® or iPad®

e Support for tiering in which a base KX lll device is used to access
multiple other tiered devices

e Multiple user capacity (1/2/4/8 remote users; 1 local user])
e UTP (Cat5/5e/6) server cabling

e Dual Ethernet ports (10/100/1000 LAN) with failover or isolation
mode support

e Field upgradable
e Local USB User port for in-rack access
= USB Keyboard/mouse ports, or connect to a cellular modem

= One front and three back panel USB ports for supported USB
devices

= Fully concurrent local and remote user access

» Local graphical user interface (GUI) for administration
e Serial port to connect to an external telephone modem
e Centralized access security
e Integrated power control

e LED indicators for dual power status, network activity, and remote
user status

e Hardware Reset button

Software
e Virtual media support in Windows®, Mac® and Linux® environments*
e Absolute Mouse Synchronization*

*Note: Virtual media and Absolute Mouse Synchronization require
use of a D2CIM-VUSB, D2CIM-DVUSB, D2CIM-DVUSB-DVI,
D2CIM-DVYUSB-HDM| or D2CIM-DVUSB-DP CIM.
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Chapter 1: Introduction

Support for digital audio over USB

Port scanning and thumbnail view of up to 32 targets within a
configurable scan set

Web-based access and management
Intuitive graphical user interface (GUI)
Support for dual port video output

256-bit encryption of complete KVM signal, including video and
virtual media

LDAP, Active Directory®, RADIUS, or internal authentication and
authorization

DHCP or fixed IP addressing

Smart card/CAC authentication

SNMP, SNMP3, SMTP, and Syslog management

IPv4 and IPv6 support

Power control associated directly with servers to prevent mistakes

Integration with Raritan's CommandCenter Secure Gateway (CC-SG)
management unit

CC Unmanage feature to remove device from CC-SG control
Support of Raritan PX1 and PX2 appliances

Support for remote IP access from the new Dominion KX Il User
Station

Support for access to serial targets using the Dominion Serial
Access Module (DSAM)
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Dominion KX3-832

KX3-832 Photos

KX3-832 Features

E

910 11 12 13 14 15 16 28 ¢ 7 28 ¥ N N N

&
Ll.J

" 20 2 2 n M

Diagram key
o Dual Power AC 100V/240V

e Dual 10/100/1000 Ethernet access

e Local USB ports
0 DVI-D port
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Diagram key

EJ
F
.

32 KVM ports for UTP Cabling (Cat5/5e/6)
Tier port for tiering devices

Modem port for external modems

Dominion KX3-864

KX3-864 Photos

e T SRR
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Diagram key
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Diagram key
Dual 10/100/1000 Ethernet access

Local USB ports

DVI-D port

64 KVM ports for UTP Cabling (Catb/5e/6)
Tier port for optional tiering devices

Modem port for optional external modems

000O0O0

Supported Number of Ports and Remote Users per Model

Model Ports Remote users
KX3-864 b4 8
KX3-832 32 8
KX3-808 8 8
KX3-464 b4 4
KX3-432 32 4
KX3-416 16 4
KX3-232 32 2
KX3-216 16 2
KX3-132 32 1
KX3-116 16 1
KX3-108 8 1
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Chapter 1: Introduction

KX Il Remote/Local Console Interfaces and User Station

Use the Remote Console interface to configure and manage the KX |l
over a network connection.

Use the Local Console interface to access the KX Ill while at the rack.

See KX Ill Remote Console Interface (on page 21), KX Il Local Console
- KX Il Administration Functions and KX Il Local Console Interface (on
page 31), respectively.

The Dominion User Station provides an alternative interface for IP
access to the KX lll's target servers. See Dominion KX 1l User Station
(on page 143).

KX 1l KVM Client Applications

KX Il works with -

e Active KVM Client [AKC]) - Default client, Windows only.

Microsoft .NET® 4.0 (or later] is required to use KX Il with the
Microsoft Windows®-based Active KVM Client (AKC). See Active KVM
Client [AKC] Help (on page 90)

e Virtual KVM Client (VKC) -Java™ 1.7 is required to use the Java-based
Virtual KVM Client (VKC). Java 1.8.0_40 is required to use the VKCS.
Also available in a Standalone version for the Chrome browser. Java
is required. See Virtual KVM Client [VKC) Help (see "Virtual KVYM
Client [VKC and VKCs] Help" on page 45)

e HTML KVM Client (HKC) - Runs on Linux, Mac, and Windows
without .NET, in |IE, Edge, Firefox, Chrome and Safari. No Java. Basic
KVM features are supported. See HTML KVM Client (HKC] Help (on
page 94).

e Mobile KVM Client (MKC] - Mobile access is provided through Mobile
Access Client, which requires the use of CommandCenter Secure
Gateway (CC-SG). See Mobile KVM Client [MKC] Help (on page 147)

Raritan.

A brand of Ellegrand



Chapter 1: Introduction

KX 11l Online Help

KX Il online help is considered your primary help resource.
KVM Client help is provided as part of KX Il online help.

Online help is accompanied by the KX Il Quick Setup Guide, which is
included with your KX lll and can be found on the Support page of
Raritan’s website
(http://www.raritan.com/support/firmware-and-documentation).

The Support page also contains a PDF version of the end user help
sections of online help, and a PDF containing the KX Ill administrator
help sections.

See the KX Il Release Notes for important information on the current
release before you begin using the KX III.

To use online help, Active Content must be enabled in your browser.
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Chapter 2

Get Started Using KX Il

This section walks you through high-level tasks to start using KX IlI.

In This Chapter

Install and Configure KX 1. ..o 10
Factory Default Login INformation.......cccccevieiiiiiiiiieee e 10
ALLOW POP-UPS .. 10
Security Warnings and Validation Messages. ... 1
Installing @ Certificate ..o 12
Converting a Binary Certificate to a Basebé4-Encoded DER Certificate

(OPLIONAL ettt 17
Logging IN £0 KX T e e 19

Install and Configure KX IlI

If you have not already done so, install and configure KX 111

See the KX Il Quick Setup Guide that came with the KX Ill device or
download it from the Raritan Support website
http://www.raritan.com/support.

Factory Default Login Information

The KX Il device is shipped from the factory with the following default
settings built in:

e Username = admin

All lowercase.

This user has administrative privileges.
e Password=raritan

All lowercase.
e |Paddress=192.168.0.192

Important: For backup and business continuity purposes, it is
strongly recommended you create a backup administrator username
and password, and keep that information in a secure location.

Allow Pop-Ups

Raritan.
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Regardless of the browser you are using, you must allow pop-ups in
order to launch the KX Ill Remote Console.
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Chapter 2: Get Started Using KX 11

Security Warnings and Validation Messages
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When logging in to KX Il using RSC, security warnings and application

validation message may appear.
These include -

e Java” security warnings and requests to validate KX Il|

See Java Validation and Access Warning (on page 11) and

Installing a Certificate (on page 12)

e Additional security warnings based on your browser and security

settings

See Additional Security Warnings (on page 12)

Java Validation and Access Warning

When logging in to KX III, Java™ 1.7 prompts you to validate KX lll, and to

allow access to the application.

Raritan recommends installing an SSL certificate in each KX Ill device in

order to reduce Java warnings, and enhance security.
See SSL Certificates

Do you want to run this application?

Name: Raritan Favorite Devices Applet
“EE' 2 Publisher: Raritan Americas, Inc.
e

Location: https:ff192.168.60. 137

This application will run with unrestricted access which may put your computer and personal
information at risk, Run this application only if you trust the location and publisher above.,

Do not show this again for apps from the publisher and location abave
6 More Information

Security Warning | &8 ]

Do you want to Continue?
The connection to this website is untrusted.

Website: https://192.168.50.137:443

Mote: The certificate is not valid and cannot be used to verify the identity of this website.

More Information
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Chapter 2: Get Started Using KX Il

Additional Security Warnings

Even after an SSL certificate is installed in the KX IIl, depending on your
browser and security settings, additional security warnings may be
displayed when you log in to KX III.

It is necessary to accept these warnings to launch the KX Il Remote
Console.

Reduce the number of warning messages during subsequent log ins by
checking the following options on the security and certificate warning
messages:

e |nthe future, do not show this warning
e Always trust content from this publisher

Installing a Certificate

You may be prompted by the browser to accept and validate the KX llI's
SSL certificate.

Depending on your browser and security settings, additional security
warnings may be displayed when you log in to KX III.

It is necessary to accept these warnings to launch the KX Ill Remote
Console. For more information, see Security Warnings and Validation
Messages (on page 11).

Two sample methods on how to install an SSL Certificate in the browser

are provided here, both using Microsoft Internet Explorer 8® and
Windows 7°.

Specific methods and steps depend on your browser and operating
system. See your browser and operating system help for details.

Raritan.
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Chapter 2: Get Started Using KX Il

Example 1: Import the Certificate into the Browser

In this example, you import the Certificate into the browser.

SRaritan.
Dominion®
Time & Session: [iy The certificate used to identify the website is not trusted. The reasons
December 16, 2013 07.08:17 Port Access are isted below.
e f Proceed at own risk.
e = p
T
t to Conti The certificate that issued ths certficate is not trusted.
= s = > cer Autharity cer is
| The connection to this website is untrusted.
I The applcation i beng downloaded from 3 site other than the one
' spedified by the security certficate.
J/ - Downioading from "192.168.61.20"
/ .5 Wiebsite: hitps://192.163.61.20:43 - Expecting Raritan KYM"
The
Note: v Y e—»mwvﬁukkus,
! This appicaton vl be blodied n 8 Ature Juva security Lodate 248 fie marsfest does not
contan the Permissions atirbute. Please contact the Publsher More Informaton Note to the Publisher: Secunty features to prevent
i of your Java will cause this
to be biocked in the future. See current Java
[ coore | [ coxe | d about JAR Manfest entries for the changes that
need to be made. il
7 Port i
B::: 2:"‘ e Note to users: For any questions, please contact the Publsher
who provided you with this application,
Connected Users:
admin (192.16851.75) 4
43 min idle
-
Visit Java.com for more detads | Gose |
¢ J

1. Open an IE browser, then log in to KX III.
Click More Information on the first Java™ security warning.

3. Click View Certificate Details on the More Information dialog. You are
prompted to install the certificate. Follow the wizard steps.

Raritan. 13
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Chapter 2: Get Started Using KX |11

Note: If you are not prompted by the browser, manually select Tools >

Internet Options to open the Internet Options dialog.

Contificate Import Wizard — _— )
Welcome to the Certificate Import
Wizard
-’ Thus it o yous copy cervAcares, cermhcate Vst
’*_ ot and certécate revocaton ket from your dak 30
&5 cortacara store
Intemet Opticers » A cervicate, which 6 e by » cerbcaton suhonty, &
o ety
and 12 orotect data o £ evtacheh secure netuork
Generai | Content | Connactiond Corviechons. A gertAcate shre s T syviem wres Mwre
cervacates e beot
Contanit Adveor To contrue, dick Nest.
9\ Ratrgs heb you contral the Intermet cof
viewed on th computer
i‘m-..
Certécates
Use certficates for encrypted connectol
i
l o4 b Certfates
v )
|| Aunocomplete |
e ! P I
I 3 z«bomm-mnnwm Cetibcate mport Wizard —
you. e ahaS — =
Feads and Wb Sons Completing the Certificate Import
7] Feeds and Web Skoes provide updated Wizard
! F5) content from webates that can be
(! fad s Sakwmet Exphores s offer - The certhcate wl be mported after you ik Frish,
programs. %
li -
g Yo have echied e Slowng settrgs:
IDIEIIPIIY Aomancaly determrectyt
Conters Corsicnte
P ame Cmars e Dedk e
G!—»‘ o
- —
Certcate Yrport Wizerd )
o The import was succes i

1. Click the Content tab.
2. Click Certificates.
The Certificate Import Wizard opens and walks you through each

step.

= File to Import - Browse to locate the Certificate

= (Certificate Store - Select the location to store the Certificate

3. Click Finish on the last step of the Wizard.

The Certificate is imported. Close the success message.

4. Click OK on the Internet Options dialog to apply the changes, then

close and reopen the browser.

Raritan.
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Chapter 2: Get Started Using KX Il

Example 2: Add the KX Ill to Trusted Sites and Import the Certificate

In this example, the KX IlI's URL is added as a Trusted Site, and the Self
Signed Certificate is added as part of the process.

e— —

InProvate Beowsing
Duagnose Connection Probler
Reopen Last Browsing Sessicn
InPrecate Fitering

InPrrvate Fitering Settings

Pop-up Blocker
SmartScreen Filter
Manage Add-ons

mpatibiiy View
Compatibity View Settings
Subscobe to ths Feed
Fred Discovery

Windows Update

Developer Tocks

Add tis webste 12 the Xone:
hitps/123.345.56 61 Add
Send to Bruetooth Device... T Mode )
OneNote Linked Notes

CuteShiftsDel  Jects fp) Customize Links (3, Source Images & deTrack 30 251

’1 Select 8 70re 1 veew O Change secirity settngs.

e et (BEEEEEE] Restcnd ‘
aor
Trusted stes
£ s sone contans webstes .
W ustret o damage your
your fies i I
Youhave webstes e 2one. Trusted stes ]
Seautty level for s 2one
£ You can a4 and remove webates from B 2one. All webstes
Custom o/ %8 200 wll iae e et secunty settngs.
Custom pecangs.

- T charge e satings, dick Custom level
+Touse e recommended settngs, ik Oefat level.

Custom v, . Oefoudtieves ‘ Webrtes:

Raset oh ores & defait et

Raritan.
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o Cancel .
-1 Requre server vericaton (htoe) for o stes s s v

Open an IE browser, then select Tools > Internet Options to open the
Internet Options dialog

Click the Security tab.

Click on Trusted Sites.

Disable Protected Mode, and accept any warnings.
Click Sites to open the Trusted Sites dialog.

Enter the KX Il URL, then click Add.

Deselect server verification for the zone (if applicable).
Click Close.

Click OK on the Internet Options dialog to apply the changes, then
close and reopen the browser.
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Chapter 2: Get Started Using KX I

Next, import the Certificate.

More Information

(1} The certificate used to dentfy the website is not trusted. The reasons
are isted below.
Proceed at your own risk.

. *
Do
Home > Ports

Time & Session
December 16, 2013 07.08:17 Port Access

Security Warning

i

i Do you want to Continue?

| The connection to this webste is untrusted.

/! 5 Website: hitos//192,168.61.20:443
Note: The cast

This appication wil be blodked in & futre Java security update
contan awrbute.

1R e manfest does rot
. More informaton

The certificate Authority that issued ths certificate is not trusted.

The apphcation i beng downloaded from & site other than the one
specfied by the secunity certficate.
-Downioading from *192.168.61.20"
~Expecting Raritan KvM*

Note to the Publisher: Secunity features to prevent
o f your Java el cause this

Y to be biocked i the future, See current Java
[ contre | [ concel ]Iﬂ about JAR Manifest entries for the changes that
f need to be made.
Tt [ s Domiion_KX3_Por Hote to users: For any questions, please contact the Publsher
who provided you with this applcation,
Connected Users:
admn (192.168.51.75)
Visit Java.com for more detads | Qg{ej»

.

1. Open an IE browser, then log in to KX III.

2. Click More Information on the first Java™ security warning.

3. Click View Certificate Details on the More Information dialog. You are

prompted to install the certificate. Follow the wizard steps.

For details see, Example 1: Import the Certificate into the
Browser (on page 13).

Raritan.
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Chapter 2: Get Started Using KX Il

Converting a Binary Certificate to a Baseb4-Encoded DER Certificate
(Optional)

KX Il requires an SSL certificate in either Baseé4-Encoded DER format
or PEM format.

If you are using an SSL certificate in binary format, you cannot install it.

However, you can convert your binary SSL certificate.

v3

Oce7eles 17d8 45 fe 8fe5 ...
shalRsA

shal

DigiCert Assured ID Root CA, ...
Thursday, November 09, 2006...
Sunday, November 09, 2031 7...
Diniert A A TN Rnnt C4

[ Edtpropertes... | [ copytoFie... |
Learn more about certificate detais

Lo ]

1. Locate the DEGHKVMO0OO1.cer binary file on your Windows machine.
Double-click on the DEGHKVMO0QO01.cer file to open its Certificate
dialog.

2. Click the Detail tab.

Raritan. 17
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Chapter 2: Get Started Using KX I

3. Click "Copy to File...".

Welcome to the Certificate Export
Wizard

This wizard helps you copy certificates, certificate trust
lists and certificate revocation lists from a certificate
store to your disk.

A certificate, which is issued by a certification authority, is
a confirmation of your identity and contains information
used to protect data or to establish secure network
connections, A certificate store is the system area where
certificates are kept.

To continue, dick Next.

Export File Format
Certificates can be exported in a variety of file formats.,

Select the format you want to use:
(©) DER encoded binary X.509 (.CER)

(0 Cryptographic Message Syntax Standard - PKCS #7 Certificates (.P78)
Indude all certificates in the certification path if possible

Personal Information Exchange - PKCS #12 (,PFX)
Indude all certificates in the certification path if possible
Delete the private key if the exportis successful
Export all extended propertes

Microsoft Serizlized Certificate Store (.SST)

Learn more about certificate file formats

5. Select "Base-64 encoded X.509" in the second Wizard dialog.
6. Click Next to save the file as a Base-64 encoded X.509.

You can now install the certificate on your KX III.

18 Raritan.
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Chapter 2: Get Started Using KX Il

Logging In to KX IlI

Raritan.
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Login to your KX Ill Remote Console from any workstation with network
connectivity. Java™ 1.7 is required to use the Java-based Virtual KVM
Client (VKC]. Java 1.8.0_40 is required to use the VKCS. Alternatively,
Microsoft .NET® 4.0 (or later] is required to use KX Ill with the Microsoft
Windows®-based Active KVM Client (AKC).

Logging in and using KX Il requires you to allow pop-ups.

For information on security warnings and validation messages, and steps
to reduce or eliminate them, see Security Warnings and Validation
Messages (on page 11).

If using a Dominion User Station, you must add the KX Il switches you
intend to access, including user credentials (login/password], on the
User Station for KX Il authentication.

> Tologin to the KX Il via Remote Console:

1. Launch a supported web browser, and enter the IP address assigned
to the KX III.

2. Adefault client is launched based on your pc and browser settings.
See KX Ill KYM Clients (on page 44). You can also choose a client by
entering the URL directly. See KX Ill KVM Client Launching (on
page 44).

3. Enter your username and password, then click Login.
Accept the user agreement [if applicable).

If security warnings appear, click to accept.

» To add the KX Ill switches and user credentials to the User
Station:

1. Power on and log in to the User Station.

2. Click Main Menu > User Station Configuration >

Add kKX Device

3. Enter and save the following information.
= KXIII's IP address or host name
= User credentials for logging in to the KX Il

Important: If you are not the user who added KX llI's to the User

Station, you MUST click the |£| button for the added KX IllI's to save
your user credentials for KX Ill authentication.
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Chapter 3

KX Ill Interface and Navigation

The KX IIl Remote Console and the KX Il Local Console are web-based
graphical user interfaces.

Use the Remote Console interface to configure and manage the KX |l
over a network connection.

Use the Local Console interface to access the KX Il while at the rack.

Access targets from either the Remote or Local console from one of the
supported KVM clients.

If you have the Dominion User Station, you can also use it to access
targets. See Dominion KX Il User Station (on page 143).

Alternatively, access targets from your mobile device. See Mobile KVM
Client [MKC]) Help (on page 147).

In This Chapter

OVEIVIBW o 20
KX Il Remote Console INTerface ... 21
KX 11l Local Console INterface ... e 31

Overview

Raritan.
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The KX Il Remote Console and the KX Il Local Console interfaces
provide a web-based interface for device configuration and
administration, as well as target server list and selection.
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Chapter 3: KX Il Interface and Navigation

KX Ill Remote Console Interface

Raritan.
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The KX Il Remote Console is a browser-based graphical user interface
that allows you to log in to KVM target servers and serial targets
connected to the KX Il and to remotely administer the KX II.

The KX IIl Remote Console provides a digital connection to your
connected KVM target servers. When you log into a KVM target server
using the KX Ill Remote Console, a Virtual KYM Client window opens.

There are many similarities among the KX Ill Local Console and the KX IlI
Remote Console graphical user interfaces, and where there are
differences, they are noted in the user manual. The following options are
available in the KX Il Remote Console but not the KX Il Local Console:

e Virtual Media

e Favorites

e Backup/Restore

e Firmware Upgrade

e SSL Certificates

e Audio
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Chapter 3: KX Il Interface and Navigation

Dominlon® X 111
Home > Ports

Time & Session:
December 05, Z013 142127

Lgar; sdmin

Slate 3 mn idle

wour F; 192168 32.158

Last Login: Dec 05, 2013 11:40:42

Device Information:

Device: Name: Dominion CX-sample:
P Addrese. 182 168.61.20
Firmware: 3.0.0:1.365

Device Wodal. DRx3-432
Hetwork LANT

Poweri: or

Powern2: off

Configurad Ag Sage

Port States:
358 Ports: up
54 Porte: cown
213 Pocts: die

Connected Users:

admn (Local Consale )
32 min idlz

admn (192 168.32 165)
3. min idie

Cnine Halp

Favarite Devies s

Port Access Page (Remote Console Display)

After a successful login, the Port Access page opens listing all ports
along with their status and availability.

Ports connected to KVM target servers (blades and standard servers) are
displayed in blue. Right-click on any of these ports to open the Port
Action menu. For more information, see Port Action Menu (on page 25).

If a KX Il port has no CIM connected or is connected to a CIM with no
name, a default port name of Dominion_Dominion-KX3_Port# is
assigned to the port. Dominion_KX3 is the device model and Port# is the
number of the KX Ill physical port.

Power | Virtual Media | User Management| Device Setfings | Security | Maintenance | Diagnostics | Help

Port Access

Click on the individual port name to see allowable operations.
0./ 4 Remote KM channeis currently in use.

Wiew By Group | View By Search | Set Scan

i Availability
1 HOMI Targ=t TAI-HDAMI up e
2 Dominion-K2_Port2 IA-DW1 ug ke
3 Low Cost DVH [PO20540016] Duak-v ug e
2 Windows HF 5F3 OCIw up o
5 P Diarminion-KXZ_Part13 TVIA-DP up e
! 5 Durini D o e
) Dominien-K22_Fort? Dush-vi ug o
8 ne-kxf-update Hat Avaiabk down e
g b KNEALAL 204 TersS TierDevic= up e
10 B EIZE0-241-lierd TierDevice up it
" ¥ KXE3Z-571-14-Tiar] TiarDavics ug L1
11-1 DCMS?mulatorPortl29 oci up e
-2 D MSimulatarPort128 i) up e
11-3 DCMSimulatorPortlz? DC up it
\ 11-4 DCMSimulatorPortd3d oci ug L1 )
. i
[ ] =] =] s-pase 15 Rows per Page| St |

Four tabs are provided on the page allowing you to view by port, view by
group, view by search and scan ports.

You can sort by Port Number, Port Name, Status (Up and Down), and
Availability (Idle, Connected, Busy, Unavailable, and Connecting) by
clicking on the column heading.

Use the Set Scan tab to scan for up to 32 targets that are connected to
the KX IIl. See Scanning Ports - Remote Console (on page 158)

Raritan.
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Chapter 3: KX Ill Interface and Navigation

Tiered Devices - Port Access Page

If you are using a tiered configuration in which a base KX Ill device is
used to access multiple other tiered devices, the tiered devices are
viewed on the Port Access page by clicking on the Expand Arrow icon ®
to the left of the tier device name.

Blade Chassis - Port Access Page

The blade chassis is displayed in an expandable, hierarchical list on the
Port Access page, with the blade chassis at the root of the hierarchy and
the individual blades labeled and displayed below the root. Use the
Expand Arrow icon ™ next to the root chassis to display the individual
blades.

Note: To view the blade chassis in a hierarchal order, blade-chassis
subtypes must be configured for the blade server chassis.

Dual Port Video Groups - Port Access Page

Dual video port groups appear on the Port Access page as Dual Port
types.

The primary and secondary ports that are a part of the port group appear
on the Port Access page as Dual Port(P) and Dual Port(S), respectively.
For example, if the CIM type is DCIM, "DCIM Dual Port (P)" is displayed.

When you access a dual port video group from the remote client, you
connect to the primary port, which opens a KVM connection window to
both the primary and secondary ports of the dual port group.

Note: The dual video primary port is defined when the port group is
created.

Note: You cannot remotely connect to the dual video port group by
clicking on a primary port unless two KVM channels are available. If two
channels are not available, the Connect link is not displayed.

Note: The Action menu is not displayed when you click on a secondary
portin a dual video port group.

Note: You cannot connect to the primary port and secondary port at the
same time from the Local Port.

Raritan. 23
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Chapter 3: KX Il Interface and Navigation

View by Group Tab

The View by Group tab displays blade chassis, 'standard’ port groups,

and dual video port groups. Click the Expand Arrow icon ™ nexttoa

group to view the ports assigned to the port group.
EENEIEITEEY

ame - Porm

Port Access

Ciick on the indrvidual port name t0 s
0/ 2 Remote KVM channels currently i

lowable operations.

View By Port [0 Bl View By Search | Set Sean

4 No. Status Mailabity

View by Search Tab

The View by Search tab allows you to search by port name. The search
feature supports the use of an asterisk (*] as a wildcard, and full and
partial names.

View by Serial Tab

The View By Serial tab is visible when a Dominion Serial Access Module
(DSAMY) is connected by USB. Up to 4 serial targets can be connected to
the DSAM by USB.

QPGRAGEERR] Pover | Vruaiedia | ser Managemen | Dovice Setings | Securty | Waitenance | D

Home = Ports

Port Access

Click on the individual port name to see allowable operations.
0/1 Remote KVM channels currently in use.

View By Port View By Group | View By Search m

USB Port Status Availability
4 L J DsAM4 Front DSAM up
4.1 DSAM4 Port 1 DCE up idle
4.2 DSANM4 Port 2 AUTO down idle
4.3 DSANM4 Port 3 AUTO down idle
4.4 DSANM4 Port 4 AUTO down idle

Rows per Page
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Set Scan Tab

The port scanning feature is accessed from the Set Scan tab on the Port
Access page. The feature allows you to define a set of targets to be
scanned. Thumbnail views of the scanned targets are also available.
Select a thumbnail to open that target in its Virtual KVM Client window.

See Scanning Ports - Remote Console (on page 158) for more
information.

Port Action Menu
When you click a Port Name in the Port Access list, the Port Action menu
appears.

Choose the desired menu option for that port to execute it. Note that only
currently available options, depending on the port’s status and
availability, are listed in the Port Action menu.

Home > Ports

Port Access

Click on the individual port name to see allowable operations.
0/ 4 Remote KVM channels currently in use.

View By Group | View By Search | Set Scan

!
{
(

LN

1 HOMI Target
z - - Port2
a—[ﬁypmumumm‘—
4 Windows XP SP3
Lo & ool T pg et > _
—
Connect

e Connect - Creates a new connection to the target server
For the KX Ill Remote Console, a new Virtual KVM Client page
appears.

For the KX Ill Local Console, the display switches to the target server,
and switches away from the local user interface.

On the local port, the KX IIl Local Console interface must be visible in
order to perform the switch.

Hot key switching is also available from the local port.
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Chapter 3: KX Il Interface and Navigation

Note: This option is not available from the KX Ill Remote Console for
an available port if all connections are busy.

Switch From
Switch From - Switches from an existing connection to the selected

port (KVM target server)
This menu item is available only for KVM targets, and only when a

Virtual KVM Client is opened.

Note: This menu item is not available on the KX IIl Local Console.

Home > Ports ]
Port Access ’
-+
Click on the individual Pﬂ.'"f name to see allowable aperatmns.
1./ 4 Remote K\VM channels CUFFE'Hﬂ}I’ in use. }
{

Wiew By Port | View By Group | View By Search | Set Scan

Switch From HDMI Target y
Connect |

}73 Low Cost DVM [PG20540016] - -
— ™o h AT ot

Disconnect
Disconnect - Disconnects this port and closes the Virtual KVM Client
page for this target server

This menu item is available only when the port status is up and
connected, or up and busy.

Raritan.
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Chapter 3: KX Ill Interface and Navigation

Note: This menu item is not available on the KX Il Local Console.
The only way to disconnect from the switched target in the Local
Console is to use the hot key.

Home > Ports

Port Access

1
o
Click on the individual port name to see allowable operat:‘ans.f
1/ 4 Remote K\VM channels currently in use. '

r

View By Group | View By Search | Set Scan

e
2 Dominion-KX2_Port? P,

PP TN T T UMPRROSAE] e petn ot

Power On

Power On - Powers on the target server through the associated
outlet

This option is visible only when there are one or more power
associations to the target, and when the user has permission to
operate this service.

Provided you have privileges to do so, you can manage power from
the Virtual KVM Client (VKC) and Active KVM Client (AKC) as well. See
Remote Power Management via Virtual KYM Client [VKC] or
Active KVM Client [AKC] (see "Power Control Using VKC, VKCS,
and AKC" on page 89)

Power Off

Power Off - Powers off the target server through the associated
outlets

This option is visible only when there are one or more power
associations to the target, when the target power is on (port status is
up), and when user has permission to operate this service.

Provided you have privileges to do so, you can manage power from
the Virtual KVM Client (VKC) and Active KVM Client (AKC) as well. See
Remote Power Management via Virtual KVM Client [VKC] or
Active KVM Client [AKC] (see “Power Control Using VKC, VKCS,
and AKC" on page 89)
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Power Cycle

e Power Cycle - Power cycles the target server through the associated
outlets
This option is visible only when there are one or more power
associations to the target, and when the user has permission to
operate this service.
Provided you have privileges to do so, you can manage power from
the Virtual KVM Client (VKC) and Active KVM Client (AKC) as well. See
Remote Power Management via Virtual KVYM Client [VKC] or
Active KVM Client [AKC] [see "Power Control Using VKC, VKCS,

and AKC" on page 89)

DKX3-808 Fast Switching

DKX3-808 maintains the video connections to the servers, enabling
faster connections to servers and faster switching between channels.

Some Video Settings do not apply to DKX3-808 targets:

e Automatic Color Calibration
e Video Sensing: Best possible video mode/Quick sense video mode

Raritan.
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Left Panel

The left panel of the KX lll interface contains the following information.

Note that some information is conditional - meaning it is displayed based
on your role, features being used and so on. Conditional information is

noted here.

Information

Time & Session

User

State

Your IP

Last Login

Under CC-SG
Management

Device Information

Device Name

|P Address

Firmware

Device Model

Serial number

Description

The date and time the
current session started

Username

The current state of the
application, either idle or
active. If idle, the
application tracks and
displays the time the
session has been idle.

The IP address used to
access the KX [lI

The last login date and
time

The IP address of the
CC-SG device managing
the KX Il

Information specific to
the KX Il you are using

Name assigned to the
device

The IP address of the KX
[

Current version of
firmware

Model of the KX IlI

Serial number of the KX
1l

When displayed?
Always

Always

Always

Always

Always

When the KX Il is
being managed by
CC-SG
Always
Always
Always

Always

Always

Always
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Information

Network

Powerlin1

Powerln2

Configured As Base
or Configured As
Tiered

Port States

Connect Users

Online Help

Favorite Devices

FIPS Mode

30

Description

The name assigned to the
current network

Status of the power 1
outlet connection. Either
on or off, or Auto-detect
off

Status of the power 2
outlet connection. Either
on or off, or Auto-detect
off

If you are using a tiering
configuration, this
indicates if the KX Il you
are accessing is the base
device or a tiered device.

The statuses of the ports
being used by the KX Il

The users, identified by
their username and IP
address, who are
currently connected to
the KX 11

Links to online help

See Managing Favorites
(on page 164)

FIPS Mode: EnabledSSL
Certificate: FIPS Mode
Compliant

When displayed?
Always

Always

Always

When the KX IIl is
part of a tiered
configuration

Always

Always

Always
When enabled

When FIPS is
enabled
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KX 11l Local Console Interface

There are many similarities among the KX Ill Local Console and the KX IlI

Remote Console graphical user interfaces. Where there are differences,
they are noted in the help.

For details on using the Local Console see KX Il Local Console (on page
168).
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Virtual Media

In This Chapter
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Overview
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ALL KX Il models support virtual media. Virtual media extends KVM
capabilities by enabling target servers to remotely access media from a
client PC and network file servers.

With this feature, media mounted on client PCs and network file servers
are essentially "mounted virtually” by the target server. The target
server can then read from and write to that media as if it were physically
connected to the target server itself.

Each KX Il comes equipped with virtual media to enable remote
management tasks using the widest variety of CD, DVD, USB, audio
playback and record devices, internal and remote drives, and images.

Virtual media sessions are secured using 128 or 256 bit AES
encryption.
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Prerequisites for Using Virtual Media
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KX 1l Virtual Media Prerequisites

e Forusersrequiring access to virtual media, the KX Il permissions
must be set to allow access to the relevant ports, as well as virtual
media access (VM Access port permission) for those ports. Port
permissions are set at the group-level.

e A USB connection must exist between the device and the target
server.

e |fyou want to use PC-Share, Security Settings must also be enabled
in the Security Settings page. Optional

e You must choose the correct USB profile for the KVM target server
you are connecting to.

Remote PC VM Prerequisites

e Certain virtual media options require administrative privileges on the
remote PC (for example, drive redirection of complete drives).

Note: If you are using Microsoft Vista or Windows 7, disable User
Account Control or select Run as Administrator when starting
Internet Explorer. To do this, click the Start Menu, locate IE,
right-click and select Run as Administrator.

Target Server VM Prerequisites
e KVM target servers must support USB connected drives.
e USB 2.0 ports are faster and preferred.

CIMs Required for Virtual Media

You must use one of the following CIMs is to use virtual media:
e D2CIM-VUSB

e D2CIM-DVUSB

e D2CIM-DVUSB-DVI

e D2CIM-DVUSB-HDMI

e D2CIM-DVUSB-DP

The black USB connector on the DVUSB CIMs are used for the keyboard
and mouse. The gray connector is used for virtual media.

Keep both USB plugs of the CIM connected to the device.

The device may not operate properly if both plugs are not connected to
the target server.
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Mounting Local Drives

This option mounts an entire drive, which means the entire disk drive is
mounted virtually onto the target server.

Use this option for hard drives and external drives only. It does not
include network drives, CD-ROM, or DVD-ROM drives.

Notes on Mounting Local Drives

KVM target servers running the Windows XP® operating system may not
accept new mass storage connections after an NTFS-formatted partition
(for example, the local C drive) has been redirected to them.

If this occurs, close the Remote Console and reconnect before
redirecting another virtual media device. If other users are connected to
the same target server, they must also close their connections to the
target server.

Supported Tasks Via Virtual Media

Virtual media provides the ability to perform tasks remotely, such as:
e Transferring files

e Running diagnostics

e Installing or patching applications

e Complete installation of the operating system

e Record and playback of digital audio

Important: Once you are connected to a virtual media drive, do not
change mouse modes in the KVM client if you are performing file
transfers, upgrades, installations or other similar actions. Doing so
may cause errors on the virtual media drive or cause the virtual
media drive to fail.
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Supported Virtual Media Types

The following virtual media types are supported for Windows®, Mac® and
Linux™ clients:

Internal and external hard drives

Internal and USB-mounted CD and DVD drives

USB mass storage devices

PC hard drives

ISO images (disk images)

1S09660 is the standard supported by Raritan. However, other ISO
standards can be used.

Digital audio devices*

Conditions when Read/Write is Not Available

Virtual media Read/Write is not available in the following situations:

For Linux® and Mace clients

When the drive is write-protected

When the user does not have Read/Write permission:
= Port Permission Access is set to None or View

= Port Permission VM Access is set to Read-Only or Deny

Supported Virtual Media Operating Systems

Raritan.
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The following client operating systems are supported:

Windows® 7 operating system
Windows 8 operating system
Windows XP® operating system
openSUSE® 11.4 Celadon (x86_64)
Fedora® 18

RHEL® 6.4

0SX Mountain Lion® 10.7 (and later]
Solaris® 10

The Active KVM Client (AKC] can be used to mount virtual media types
but only for Windows operating systems.
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Number of Supported Virtual Media Drives

With the virtual media feature, you can mount up to two drives (of
different types) that are supported by the USB profile currently applied to
the target. These drives are accessible for the duration of the KVM
session.

For example, you can mount a specific CD-ROM, use it, and then
disconnect it when you are done. The CD-ROM virtual media “channel”
will remain open, however, so that you can virtually mount another
CD-ROM. These virtual media “channels” remain open until the KVM
session is closed as long as the USB profile supports it.

To use virtual media, connect/attach the media to the client or network
file server that you want to access from the target server.

This need not be the first step, but it must be done prior to attempting to
access this media.

Connecting and Disconnecting from Virtual Media

Access a Virtual Media Drive on a Client Computer

Important: Once you are connected to a virtual media drive, do not
change mouse modes in the KVM client if you are performing file
transfers, upgrades, installations or other similar actions. Doing so
may cause errors on the virtual media drive or cause the virtual
media drive to fail.

P> To access a virtual media drive on the client computer:

1. From the KVM client, choose Virtual Media > Connect Drive, or click

the Connect Drive... button D The Map Virtual Media Drive dialog
appears.

Map Virtual Media Drive =3

Select a local drive to mount onto the target server.

Local Drive:

HINE : 7
'l L ({Hard Disk Partition) P

Read-Write

| ok || cancel ]J

2. Choose the drive from the Local Drive drop-down list.
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If you want Read and Write capabilities, select the Read-Write
checkbox.

This option is disabled for nonremovable drives. See the Conditions
when Read/Write is Not Available (on page 35) for more
information.

When checked, you will be able to read or write to the connected USB
disk.

WARNING: Enabling Read/Write access can be dangerous!
Simultaneous access to the same drive from more than one entity
can result in data corruption. If you do not require Write access,
leave this option unselected.

Click OK. The media will be mounted on the target server virtually.
You can access the media just like any other drive.

Mounting CD-ROM/DVD-ROM/ISO Images
This option mounts CD-ROM, DVD-ROM, and ISO images.

Note: IS09660 format is the standard supported by Raritan. However,
other CD-ROM extensions may also work.

>

1.

To access a CD-ROM, DVD-ROM, or ISO image:
From the KVM client, choose Virtual Media > Connect CD-ROM/ISO

Image, or click the Connect CD ROM/ISO button @ . The Map
Virtual Media CD/ISO Image dialog appears.

For internal and external CD-ROM or DVD-ROM drives:
a. Choose the Local CD/DVD Drive option.

b. Choose the drive from the Local CD/DVD Drive drop-down list.
All available internal and external CD and DVD drive names will
be populated in the drop-down list.

c. Click Connect.
For ISO images:

a. Choose the ISO Image option. Use this option when you want to
access a disk image of a CD, DVD, or hard drive. ISO format is
the only format supported.

b. Click Browse.

¢. Navigate to the path containing the disk image you want to use
and click Open. The path is populated in the Image Path field.

d. Click Connect.
For remote ISO images on a file server:

a. Choose the Remote Server ISO Image option.
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b. Choose Hostname and Image from the drop-down list. The file
servers and image paths available are those that you configured
using the File Server Setup page. Only items you configured
using the File Server Setup page will be in the drop-down list.

c. File Server Username - User name required for access to the
file server. The name can include the domain name such as
mydomain/username.

d. File Server Password - Password required for access to the file
server (field is masked as you type).

e. Click Connect.

The media will be mounted on the target server virtually. You can
access the media just like any other drive.

Note: If you are working with files on a Linux® target, use the Linux Sync
command after the files are copied using virtual media in order to view
the copied files. Files may not appear until a sync is performed.

Note: If you are using the Windows 7° operating system®, Removable
Disk is not displayed by default in the Window's My Computer folder
when you mount a Local CD/DVD Drive or Local or Remote ISO Image. To
view the Local CD/DVD Drive or Local or Remote ISO Image in this folder,
select Tools > Folder Options > View and deselect "Hide empty drives in
the Computer folder”.

Note: You cannot access a remote ISO image via virtual media using an
IPvé address due to third-party software technical limitations.

Disconnect from Virtual Media Drives

» To disconnect the virtual media drives:
e For local drives, choose Virtual Media > Disconnect Drive.

e For CD-ROM, DVD-ROM, and ISO images, choose Virtual Media >
Disconnect CD-ROM/ISO Image.

Note: In addition to disconnecting the virtual media using the Disconnect
command, simply closing the KVM connection closes the virtual media as
well.

Virtual Media in a Windows XP Environment

If you are running the Virtual KVM Client or Active KVM Clientin a
Windows® XP environment, users must have Administrator privileges to
access any virtual media type other than CD-ROM connections, ISOs and
ISO images.
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Virtual Media in a Linux Environment
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Active System Partitions
You cannot mount active system partitions from a Linux client.

Linux Ext3/4 drive partitions need to be unmounted via umount
/dev/<device label> prior to a making a virtual media connection.

Mapped Drives

Mapped drives from Linux clients are not locked when mounted onto
connected targets. This applies only to KX Ill 2.4.0 (and later).

Drive Partitions
The following drive partition limitations exist across operating systems:

e Windows® and Mac targets are not able to read Linux formatted
partitions

e Windows and Linux cannot read Mac formatted partitions

e Only Windows Fat partitions are supported by Linux

Root User Permission Requirement

Your virtual media connection can be closed if you mount a CD ROM from
a Linux client to a target and then unmount the CD ROM.

To avoid these issues, you must be a root user.
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Connect Drive Permissions (Linux)

Users must have the appropriate access permissions in order to connect
the Drive/CD-ROM to the target. This can be checked using:

guest userfadministrator-desktop:~$ 1ls -1 /dev/sr0
brw-rw----+ 1 root cdrom 11, 12-03-2010 11:52 /dev/sr0

In the above example, the permission must be changed to allow read
access.

On a system that supports ACLs in its file utilities, the ls command
changes its behavior in the following way:

e For files that have a default ACL or an access ACL that contains
more than the three required ACL entries, the [s(1) utility in the long
form produced by Ls -l displays a plus sign ( + ] after the permission
string.

This is indicated in the example provided here for /dev/sr0, use getfacl -a
/dev/sr0 to see if the user has been provided access as part of an ACL. In
this case they have and are therefore able to connect the cd-rom onto
the target even though the output of the ls -l command may indicate
otherwise.

guest userfadministrator-desktop:~$ getfacl -a /dev/sr0
getfacl: Removing leading '/' from absolute path names
# file: dev/sr0

# owner: root

# group: cdrom

user::rw-

user:guest user:rw-

group: :rw-

mask::rw—

other::---

A similar check of the permissions for a removable device shows:
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guest user@administrator-desktop:~$ 1ls -1 /dev/sdbl
brw-rw---- 1 root disk 8, 17 12-03-2010 12:02 /dev/sdbl

guest userfadministrator-desktop:~$ 1ls -1 /dev/sdbl
brw-rw---- 1 root disk 8, 17 12-03-2010 12:02 /dev/sdbl
&gt; getfacl -a /dev/sdbl

getfacl: Removing leading '/' from absolute path names
# file: dev/sdbl

# owner: root

# group: disk

user: :rw-

group: :rw-

other::---

This requires that the user is provided read-only permissions for the
removable device:

root@administrator-desktop:~# chmod 664 /dev/sdbl
root@administrator-desktop:~# 1ls -1 /dev/sdbl
brw-rw-r-- 1 root disk 8, 17 12-03-2010 12:02 /dev/sdbl

The drive is then available to connect to the target.

Virtual Media in a Mac Environment

Active System Partition

You cannot use virtual media to mount active system partitions for a Mac
client.

Drive Partitions

The following drive partition limitations exist across operating systems:

e Windows® and Mac targets are not able to read Linux formatted
partitions

e Windows cannot read Mac formatted partitions

e Windows FAT and NTFS are supported by Mac

e Mac users must unmount any devices that are already mounted in
order to connect to a target server. Use >diskutil umount
/dev/disk1s1 to unmount the device and diskutil mount /dev/disk1s1
to remount it.
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Connect Drive Permissions (Mac)

In order for a device to be available to connect to a target from a Mac®
client, you must have read-only permissions to the removable device:

root@administrator-desktop:~# chmod 664 /dev/sdbl
root@administrator-desktop:~# 1ls -1 /dev/sdbl
brw-rw-r-- 1 root disk 8, 17 12-03-2010 12:02 /dev/sdbl

Virtual Media File Server Setup (File Server ISO Images Only)

This feature is only required when using virtual media to access file
server |SO images. 1IS09660 format is the standard supported by Raritan.
However, other CD-ROM extensions may also work.

Note: SMB/CIFS support is required on the file server.

Use the Remote Console File Server Setup page to designate the files
server(s) and image paths that you want to access using virtual media.
File server ISO images specified here are available for selection in the
Remote Server ISO Image Hostname and Image drop-down lists in the
Map Virtual Media CD/ISO Image dialog. See Mounting
CD-ROM/DVD-ROMY/ISO Images (on page 37).

P> To designate file server ISO images for virtual media access:
1. Choose Virtual Media from the Remote Console. The File Server
Setup page opens.

2. Check the Selected checkbox for all media that you want accessible
as virtual media.

3. Enter information about the file server ISO images that you want to
access:

= |P Address/Host Name - Host name or IP address of the file
server.

= Image Path - Full path name of the location of the ISO image. For
example, /sharename0/path0/image0.iso,
\sharename1\path1\image1.iso, and so on.

Note: The host name cannot exceed 232 characters in length.

4. Click Save. All media specified here are now available for selection in
the Map Virtual Media CD/ISO Image dialog.
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Note: If you are connecting to a Windows 2003° server and attempt to
load an ISO image from the server, you may receive an error stating
“Virtual Media mounting on port failed. Unable to connect to the file
server or incorrect File Server username and password".

If this occurs, disable "Microsoft Network Server: Digitally Sign
Communications” option on the server under the Domain Controllers
policies.
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Active KVM Client AKC  Windows Platforms Full-featured KVM Client
Requires Microsoft NET  Java-Free

Virtual KVM Client VKC Linux & Mac Full-featured KVM Client
Requires Java Requires Java

HTML KVM Client HKC Linux & Mac Basic KVM Access Only
Windows w/o .NET Java-Free

HTML & Javascript

e AKC is best for Windows Platforms
e VKC is best for Linux and Mac users with Java
e HKC is best for Linux & Mac users without Java

Note: HKC currently provides basic KVM-over-IP access

In This Chapter

KX I KVM Client LaunChing ....cooeiiiiiiiiiic s A
Virtual KVM Client (VKC and VKCS) Help ...cceeiiiiirieccececeeeee 45
Active KVM Client [AKC) Help ..o 90
HTML KVM Client (HKC) Help ...ooeiieireieeciceee e 94

KX Il KVM Client Launching

KVM Client Underlying Automatically URL to Force Launch
Technology Launched For

Active KVM  AKC Microsoft .NET Windows & .NET  <KX3 IP Address>/akc

Client Framework Framework

Virtual KVM  VKC Oracle Java Non-Windows <KX3 IP Address>/vkc
Client with Java

HTML KVM HKC Browser HTML Non-Windows <KX3 IP Address>/hkc
Client & Javascript without Java
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Virtual KVM Client (VKC and VKCs) Help

Time & Seaxiorc
Decensber 13, 31321178

User: aciren
Qate acive
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Lasi Lage Dec 12 3212 163013

Derwicon Wdormation
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Overview

VKC is the default client for Non-Windows platform clients with Java.

Whenever you access a target server from the Port Access page of KX Il
the Remote Console, a Virtual KVM Client (VKC) window opens.

BREEELERANTO R @

"

T

"l\ A g

There is one Virtual KVM Client for each target server connected.

Virtual KVM Client windows can be minimized, maximized, and moved
around your computer desktop.

IMPORTANT: Refreshing your browser closes the Virtual KVM Client
connection.

Recommended Minimum Virtual KVM Client (VKC) Requirements

Raritan recommends the Virtual KVM Client (VKC) machines meet the
following minimum requirements for use with KX III.

e Client machine with either a -
= 'modern’ dual-core CPU for a single connections, or

= 'modern’ quad core CPU for two or more simultaneous
connections

e 4GB of RAM
= VKC requires 50MB of RAM per connection
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Virtual KVM Client Java Requirements

Java™ 1.7 is required to use the Java-based Virtual KVM Client (VKC).
Java 1.8.0_40 is required to use the VKCS.

Java 7 is not supported, and a Java error displays if you attempt to
launch VKCS with JRE 1.7.

If Java is not installed, a prompt is displayed that the file cannot be
opened, with an option to search for the program.

Note: VKC cannot be launched from Edge, Chrome 45 or later, Firefox 42
or later. VKCS is recommended for these browsers.

P> VKCS Launching:

For all browsers, the VKCS standalone application needs to be
downloaded everytime you use it.

e Chrome: The downloaded VKCS jnlp file must always be clicked at
bottom left corner of browser window to launch.

G NewTab x New Tab
C' | [7192.168.1.203/vkc

% Apps  For quick access, place your bookmarks here on the bookmarks bar. Import bookmarks now.

Google

(=

%) VkeStandAloneAppli &wn ¥
'y
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e Edge: You must click Open at the bottom of the browser to launch.

X

B start X =

o
(D) 192.168.1.203 g =4 O -

VkeStandAloneApplication (25).jnlp finished downloading. ‘EI View downloads X

e Internet Explorer: Launches automatically.

e Firefox: Use the option "Do this automatically for files like this from
now on”, when the vkcs.jnlp file downloads, and it will launch
automatically in future

Proxy Server Configuration for Use with VKC, VKCS, and AKC

When the use of a Proxy Server is required, a SOCKS proxy must also be
provided and configured on the remote client PC.

Note: If the installed proxy server is only capable of the HTTP proxy
protocol, you cannot connect.

P> To configure the SOCKS proxy:
1. Onthe remote client PC, select Control Panel > Internet Options.

a. Onthe Connections tab, click 'LAN settings’. The Local Area
Network (LAN] Settings dialog opens.

b. Select 'Use a proxy server for your LAN".
Click Advanced. The Proxy Settings dialog opens.
Configure the proxy servers for all protocols.

IMPORTANT: Do not select 'Use the same proxy server for all
protocols’.
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Note: The default port for a SOCKS proxy [1080] is different from
HTTP proxy (3128].

e. Click OK at each dialog to apply the settings.
2. Next, configure the proxy settings for the Java™ applets:
a. Select Control Panel > Java.

b. On the General tab, click Network Settings. The Network
Settings dialog opens.

Select "Use Proxy Server”.
Click Advanced. The Advanced Network Settings dialog opens.
e. Configure the proxy servers for all protocols.

IMPORTANT: Do not select 'Use the same proxy server for all
protocols’.

Note: The default port for a SOCKS proxy (1080] is different from
HTTP proxy (3128].

Connect to a Target from Virtual KVM Client (VKC], Standalone VKC
(VKCs), or Active KVM Client (AKC)

Once you have logged on to the KX IIl Remote Console, access target
servers via the Virtual KVM Client (VKC), Standalone VKC (VKCs), or
Active KVM Client (AKC).

» To connect to an available server:

1. Onthe Port Access page, click on the port name of the target server
you want to connect to. The Port Action menu opens.

2. Click Connect.

Home > Ports

Port Access

Click on the individual
0/ 4 Remote K\VM char

View By Grd
Name

= e
See Port Action Menu (on page 25) for details on additional available
menu options.
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Configuring Connection Properties

Connection properties manage streaming video performance over
remote connections to target servers.

The properties are applied only to your connection - they do not impact
the connection of other users accessing the same target servers.

If you make changes to connection properties, they are retained by the
client.

Access Connection Properties

> To access connection properties:

@ Click Connection > Properties, or click the Connection... icon to open the
Connection Properties dialog.

Connection USB Profile Keyboard Video Mouse Tools View Virtual Media Audio SmartCard Help

SNIERERAI0OR@E

Video Mode: Full Color 2

Noise Filter: 2

U

[ox ) (concel ]

Default Connection Property Settings - Optimized for Best Performance

The KX Il comes configured to provide optimal performance for the
majority of video streaming conditions.

Default connection settings are:

e Optimized for: Text Readability - video modes are designed to
maximize text readability.

This setting is ideal for general IT and computer applications, such
as performing server administration.
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e Video Mode - defaults to Full Color 2.

Video frames transmit in high-quality, 24-bit color. This setting is
suitable where a high-speed LAN is used.

e Noise Filter - defaults to 2.
The noise filter setting does not often need to be changed.

Click Reset on the Connection Properties dialog at any time to return to
the default settings.

Tip: Use the Connection Information dialog to monitor the connection in
real-time. See Access and Copy Connection Information (on page 53)

. * - )\

Description

Dominionk2 Device Name

192.168.61.15 IF Address

443 Port

187 KB/s Data In/Second
Data Qut/Second
FPS
Connect Time
Horizontal Resolution
Vertical Resolution
Refresh Rate
Protocol Version

: Copy to Clipboard | [

Optimize for: Selections

Text Readability

Text Readability is designed to provide video modes with lower color
depth but text remains readable. Greyscale modes are even available
when applying lower bandwidth settings.

This setting is ideal when working with computer GUIs, such as server
administration.

When working in full color video modes, a slight contrast boost is
provided, and text is sharper.

In lower quality video modes, bandwidth is decreased at the expense of
accuracy.
Color Accuracy

When Color Accuracy is selected, all video modes are rendered in full
24-bit color with more compression artifacts.

This setting applies to viewing video streams such as movies or other
broadcast streams.

In lower quality video modes, sharpness of fine detail, such as text, is
sacrificed.
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Video Mode

The Video Mode slider controls each video frame's encoding, affecting
video quality, frame rate and bandwidth.

Optimize for: :Text Readability v:

Video Mode: Full Color 2

U

Best Least
Quality Moise Filter: 2 Bandwidth

U 1

‘l
[OK H Cancel H Apply ]!

In general, moving the slider to the left results in higher quality at the
cost of higher bandwidth and, in some cases, lower frame rate.

Moving the slider to the right enables stronger compression, reducing
the bandwidth per frame, but video quality is reduced.

In situations where system bandwidth is a limiting factor, moving the
video mode slider to the right can result in higher frame rates.

When Text Readability is selected as the Optimized setting, the four
rightmost modes provide reduced color resolution or no color at all.

These modes are appropriate for administration work where text and
GUIl elements take priority, and bandwidth is at a premium.

Click Reset on the Connection Properties dialog at any time to return to
the default settings.
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Noise Filter

Unless there is a specific need to do so, do not change the noise filter
setting. The default setting is designed to work well in most situations.

The Noise Filter controls how much interframe noise is absorbed by the
KX .

Optimize for: Text Readability |

Video Mode: Full Calor 2

U

Best Least
Quality Moise Filter: 2 Bandwidth

U t

|
o) (o ) Lo |

Moving the Noise Filter slider to the left lowers the filter threshold,
resulting in higher dynamic video quality. However, more noise is likely
to come through, resulting in higher bandwidth and lower frame rates.

Moving the slider to the right raises the threshold, allows less noise and
less bandwidth is used. Video artifacts may be increased.

Moving the noise filter to the right may be useful when accessing a
computer GUI over severely bandwidth-limited connections.

Click Reset on the Connection Properties dialog at any time to return to
the default settings.
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Connection Information

Open the Connection Information dialog for real-time connection
information on your current connection, and copy the information from
the dialog as needed.

See Configuring Connection Properties (on page 49)

>

Current connection information:

Name of the KX Il

IP address of the KX Il

Port - The KVM communication TCP/IP port used to access KX II1.
Data In/Second - Data rate received from the KX IlI

Data Out/Second - Data rate sent to the KX II1.

Connect Time - The duration of the current connection.

FPS - Video frames per second transmitted received from the KX I11.
Horizontal Resolution - The target server horizontal resolution.
Vertical Resolution - The target server vertical resolution.
Refresh Rate - Refresh rate of the target server.

Protocol Version - Raritan communications protocol version.

Access and Copy Connection Information

Connection USB Profile Keyboard Video Mouse Tools View Virtual Media Audio SmartCard Help

Connection Info

§

Description Data

Device Name KX3-61-20
192.168.61.20
443
0B/s
0B/s

1
2
3
4
3
6
7

0
00:10:22
1024

- e D @
- o
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Steps
o Click Connection > Info... to open the Connection Info dialog.

e Click Copy to Clipboard. Paste the information as needed.

USB Profiles
Select a USB profile that best applies to the KVM target server.

For example, if the server is running Windows® operating system, it
would be best to use the Generic profile.

Or, to change settings in the BIOS menu or boot from a virtual media
drive, depending on the target server model, a BIOS profile may be more
appropriate.

> To set a USB profile for a target server:

e Choose USB Profile, then choose Generic, or choose Other Profiles
to select from a menu.

Connection [USBPloﬁle Keyboard Video Mouse Tools View Virtual Media Audic SmartCard Help

% h E ©  Generic

Other Profiles

Help on USB Profiles

¢

Mac O5-X (10.4.9 and later)

|4

Pr—— %

ELDINVIES

o7

HP Proliant DL380/DL380 G4 (Windows 2003 Server Installation) =
BIOSIEM Thinkcentre Lenovo

RUBY Industrial Mainboard (AwardBIOS)

HP Proliant DL360/DL380 G4 (HP SmartStart CD)

BIOS Dell Powerkdge Keyboard and Mouse Only

Supermicro Mainboard (Phoenix AwardBIOS)

SuSE Linux 9.2

e Y =

b

T —r

P> To view details on USB profiles:
e Choose USB Profile > Help on USB Profiles.
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Keyboard

Send Ctrl+Alt+Del Macro

Due to its frequent use, a Ctrl+Alt+Delete macro is preprogrammed.

Selecting Keyboard > Send Ctrl+Alt+Del, or clicking on the

Ctrl+Alt+Delete button EE in the toolbar sends this key sequence to
the server or to the KVM switch to which you are currently connected.

In contrast, if you were to physically press the Ctrl+Alt+Del keys, the
command would first be intercepted by your own PC due to the structure
of the Windows operating system, instead of sending the key sequence to
the target server as intended.

Send LeftAlt+Tab (Switch Between Open Windows on a Target Server)

Select Keyboard > Send LeftAlt + Tab to switch between open windows
on the target server or KVM switch you are connected to.

Setting CIM Keyboard/Mouse Options

> To access the DCIM-USBG2 setup menu:

1. Put the mouse focus on a window such as Note Pad (Windows®
operating system) or an equivalent.

2. Select Set CIM Keyboard/Mouse options. This is the equivalent of
sending the Left-Control and Num Lock to the target. The CIM setup
menu options are then displayed.

3. Set the language and mouse settings.
Exit the menu to return to normal CIM functionality.

Send Text to Target

P> To use the Send Text to Target function for the macro:

1. Click the Keyboard > Send Text to Target. The Send Text to Target
dialog appears.

2. Enter the text you want sent to the target.

Note: Non-English characters are not supported by the Send Text to
Target function.

3. Ifthe target uses a US/International keyboard layout, select the
"Target system is set to the US/International keyboard layout”
checkbox.

4. Click OK.
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Keyboard Macros

Keyboard macros ensure that keystroke combinations intended for the
target server are sent to and interpreted only by the target server.
Otherwise, they might be interpreted by your client PC.

Macros are stored on the client PC and are PC-specific. If you use
another PC, you cannot see your macros.

In addition, if another person uses your PC and logs in under a different
name, that user will see your macros since they are computer-wide.

Keyboard macros created in Virtual KVM Client (VKC) cannot be used in
Active KVM Client (AKC]) or vice versa.

Build a New Macro

>

1.

To build a macro:

Click Keyboard > Keyboard Macros. The Keyboard Macros dialog
appears.

Click Add. The Add Keyboard Macro dialog appears.

Type a name for the macro in the Keyboard Macro Name field. This
name appears in the Keyboard menu after it is created.

From the Hot-Key Combination field, select a keyboard combination
from the drop-down list. This allows you to execute the macro with a
predefined keystroke. Optional

In the Keys to Press drop-down list, select each key you would like to
use to emulate the keystrokes that is used to perform the command.
Select the keys in the order by which they are to be pressed. After
each selection, select Add Key. As each key is selected, it appears in
the Macro Sequence field and a Release Key command is
automatically added after each selection.

For example, create a macro to close a window by selecting Left Ctrl
+ Esc. This appears in the Macro Sequence box as follows:

Press Left Alt
Press F4

Esc

Release F4

Esc

Release Left Alt

Review the Macro Sequence field to be sure the macro sequence is
defined correctly.

a. Toremove a step in the sequence, select it and click Remove.
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b. To change the order of steps in the sequence, click the step and
then click the up or down arrow buttons to reorder them as
needed.

7. Click OK to save the macro. Click Clear to clear all field and start
over. When you click OK, the Keyboard Macros dialog appears and
lists the new keyboard macro.

8. Click Close to close the Keyboard Macros dialog. The macro now
appears on the Keyboard menu in the application.

9. Select the new macro on the menu to run it or use the keystrokes
you assigned to the macro.

Import Macros

> To import macros:

1. Choose Keyboard > Import Keyboard Macros to open the Import
Macros dialog. Browse to the folder location of the macro file.

2. Click on the macro file and click Open to import the macro.

a. Iftoo many macros are found in the file, an error message is
displayed and the import terminates once OK is selected.

b. If the import fails, an error dialog appears and a message
regarding why the import failed is displayed. Select OK to
continue the import without importing the macros that cannot be
imported.

3. Select the macros to be imported by checking their corresponding
checkbox or using the Select All or Deselect All options.

4. Click OK to begin the import.

a. If aduplicate macro is found, the Import Macros dialog appears.
Do one of the following:
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= Click Yes to replace the existing macro with the imported
version.

= Click Yes to All to replace the currently selected and any
other duplicate macros that are found.

= Click No to keep the original macro and proceed to the next
macro

= Click No to All keep the original macro and proceed to the
next macro. Any other duplicates that are found are skipped
as well.

= Click Cancel to stop the import.

= Alternatively, click Rename to rename the macro and import
it. If Rename is selected, the Rename Macro dialog appears.
Enter a new name for the macro in the field and click OK.
The dialog closes and the process proceeds. If the name that
is entered is a duplicate of a macro, an alert appears and you
are required to enter another name for the macro.

b. If during the import process the number of allowed, imported
macros is exceeded, a dialog appears. Click OK to attempt to
continue importing macros or click Cancel to stop the import
process.

The macros are then imported. If a macro is imported that contains a hot
key that already exists, the hot key for the imported macro is discarded.

Export Macros

1. Choose Tools > Export Macros to open the Select Keyboard Macros
to Export dialog.

Export Keyboard Maci

Close Window Selact All
Deselect Al

2. Select the macros to be exported by checking their corresponding
checkbox or using the Select All or Deselect All options.

3. Click Ok. An "Export Keyboard Macros to" dialog is displayed. Locate
and select the macro file. By default, the macro exists on your
desktop.
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4. Select the folder to save the macro file to, enter a name for the file
and click Save. If the macro already exists, you receive an alert
message.

5. Select Yes to overwrite the existing macro or No to close the alert
without overwriting the macro.

Video Properties

Refreshing the Screen

The Refresh Screen command forces a refresh of the video screen. Video
settings can be refreshed automatically in several ways:

e The Refresh Screen command forces a refresh of the video screen.

e The Auto-sense Video Settings command automatically detects the
target server's video settings.

e The Calibrate Color command calibrates the video to enhance the
colors being displayed.

In addition, you can manually adjust the settings using the Video Settings
command.

P> To refresh the video settings, do one of the following:
e Choose Video > Refresh Screen, or click the Refresh Screen button

@ in the toolbar.

Auto-Sense Video Settings

The Auto-sense Video Settings command forces a re-sensing of the video
settings [resolution, refresh rate) and redraws the video screen.

P> To automatically detect the video settings:
e Choose Video > Auto-sense Video Settings, or click the Auto-Sense

[ £
Video Settings button in the toolbar.

A message stating that the auto adjustment is in progress appears.
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Calibrating Color

Use the Calibrate Color command to optimize the color levels (hue,
brightness, saturation) of the transmitted video images.

The color settings are on a target server-basis.

Note: When color is successfully calibrated, the values are cached and
reused each time you switch to the target. Changes to the brightness and
contrast in Video Settings are not cached. Changing resolution resets the
video to the cached values again. You can clear the cached values in
Video > Clear Video Settings Cache. See Clear Video Settings Cache (on
page 60.

» To calibrate the color:
e Choose Video > Calibrate Color, or click the Calibrate Color button

@ in the toolbar.

The target device screen updates its color calibration.

Clear Video Settings Cache

You can clear the video settings cache to delete old settings that do not
apply anymore, such as when a target server is replaced. When you clear
the video settings cache, the server automatically does a video
auto-sense and color calibration. The new values are cached and reused
when the target is accessed again.

P> To clear the video settings cache:
e Choose Video > Clear Video Settings Cache in the toolbar.

Adjusting Video Settings

Use the Video Settings command to manually adjust the video settings.

P> To change the video settings:
1. Choose Video > Video Settings to open the Video Settings dialog.

2. Adjust the following settings as required. As you adjust the settings

the effects are immediately visible:

a. PLL Settings
Clock - Controls how quickly video pixels are displayed across
the video screen. Changes made to clock settings cause the video
image to stretch or shrink horizontally. 0Odd number settings are
recommended. Under most circumstances, this setting should
not be changed because the autodetect is usually quite accurate.
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Phase - Phase values range from 0 to 31 and will wrap around.
Stop at the phase value that produces the best video image for
the active target server.

b. Brightness: Use this setting to adjust the brightness of the target
server display.

c. Brightness Red - Controls the brightness of the target server
display for the red signal.

d. Brightness Green - Controls the brightness of the green signal.

e. Brightness Blue - Controls the brightness of the blue signal.
f. Contrast Red - Controls the red signal contrast.

g. Contrast Green - Controls the green signal.

h. Contrast Blue - Controls the blue signal.

If the video image looks extremely blurry or unfocused, the
settings for clock and phase can be adjusted until a better image
appears on the active target server.

Warning: Exercise caution when changing the Clock and Phase
settings. Doing so may result in lost or distorted video and you may
not be able to return to the previous state. Contact Raritan Technical
Support before making any changes.

i. Horizontal Offset - Controls the horizontal positioning of the
target server display on your monitor.

j. Vertical Offset - Controls the vertical positioning of the target
server display on your monitor.

3. Select Automatic Color Calibration to enable this feature. This
setting does not apply to KX3-808 target servers.

4. Select the video sensing mode. This setting does not apply to
KX3-808 target servers when connecting to the target, but will apply
if you change resolution.

= Best possible video mode

The device will perform the full Auto Sense process when
switching targets or target resolutions. Selecting this option
calibrates the video for the best image quality.

= Quick sense video mode

With this option, the device will use a quick video Auto Sense in
order to show the target's video sooner. This option is especially
useful for entering a target server's BIOS configuration right
after a reboot.

5. Click OK to apply the settings and close the dialog. Click Apply to
apply the settings without closing the dialog.
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Note: Some Sun background screens, such as screens with very dark
borders, may not center precisely on certain Sun servers. Use a different
background or place a lighter colored icon in the upper left corner of the

Contrast Blue: 80

Horizontal Offset: 265

screen.
Video Settings

PLL Settings
Clock: 1,312 1026 { {1812
Phase: 1] o 31

Color Settings
Brightness Red: o o [} 127
Brightness Green: 0 o I} 127
Brightness Blue: = o {} 127
Contrast Red: CEIE i 127
Contrast Green: 87> 0 I} 127

Vertical Offset: 3

Automatic Color Calibration

Video Sensing

(@) Best possible video mode

() Quick sense video mode

Screenshot from Target Command (Target Screenshot)

Take a screenshot of a target server using the Screenshot from Target
server command. If needed, save this screenshot to a file location of your

choosing as a bitmap, JPEG or PNG file.

P> To take a screenshot of the target server:

1. Select Video > Screenshot from Target, or click the Target

Screenshot button ﬂ on the toolbar.

2. Inthe Save dialog, choose the location to save the file, name the file,

and select a file format from the 'Files of type' drop-down.

3. Click Save to save the screenshot.

Raritan.

A brand of Hllegrand’



Raritan.

A brand of Lllegrand

Chapter 5: KX Il KVM Clients

Mouse Options
You can operate in either single mouse mode or dual mouse mode.

When in a dual mouse mode, and provided the option is properly
configured, the mouse cursors align.

When controlling a target server, the Remote Console displays two
mouse cursors - one belonging to your KX Ill client workstation, and the
other belonging to the target server.

When there are two mouse cursors, the device offers several mouse
modes:

e Absolute (Mouse Synchronization)

e Intelligent (Mouse Mode)

e Standard (Mouse Mode]

When the mouse pointer lies within the KVM Client target server window,

mouse movements and clicks are directly transmitted to the connected
target server.

While in motion, the client mouse pointer slightly leads the target mouse
pointer due to mouse acceleration settings.

On fast LAN connections, you can use single mouse mode, and view only
the target server's pointer.

You can toggle between these two modes (single mouse and dual
mouse).
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Dual Mouse Modes
Absolute Mouse Synchronization

In this mode, absolute coordinates are used to keep the client and target
cursors in synch, even when the target mouse is set to a different
acceleration or speed.

This mode is supported on servers with USB ports and is the default
mode for virtual media CIMs.

Absolute Mouse Synchronization requires the use of a virtual media CIM
e D2CIM-VUSB

e D2CIM-DVUSB

e D2CIM-DVUSB-DVI

e D2CIM-DVUSB-HDMI

e D2CIM-DVUSB-DP

P> To enter Absolute Mouse Synchronization:
e Choose Mouse > Absolute from the KVM client.

The black USB connector on the DVUSB CIMs are used for the keyboard
and mouse. The gray connector is used for virtual media.

Keep both USB plugs of the CIM connected to the device.

The device may not operate properly if both plugs are not connected to
the target server.

Intelligent Mouse Mode

In Intelligent Mouse mode, the device can detect the target mouse
settings and synchronize the mouse cursors accordingly, allowing
mouse acceleration on the target. Intelligent mouse mode is the default
for non-VM targets.

Enter Intelligent Mouse Mode

P> To enter intelligent mouse mode:
e Choose Mouse > Intelligent.
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Intelligent Mouse Synchronization Conditions

The Intelligent Mouse Synchronization command, available on the Mouse
menu, automatically synchronizes mouse cursors during moments of
inactivity. For this to work properly, however, the following conditions
must be met:

e The active desktop should be disabled on the target.
e No windows should appear in the top left corner of the target page.

e There should not be an animated background in the top left corner of
the target page.

e The target mouse cursor shape should be normal and not animated.

e The target mouse speeds should not be set to very slow or very high
values.

e Advanced mouse properties such as “Enhanced pointer precision” or
“Snap mouse to default button in dialogs” should be disabled.

e Choose "Best Possible Video Mode” in the Video Settings window.

e The edges of the target video should be clearly visible (that is, a
black border should be visible between the target desktop and the
remote KVM console window when you scroll to an edge of the target
video image).

e When using the intelligent mouse synchronization function, having a
file icon or folder icon located in the upper left corner of your
desktop may cause the function not to work properly. To be sure to
avoid any problems with this function, Raritan recommends you do
not have file icons or folder icons in the upper left corner of your
desktop.

After autosensing the target video, manually initiate mouse
synchronization by clicking the Synchronize Mouse button on the toolbar.
This also applies when the resolution of the target changes if the mouse
cursors start to desync from each other.

If intelligent mouse synchronization fails, this mode will revert to
standard mouse synchronization behavior.

Please note that mouse configurations will vary on different target
operating systems. Consult your OS guidelines for further details. Also
note that intelligent mouse synchronization does not work with UNIX
targets.
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Standard Mouse Mode

Standard Mouse mode uses a standard mouse synchronization algorithm.
The algorithm determines relative mouse positions on the client and
target server.

In order for the client and target mouse cursors to stay in synch, mouse
acceleration must be disabled. Additionally, specific mouse parameters
must be set correctly.

» To enter Standard Mouse mode:
e Choose Mouse > Standard.

Mouse Synchronization Tips
If you have an issue with mouse synchronization:

1. Verify that the selected video resolution and refresh rate are among
those supported by the device. The KVM Client Connection Info dialog
displays the actual values that the device is seeing.

Force an auto-sense by clicking the KVM Client auto-sense button.

3. If that does not improve the mouse synchronization (for Linux, UNIX,
and Solaris KVM target servers):

a. Open aterminal window.
b. Enter the following command: xset mouse 1 1

c. Close the terminal window.

4. Click the "KVM Client mouse synchronization™ button ”}

Synchronize Your Mouse

In dual mouse mode, the Synchronize Mouse command forces
realignment of the target server mouse cursor with the client mouse
cursor.

P> To synchronize the mouse cursors, do one of the following:

e Click the Synchronize Mouse button '} in the KVM client toolbar,
or select Mouse > Synchronize Mouse from the menu bar.

Note: This option is available only in Standard and Intelligent mouse
modes.
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Single Mouse Mode

Single Mouse mode uses only the target server mouse cursor; the client
mouse cursor no longer appears onscreen.

Note: Single mouse mode does not work on Windows or Linux targets
when the client is running on a Virtual Machine.

P> To enter single mouse mode, do one the following:
e Choose Mouse > Single Mouse Cursor.

e Click the Single/Double Mouse Cursor button h in the toolbar.

Single Cursor

& You are about to enter Single Cursor mode, While you are in this mode,

W this software will have exclusive control over the mouse and keyboard.

To exit single cursor mode, you must press Cerl+ LeftAlt+ O
[7] Scale the video {no scroll bars)

[ ok || Cancel

P> To exit single mouse mode:

1. Press Ctrl+Alt+0 on your keyboard to exit single mouse mode.

Tool Options
General Settings

P> To set the tools options:
1. Click Tools > Options. The Options dialog appears.

2. Select the Enable Logging checkbox only if directed to by Technical
Support.

This option creates a log file in your home directory.
3. Choose the Keyboard Type from the drop-down list (if necessary).
The options include:
» US/International
= French (France)
=  German (Germany)
= Japanese

= United Kingdom
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Korean (Korea)
French (Belgium)
Norwegian (Norway)
Portuguese (Portugal]
Danish (Denmark]
Swedish (Sweden])
German (Switzerland)
Hungarian (Hungary)
Spanish (Spain)
Italian (Italy)
Slovenian
Translation: French - US

Translation: French - US International

In AKC, the keyboard type defaults to the local client, so this option
does not apply.

Configure hotkeys:

Exit Full Screen Mode - Hotkey.

When you enter Full Screen mode, the display of the target
server becomes full screen and acquires the same resolution as
the target server.

This is the hot key used for exiting this mode.
Exit Single Cursor Mode - Hotkey.

When you enter single cursor mode, only the target server
mouse cursor is visible.

This is the hot key used to exit single cursor mode and bring back
the client mouse cursor.

Disconnect from Target - Hotkey.

Enable this hotkey to allow users to quickly disconnect from the
target.

For hotkey combinations, the application does not allow you to assign
the same hotkey combination to more than one function.

For example, if Q is already applied to the Disconnect from Target
function, it won't be available for the Exit Full Screen Mode function.

Further, if a hotkey is added to the application due to an upgrade and
the default value for the key is already in use, the next available value
is applied to the function instead.
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5. Click OK.
Options ﬁw

General | Client Launch Settings | Scan Settings

Keyboard Type: (Englsh (Us/Int1) -
Exit Full Screen Mode - Hotiey: CirlHLeftAlt+M - I
Exit Single Cursor Mouse Mode - Hotkey: :Ctr|+Le&A|t+O -
Disconnect From Target - Hotkey: :Ctr|+Leﬂ:A|t+Q - |

Ok H Cancel H Apply ]

Keyboard Limitations
Turkish Keyboards

If using a Turkish keyboard, you must connect to a target server through
the Active KVM Client [AKC). It is not supported by other Raritan clients.

Slovenian Keyboards
The < key does not work on Slovenian keyboards due to a JRE limitation.
Language Configuration on Linux

Because the Sun JRE on Linux has problems generating the correct Key
Events for foreign-language keyboards configured using System
Preferences, Raritan recommends that you configure foreign keyboards
using the methods described in the following table.

Language Configuration method

US Intl Default

French Keyboard Indicator

German System Settings (Control Center]
Japanese System Settings (Control Center)
UK System Settings (Control Center)
Korean System Settings (Control Center]
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Language Configuration method

Belgian Keyboard Indicator

Norwegian Keyboard Indicator

Danish Keyboard Indicator

Swedish Keyboard Indicator

Hungarian System Settings (Control Center)
Spanish System Settings (Control Center)
Italian System Settings (Control Center)
Slovenian System Settings (Control Center])
Portuguese System Settings (Control Center)

Note: The Keyboard Indicator should be used on Linux systems using
Gnome as a desktop environment.

Client Launch Settings

Configuring client launch settings allows you to define the screen
settings for a KVM session.

P> To configure client launch settings:

1. Click Tools > Options. The Options dialog appears.
2. Click on the Client Launch Settings tab.

a.

To configure the target window settings:

Select ‘'Standard - sized to target Resolution’ to open the window
using the target's current resolution. If the target resolution is
greater than the client resolution, the target window covers as
much screen area as possible and scroll bars are added (if
needed).

Select 'Full Screen’ to open the target window in full screen
mode.

To configure the monitor on which the target viewer is launched:

Select "Monitor Client Was Launched From® if you want the
target viewer to be launched using the same display as the
application that is being used on the client (for example, a web
browser or applet).

Use "Select From Detected Monitors' to select from a list of
monitors that are currently detected by the application. If a
previously selected monitor is no longer detected, ‘Currently
Selected Monitor Not Detected’ is displayed.
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= To configure additional launch settings:

a. Select 'Enable Single Cursor Mode' to enable single mouse
mode as the default mouse mode when the server is accessed.

b. Select 'Enable Scale Video' to automatically scale the display on
the target server when it is accessed.

¢. Select 'Pin Menu Toolbar® if you want the toolbar to remain
visible on the target when itis in Full Screen mode. By default,
while the target is in Full Screen mode, the menu is only visible
when you hover your mouse along the top of the screen.

Click OK.

Options - g1

General | Client Launch Settings | Scan Settings|

Window Made
(@) Standard - sized to target resolution

() Full Screen

Moritor 1]

(@ Monitor Client Was Launched From

() Select From Detected Monitors
Monitor A |
Detected Monitors:
Other
Enable Single Mouse Cursor
Enable Scale Video
QK ][ Cancel H Apply ]
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Configuring Port Scan Settings in VKC/VKCS and AKC
Configuring port scan options in VKC/VKCS and AKC applies to scanning
from the KX IIl Remote Console.

To configure port scan options for the Local Console, see Configure
Local Console Scan Settings (on page 175)

Use the port scanning feature to search for selected targets, and display
them in a slide show view, allowing you to monitor up to 32 targets at one
time.

You can connect to targets or focus on a specific target as needed. Scans
can include standard targets, blade servers, tiered Dominion devices,
and KVM switch ports.

Configure scan settings from either the VKC/VKCS or AKC.

See Scanning Ports - Remote Console (on page 158)

Use the Scan Settings tab to customize the scan interval and default
display options.

Configure Port Scan

P> To set scan settings:
1. Click Tools > Options. The Options dialog appears.
Select the Scan Settings tab.

3. Inthe "Display Interval (10-255 sec]:" field, specify the number of
seconds you want the target that is in focus to display in the center of
the Port Scan window.

4. Inthe "Interval Between Ports (10 - 255 sec):" field, specify the
interval at which the device should pause between ports.

5. Inthe Display section, change the default display options for the
thumbnail size and split orientation of the Port Scan window.

Raritan.
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Click OK.

Options . ﬁ1

[ General | ciient Launch Settings | Scan Settings |

Scan Intervals
Display Interval (10-255 sec): 10|

Interval Between Ports (10-255 sec): |10

Display
Thumbnail Size: | 160x120 =
Split Orientation: Vertical -

[ QK ][ Cancel ][ Apply ]

Collecting a Diagnostic Snapshot of the Target

Administrators are able to collect a "snapshot” of a target from either
the VKC/VKCS or Active KVM Client (AKC).

The "snapshot” function generate log files and image files from the
target.

It then bundles these files in a zip file that can be sent to Raritan
Technical Support in order to help diagnose technical problems you may
be encountering.

The following files are included in the zip file:

Raritan.
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screenshot_image.png

This is a screenshot of the target that captures a picture of the issue
you are experiencing. This feature is operates in the same as the
"Screenshot from Target” feature.

raw_video_image.png:
A snapshot image created from raw video data. Please note that

client's postprocessing is applied, just as if it were a "regular”
screen update.

raw_video_ycbcr420.bin:

Binary file of the raw snapshot.

raw_video_ycbcr420.txt:

Text file containing data used by Raritan to help diagnose issues.
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e Log.txtfile:

These are the client logs.

Note that the logs are included even if you have not enabled
information to be captured in them. VKC uses internal memory to

capture the information in this case.

Collect a Diagnostic Snapshot from VKC, VKCS, and AKC

Raritan.
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P To capture a diagnostic snapshot:

Steps

®

®
®

TUD e Wlgh g L e . =)
Wome | Sadup Teek Sty Welw  Wep w
m./m- { FPupicas + a I wop o e 3 “)(m
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Q (e g g " 5| l-_r Q \
| D B @ ~
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— — —

Access a target, and then click Tools > Collect a Diagnostic Snapshot.

Several messages are displayed as the information is collected.

You are prompted to save the zip file containing the diagnostic files.

The zip file containing the diagnostic files that were collecting opens.
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View Options

View Toolbar

You can use the Virtual KVM client with or without the toolbar display.

> To toggle the display of the toolbar (on and off):
e Choose View > View Toolbar.

View Status Bar

By default, the status bar is displayed at the bottom of the target window.

» To hide the status bar:
e Click View > Status Bar to deselect it.

» To restore the status bar:
e Click View > Status Bar to select it.

Scaling

Scaling your target window allows you to view the entire contents of the
target server window.

This feature increases or reduces the size of the target video to fit the
Virtual KVM Client window size, and maintains the aspect ratio so that
you see the entire target server desktop without using the scroll bar.

> To toggle scaling (on and off):
e Choose View > Scaling.

Raritan.
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Full Screen Mode
When you enter Full Screen mode, the target's full screen is displayed
and acquires the same resolution as the target server.

The hot key used for exiting this mode is specified in the Options dialog,
see Tool Options (on page 67).

While in Full Screen mode, moving your mouse to the top of the screen
displays the Full Screen mode menu bar.

If you want the menu bar to remain visible while in Full Screen mode,
enable the Pin Menu Toolbar option from the Tool Options dialog. See
Tool Options (on page 67).

> To enter full screen mode:
e Choose View > Full Screen, or click the Full Screen button @

» To exit full screen mode:

e Press the hot key configured in the Tool's Options dialog. The default
is Ctrl+Alt+M.

If you want to access the target in full screen mode at all times, you can
make Full Screen mode the default.

» To set Full Screen mode as the default mode:
1. Click Tools > Options to open the Options dialog.
2. Select Enable Launchin Full Screen Mode and click OK.

Connect to Virtual Media

See Virtual Media (on page 32)
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Smart Cards

Using the KX lll, you are able to mount a smart card reader onto a target
server to support smart card authentication and related applications.

For a list of supported smart cards, smart card readers, and additional
system requirements, see Smart Card Minimum System
Requirements, CIMs and Supported/Unsupported Smart Card
Readers (on page 78).

Note: The USB Smart Card token [eToken NG-OTP] is only supported
from the remote client.

Smart card reader mounting is also supported from the Local Console.

See Local Console Smart Card Access (on page 177) in your Dominion
device help.

Smart Card Minimum System Requirements, CIMs and
Supported/Unsupported Smart Card Readers

Before you begin using a smart card reader, review the following:

e Smart Card Minimum System Requirements (on page 205)

e Supported Computer Interface Module [CIMs] Specifications (on
page 197)

e Supported and Unsupported Smart Card Readers

Authentication When Accessing a Smart Card Reader

When accessing a server remotely, you can select an attached smart
card reader and mount it onto the server.

Smart card authentication is used with the target server, it is not used to
log into the device. Therefore, changes to smart card PIN and
credentials do not require updates to device accounts.

PC Share Mode and Privacy Settings when Using Smart Cards

When PC-Share mode is enabled on the device, multiple users can share
access to a target server.

However, when a smart card reader is connected to a target, the device
will enforce privacy regardless of the PC-Share mode setting.

In addition, if you join a shared session on a target server, the smart card
reader mounting will be disabled until exclusive access to the target
server becomes available.
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Smart Card Reader Detected

After a KVM session is established with a target server, a Smart Card
menu and button are available in VKC and AKC.

Once the Smart Card button is selected or Smart Card is selected from
the menu, the smart card readers that are detected as attached to the
remote client are displayed in a dialog.

From this dialog, you can attach additional smart card readers, refresh
the list of smart card readers attached to the target, and detach smart
card readers.

You are also able to remove or reinsert a smart card. This function can
be used to provide notification to a target server 0S that requires a
removal/reinsertion in order to display the appropriate login dialog.
Using this function allows the notification to be sent to a single target
without affecting other active KVYM sessions.

Mount a Smart Card Reader
When mounted onto the target server, the card reader and smart card
will cause the server to behave as if they had been directly attached.

Removal of the smart card or smart card reader will cause the user
session to be locked or you will be logged out depending on how the card
removal policy has been setup on the target server 0S.

When the KVM session is terminated, either because it has been closed
or because you switch to a new target, the smart card reader will be
automatically unmounted from the target server.

» To mount a smart card reader from VKC or AKC:

1. Click the Smart Card menu and then select Smart Card Reader.

Alternatively, click the Smart Card button Q in the toolbar.

2. Select the smart card reader from the Select Smart Card Reader
dialog.

3. Click Mount.
A progress dialog will open. Check the "Mount selected card reader
automatically on connection to targets’ checkbox to mount the smart

card reader automatically the next time you connect to a target.
Click OK to begin the mounting process.
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Update a Smart Card Reader

P> To update the smart card in the Select Smart Card Reader
dialog:

e Click Refresh List if a new smart card reader has been attached to
the client PC.

Send Smart Card Remove and Reinsert Notifications

» To send smart card remove and reinsert notifications to the
target:

e Select the smart card reader that is currently mounted and click the
Remove/Reinsert button.

Unmount (Remove) a Smart Card Reader

» To unmount a smart card reader:

e Select the smart card reader to be unmounted and click the
Unmount button.
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Digital Audio

The KX Il supports end-to-end, bidirectional, digital audio connections
for digital audio playback and capture devices from a remote client to a
target server.

The audio devices are accessed over a USB connection.
Current device firmware is required.

One of the following CIMs must be used:

e D2CIM-DVUSB

e D2CIM-DVUSB-DVI

e D2CIM-DVUSB-HDMI

e D2CIM-DVUSB-DP

Windows®, Linux® and Mac® operating systems are supported. VKC, VKCS,
and AKC support connections to audio devices.

Note: Audio CDs are not supported by virtual media so they do not work
with the audio feature.

Before you begin using the audio feature, Raritan recommends you
review the audio related information documented in the following
sections of Help:

e Supported Audio Device Formats (on page 81)

e Recommendations for Dual Port Video

e Dual Video Port Group Supported Mouse Modes

e CIMs Required for Dual Video Support

e Informational Notes, Audio (on page 235)

Supported Audio Device Formats

The KX Il supports one playback and capture device and one record
device on a target at a time. The following audio device formats are
supported:

e Stereo, 16 bit, 44.1K

e Mono, 16 bit, 44.1K

e Stereo, 16 bit, 22.05K

e Mono, 16 bit, 22.05K

e Stereo, 16 bit, 11.025K

e Mono, 16 bit, 11.025K
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Digital Audio VKC and AKC Icons

Audio
icons

o)
ol
o

P
\.&_.-'

[ Ha-

Icon name

Speaker

Microphone

Description

These icons are located in status bar at the
bottom of the client window.

Green, blinking waves indicate an audio playback
session is currently streaming.

A black speakericon is displayed when the
session is muted.

The icon is grayed out when no audio is
connected.

These icons are located in the status bar at the
bottom of the client window.

Red, blinking waves indicate an audio capture
session is currently underway.

The Speaker icon, indicating a playback session
is streaming, is also displayed when a session is
underway.

A black Microphone icon is displayed when the
session is muted.

When the Microphone icon is grayed out, no
audio is connected.

Audio Playback and Capture Recommendations and Requirements

Audio Level

e Setthe target audio level to a mid-range setting.

For example, on a Windows® client, set the audio to 50 or lower.

This setting must be configured through the playback or capture audio
device, not from the client audio device control.

82
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Recommendations for Audio Connections when PC Share Mode is Enabled

If you are using the audio feature while running PC Share mode, audio
playback and capture are interrupted if an additional audio device is
connected to the target.

For example, User A connects a playback device to Target1 and runs an
audio playback application then User B connects a capture device to the
same target. User A's playback session is interrupted and the audio
application may need to be restarted.

The interruption occurs because the USB device needs to be
re-enumerated with the new device configuration.

It may take some time for the target to install a driver for the new device.

Audio applications may stop playback completely, go to the next track, or
just continue playing.

The exact behavior is dependent on how the audio application is designed
to handle a disconnect/reconnect event.

Bandwidth Requirements

The table below details the audio playback and capture bandwidth
requirements to transport audio under each of the selected formats.

Audio format Network bandwidth requirement
44.1 KHz, 16bit stereo 176 KB/s
44.1 KHz, 16bit mono 88.2 KB/s
2.05 KHz, 16bit stereo 88.2 KB/s
22.05 KHz, 16bit mono 44.1 KB/s

11.025 KHz, 16bit stereo 44.1 KB/s
11.025 KHz, 16bit mono Audio 22.05 KB/s
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In practice, the bandwidth used when an audio device connects to a
target is higher due to the keyboard and video data consumed when
opening and using an audio application on the target.

A general recommendation is to have at least a 1.5MB connection before
running playback and capture.

However, high video-content, full-color connections using high-target
screen resolutions consume much more bandwidth and impact the
quality of the audio considerably.

To help mitigate quality degeneration, there are a number of
recommended client settings that reduce the impact of video on audio
quality at lower bandwidths:

e Connect audio playback at the lower quality formats. The impact of
video consuming bandwidth is much less notable at 11k connections
than at 44k

e Set the connection speed under Connection Properties to a value
that best matches the client to server connection

e Under Connection Properties, set the color depth to as low a value as
possible. Reducing the color depth to 8 bit color considerably
reduces the bandwidth consumed

e Set Smoothing, to High. This will improve the appearance of the
target video by reducing displayed video noise

e Under Video settings, set the Noise Filter to its highest setting of 7
(highest value] so less bandwidth is used for target screen changes
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Saving Audio Settings

Audio device settings are applied on a per KX Ill device basis.

Once the audio devices settings are configured and saved on the KX IlI,
the same settings are applied to it.

For example, you can configure a Windows® audio device to us a stereo,
16 bit, 44.1K format.

When you connect to different targets and use that Windows audio device,
the stereo, 16 bit, 44.1K format is applied to each target server.

For both playback and recording devices, the device type, device format,
and the buffer settings applied to the device are saved.

See Connecting and Disconnecting from a Digital Audio Device (on
page 86] for information on connecting to and configuring an audio
device, and Adjusting Capture and Playback Buffer Size (Audio Settings])
for information on audio device buffer settings.

If you are using the audio feature while running PC Share mode and VM
Share mode so multiple users can access the same audio device on a
target at once, the audio device settings of the user who initiates the
session are applied to all users who join the session.

So, when a user joins an audio session, the target machine settings are
used. See Connecting to Multiple Targets from a Single Remote
Client (on page 85).

Connecting to Multiple Targets from a Single Remote Client

Connect to audio on up to four (4] target servers at the same time from a
single, remote client.

See Connecting and Disconnecting from a Digital Audio Device (on
page 86) for information on connecting to audio devices.

A Speakericon o is displayed in the status bar at the bottom of the

client window. It is grayed out when no audio is being used. When the
T

IV
Speaker icon and Microphone icon '*'cﬁ" are displayed in the status bar,
the session is being captured as it is streamed.

Note: When an audio session is underway, be sure to keep the session
active or change the KX lll's idle timeout time so the audio session does
not time out.
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Operating System Audio Playback Support

Review the table shown here to see which Raritan client works with
audio playback/capture for each operating system:

Operating system Audio playback and capture supported
by:

Windows® e Active KVM Client (AKC)
e Virtual KVM Client (VKC)

Linuxe e Virtual KVM Client (VKC)

Mace e Virtual KVM Client (VKC)

Connecting and Disconnecting from a Digital Audio Device

Audio device settings are applied on a per KX |l device basis.

Once the audio devices settings are configured and saved on the KX IlI,
the same settings are applied to it.

See Saving Audio Settings (on page 85) for more information.

Note: If you are using the audio feature while running PC Share mode
and VM Share mode, see Audio Playback and Capture
Recommendations and Requirements (on page 82] for important
information. See also Connecting to Multiple Targets from a Single
Remote Client (on page 85).

Connect to a Digital Audio Device

» To connect to an audio device:

1. Connect the audio device to the remote client PC prior to launching
the browser connection to the KX III.

2. Connect to the target from the Port Access page.

3. Once connected, click the Audio button E:J'}} in the toolbar.

The Connect Audio Device dialog appears. A list of available audio
devices connected to the remote client PC is displayed.

Note: If there are no available audio devices connected to the remote
client PC, the Audio icon is grayed out. .

4. Check Connect Playback Device if you are connecting to a playback
device.

5. Select the device that you wish to connect from the drop-down list.
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Select the audio format for the playback device from the Format:
drop-down.

Note: Select the format that you wish to use based on the available
network bandwidth. Formats with lower sampling rates consume
less bandwidth and may tolerate more network congestion.

Select the "Mount selected playback device automatically on
connection to target” checkbox to automatically connect an audio
playback device when you connect to an audio supporting target.

Check Connect Recording Device if you are connecting a recording
device.

Note: The device names listed in the Connect Recording Device
drop-down are truncated to a maximum of 30 characters for Java
clients.

Select the device that you wish to connect from the drop-down list.

. Select the audio format for the recording device from the Format:

drop-down.

Click OK. If the audio connection is established, a confirmation
message appears. Click OK.

If the connection was not established, an error message appears.

Once an audio connection is established, the Audio menu changes to
Disconnect Audio. The settings for the audio device are saved and
applied to subsequent connections to the audio device.

1}

A Speaker icon ‘:«: is displayed in the status bar at the bottom of
the client window. It is grayed out when no audio is being used. When

il
the Speaker icon and Microphone icon '*':ﬁ" are displayed in the
status bar, the session is being captured as it is streamed.

Disconnect from an Audio Device

>

To disconnect from the audio device:
Click the Audio icon # in the toolbar and select OK when you are
prompted to confirm the disconnect. A confirmation message

appears. Click OK.

87



88

Chapter 5: KX Il KVM Clients

Adjusting Capture and Playback Buffer Size (Audio Settings]

Once an audio device is connected, the capture and playback buffer size
can be adjusted as needed.

This feature is useful for controlling the quality of the audio, which may
be impacted by bandwidth limitations or network spikes.

Increasing the buffer size improves the audio quality but may impact the
delivery speed.

The maximum available buffer size is 400 milliseconds since anything
higher than that greatly impacts audio quality.

The buffer size can be adjusted whenever needed, including during an
audio session.

Audio settings are configured in VKC or AKC.

Adjust Audio Settings

P To adjust audio settings:

1. Select Audio Settings from the Audio menu. The Audio Settings
dialog opens.
2. Adjust the capture and/or playback buffer size as needed. Click OK.

Capture Buffer Size: I miliseconds

Playback Buffer Size: milliseconds
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Power Control Using VKC, VKCS, and AKC

You can power on, power off, and power cycle a target through the outlet
it is connected to.

Access the target, and then select a power control option from the Power
Control menu.

Connection USB Profile Keyboard Video Mouse Tools View Virtual Media Audic SmartCard [PowerContlol] Help

GRESBRBEQILOREE m——

Power Off

Power Cycle

The menu option is disabled if you do not have permission for power
control, and when outlets are not associated with the port.

Version Information - Virtual KVM Client

This menu command provides version information about the Virtual KVM
Client, in case you require assistance from Raritan Technical Support.

» To obtain version information:
1. Choose Help > About Raritan Virtual KVM Client.

2. Use the Copy to Clipboard button to copy the information contained
in the dialog to a clipboard file so it can be accessed later when
dealing with support (if needed).
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Active KVM Client (AKC) Help

Overview

The Active KVM Client (AKC]) is based on Microsoft Windows .NET®
technology.

This allows you to run the client in a Windows environments without
using the Java® Runtime Environment (JRE], which is required to run
Raritan's Virtual KVM Client (VKC).

AKC is the default KX Il client on Windows platforms with .NET
Framework, and it also works with CC-SG.

AKC provides the same features as VKC with the exception of the

following:

e Keyboard macros created in AKC cannot be used in VKC

o Direct port access configuration (see Enabling Direct Port Access via
URL)

e AKC server certification validation configuration (see Prerequisites
for Using AKC (on page 91))

e AKC automatically loads favorites, VKC does not. See Managing
Favorites (on page 164)

For details on using the features, see Virtual KVM Client [VKC) Help
(see "Virtual KVM Client [VKC and VKCs] Help" on page 45).

Recommended Minimum Active KVM Client (AKC) Requirements

Raritan recommends the Active KVM Client [AKC) machines meet the
following minimum requirements for use with KX Il1.

e Client machine with either a -
=  'modern’ dual-core CPU for a single connections, or

= 'modern’ quad core CPU for two or more simultaneous
connections

e 4GB of RAM

AKC Supported Microsoft .NET Framework
The Active KVM Client (AKC) requires Windows .NET® version 4.0 or 4.5.
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AKC Supported Operating Systems

When launched from Internet Explorere, the Active KVM Client (AKC)
allows you to reach target servers via the KX I11.

AKC is compatible with the following platforms:

e Windows XP® operating system

e Windows Vista® operating system (up to 64 bit)
e  Windows 7¢ operating system (up to é4 bit)

e Windows 8¢ operating system [up to é4 bit)

e Windows 10 @ operating system (up to 64 bit)

Note: You must be using Windows 7 if WINDOWS PC FIPs is turned on
and you are accessing a target using AKC and a smartcard.

Since .NET is required to run AKC, if you do not have .NET installed or
you have an unsupported version of .NET installed, you will receive a
message instructing you to check the .NET version.

Note: Raritan recommends Windows XP® operating system users verify
you have a working version of NET 4.0 or 4.5 already installed before you
launch AKC. If you do not verify your .NET version is working, you may be
prompted to download a file versus receiving the default message to
check your .NET version.

AKC Supported Browsers
e Internet Explorer® 10 (and later)

e Chrome on Windows platforms. You must have the Chrome
ClickOnce plugin installed.

Prerequisites for Using AKC

Allow Cookies

Ensure the cookies from the IP address of the device that is being
accessed are not currently being blocked.

Include KX Il IP Address in 'Trusted Sites Zone'

Windows Vista®, Windows® 7 and Windows 2008 server users should
ensure that the IP address of the device being accessed is included in
their browser's Trusted Sites Zone.
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Disable ‘Protected Mode’

Windows Vista®, Windows® 7 and Windows 2008 server users should
ensure that Protected Mode is not on when accessing the Raritan device.

Enable AKC Download Server Certificate Validation

If the Raritan device (or CC-SG) administrator has enabled the Enable
AKC Download Server Certificate Validation option:

Administrators must upload a valid certificate to the device or
generate a self-signed certificate on the device. The certificate must
have a valid host designation.

Each user must add the CA certificate (or a copy of self-signed
certificate) to the Trusted Root CA store in their browser.

Proxy Server Configuration for Use with VKC, VKCS, and AKC

When the use of a Proxy Server is required, a SOCKS proxy must also be
provided and configured on the remote client PC.

Note: If the installed proxy server is only capable of the HTTP proxy
protocol, you cannot connect.

>

1.

To configure the SOCKS proxy:
On the remote client PC, select Control Panel > Internet Options.

a. Onthe Connections tab, click 'LAN settings'. The Local Area
Network (LAN] Settings dialog opens.

b. Select 'Use a proxy server for your LAN".
Click Advanced. The Proxy Settings dialog opens.
d. Configure the proxy servers for all protocols.

IMPORTANT: Do not select "Use the same proxy server for all
protocols’.

Note: The default port for a SOCKS proxy (1080] is different from
HTTP proxy (3128).

e. Click OK at each dialog to apply the settings.
Next, configure the proxy settings for the Java™ applets:
a. Select Control Panel > Java.

b. On the General tab, click Network Settings. The Network
Settings dialog opens.

Select "Use Proxy Server”.
d. Click Advanced. The Advanced Network Settings dialog opens.

e. Configure the proxy servers for all protocols.
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IMPORTANT: Do not select 'Use the same proxy server for all
protocols’.

Note: The default port for a SOCKS proxy (1080] is different from
HTTP proxy (3128].

Connect to a Target from Virtual KVM Client (VKC], Standalone VKC
(VKCs), or Active KVM Client (AKC)

Once you have logged on to the KX |l Remote Console, access target
servers via the Virtual KVM Client (VKC), Standalone VKC (VKCs), or
Active KVM Client (AKC]).

» To connect to an available server:

1. Onthe Port Access page, click on the port name of the target server
you want to connect to. The Port Action menu opens.

2. Click Connect.

Home > Ports

Port Access

Click on the individual
0/ 4 Remote K\VM char

See Port Action Menu (on page 25) for details on additional available
menu options.
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HTML KVM Client (HKC) Help

The HTML KVM client (HKC) provides basic KVM over IP access that runs
in the browser without applets or browser plugins. HKC uses Javascript,
NOT Java.

HKC runs on Linux and Mac clients, and on Windows clients without .NET
in Internet Explorer 11 [not supported in IE 10 or lower], Edge, Firefox,
Chrome and Safari browsers. See KX Ill KVYM Client Launching (on page
44) for a full matrix of clients.

Basic KVM features are supported. Future releases will provide
advanced KVM features.

>

94

Supported Features:
Connection properties
USB profiles

Video settings

Input settings

Not supported:

Audio

Virtual Media

Smartcard

Tools Menu for setting Client launch settings
Port Scanning

Support for Dual Monitor Targets

Limited keyboard support: US-English, UK-English, and German are
supported

Export/Import of keyboard macros
Hotkeys for keyboard macros
Pre-populated keyboard macros for Sun targets

Can only create Macros from keys that exist on the client PC
(US-English, UK-English or German], no special function keys

Single Mouse mode - not available on IE, Edge or Safari browsers

Known Issues:

To enable scrollbars on Mac Browser target connections: On the 0S
menu bar, choose System Preferences > General > Show scroll bars:
Always.
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e Internet Explorer and Edge support only 6 sessions at a time. The
error displayed when attempting to connect to a seventh target is
"Error could not connect to target.” For IE11, you can increase the
sessions allowed in the Group policy editor. See

https://jwebsocket.org/documentation/reference-guide/internet-exp

lorer-tips.

e ForIE11 and Edge IPvé device connections, either use device
hostname or literal IPv6 as UNC. See

https://en.wikipedia.org/wiki/IPvé_address#Literal_IPvé_addresses

_in_UNC_path_names
e For Mac/Safari IPvé device connections, use device hostname.

e Client Keyboard input selection should be set for each device
individually.

e |If encountering issues on browsers that have previously connected to

a version of KX3.3 that supported the HTML KVM client, it may be
necessary to clear the Cache Web Content from the browser.

e Tolaunch HKC automatically in Safari browser: Use http://<IP
Address>/hkc, OR use http://<IP Address>/ if "Java content on
browser"” is disabled in Java Control Panel, and "Java Plugin” is
disabled in the browser.

e From Chrome running on Linux, to get " * or *, the key needs to be
hit three times, or twice followed by a space.

e For Mac Client browsers, ensure that the device certificate is
installed and trusted. The certificate Common name should match
the IP address/Hostname used to connect to the device. See SSL
Certificates for information on creating and installing certificates

e On adefault build of Redhat 7/Firefox ESR 24.5, there is no target
video displayed on HKC connections. Older versions of Firefox lack
HTML5 functions needed to support HKC. Upgrade Firefox to the
latest available version.

Connection Properties

Connection properties manage streaming video performance over
remote connections to target servers.

The properties are applied only to your connection - they do not impact
the connection of other users accessing the same target servers.

If you make changes to connection properties, they are retained by the
client.

> To view connection properties:
e Choose File > Connection Properties.
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Default Connection Properties

The KX Il comes configured to provide optimal performance for the
majority of video streaming conditions.

Default connection settings are:

e Optimized for: Text Readability - video modes are designed to
maximize text readability.

This setting is ideal for general IT and computer applications, such
as performing server administration.

e Video Mode - defaults to Full Color 2.

Video frames transmit in high-quality, 24-bit color. This setting is
suitable where a high-speed LAN is used.

e Noise Filter - defaults to 2.
The noise filter setting does not often need to be changed.

Click Reset to regain the default connection properties.

Connection Properties

Optimize for: Text Readability =
Video Mode: Full Color 2

Lower

Best
Noise Filter: 2
oise Tier Bandwidth

Quality
g

= o] ]
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Text Readability

Text Readability is designed to provide video modes with lower color
depth but text remains readable. Greyscale modes are even available
when applying lower bandwidth settings.

This setting is ideal when working with computer GUIs, such as server
administration.

When working in full color video modes, a slight contrast boost is
provided, and text is sharper.

In lower quality video modes, bandwidth is decreased at the expense of
accuracy.

Color Accuracy

When Color Accuracy is selected, all video modes are rendered in full
24-bit color with more compression artifacts.

This setting applies to viewing video streams such as movies or other
broadcast streams.

In lower quality video modes, sharpness of fine detail, such as text, is
sacrificed.

Video Mode

The Video Mode slider controls each video frame's encoding, affecting
video quality, frame rate and bandwidth.

Connection Properties

Optimize for: Text Readability =
Video Mode: Full Color 2

Best Lower
Noise Filter: 2
Quality oise Fier Bandwidth

&

= o] ]
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In general, moving the slider to the left results in higher quality at the
cost of higher bandwidth and, in some cases, lower frame rate.

Moving the slider to the right enables stronger compression, reducing
the bandwidth per frame, but video quality is reduced.

In situations where system bandwidth is a limiting factor, moving the
video mode slider to the right can result in higher frame rates.

When Text Readability is selected as the Optimized setting, the four
rightmost modes provide reduced color resolution or no color at all.

These modes are appropriate for administration work where text and
GUl elements take priority, and bandwidth is at a premium.

Noise Filter

Unless there is a specific need to do so, do not change the noise filter
setting. The default setting is designed to work well in most situations.

The Noise Filter controls how much interframe noise is absorbed by the
KX I

Connection Properties

Optimize for: Text Readability =
Videc Mode: Full Color 2

Best Lower
Noise Filter: 2
Quality oise Tier Bandwidth

H

e (0 (D D

Moving the Noise Filter slider to the left lowers the filter threshold,
resulting in higher dynamic video quality. However, more noise is likely
to come through, resulting in higher bandwidth and lower frame rates.

Moving the slider to the right raises the threshold, allows less noise and
less bandwidth is used. Video artifacts may be increased.

Moving the noise filter to the right may be useful when accessing a
computer GUI over severely bandwidth-limited connections.
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Connection Info

Open the Connection Information dialog for real-time connection
information on your current connection, and copy the information from
the dialog as needed.

See Connection Properties (see "Default Connection Properties” on
page 96] for help configuring the connection properties.

Name of the KX Il

IP address of the KX Il

Port - The KVM communication TCP/IP port used to access KX II1.
Data In/Second - Data rate received from the KX lI

Data Out/Second - Data rate sent to the KX II1.

FPS - Video frames per second from the KX III.

Average FPS - Average number of video frames per second.
Connect Time - The duration of the current connection.
Horizontal Resolution - The target server horizontal resolution.
Vertical Resolution - The target server vertical resolution.
Refresh Rate - Refresh rate of the target server.

Protocol Version - Raritan communications protocol version.

To view connection info:
Choose File > Connection Info.

Raritan.
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Connection Info

Device Name: DominionKX
IP Address: 192.168.61.14
Port: 443

Data In/Second: 0B/s

Data Out/Second: 0B/s

FPS: 0

Avg. FPS: 0.00

Connect Time: 00:16:25

Horizontal Resolution:

Vertical Resolution:

Refresh Rate: 60 Hz
Protocol Version: 1.31
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USB Profile
Select a USB profile that best applies to the KVM target server.

For example, if the server is running Windows® operating system, it
would be best to use the Generic profile.

Or, to change settings in the BIOS menu or boot from a virtual media
drive, depending on the target server model, a BIOS profile may be more
appropriate.

P> To set a USB profile for a target server:

e Choose USB Profile, then choose Generic, or choose Other Profiles
to select from a menu.

@ Target 9-RSAII-SLIMLINE - HTML KVM Client - Google Chrome -

A b#75://192.168.61.14/jsclient/Client.asp#
File ~ USB Profile ~ Input ~ Video ~ View ~ Help ~

g RE Generic v a ﬂ

Other Linux

Help on USB profiles Mac OS-X (10.4.9 and later)
HP Proliant DL360/DL380 G4 (Windows 2003 Server Installation)
BIOS IBM Thinkcentre Lenovo
RUBY Industrial Mainboard (AwardBIOS)
HP Proliant DL360/DL380 G4 (HP SmartStart CD)
BIOS Dell PowerEdge Keyboard and Mouse Only
Supermicro Mainboard (Phoenix AwardBIOS)
SuSE Linux 9.2
BIOS Mac

> To view details on USB profiles:
Choose USB Profile > Help on USB Profiles.

Input Menu
Keyboard Layout

P> To set your keyboard type.
e Choose Input > Keyboard Layout, then select your keyboard type.
= de

= en-gb

100 Raritan.

A brand of Hllegrand’



Raritan.

A brand of Lllegrand

Chapter 5: KX Il KVM Clients

= en-us
File ~ USB Profile ~ Input ~ Video ~ View ~
3 @ A Keyboard Layout
BRE@ KE ;) orets de
s Send Macro en-ab
N -9
# Macro Editor e

4 Mouse Modes
22 Mouse Sync

Send Macro

Due to frequent use, several keyboard macros are preprogrammed.

> To send a preprogrammed macro:

Choose Input > Send Macro, then select the macro:

= Ctrl+Alt+Del: Sends the key sequence to the target without
affecting the client.

= Alt+F4: Closes a window on a target server.
= Alt+Tab: Switch between open windows on a target server.
File ~ USB Profile ~ Input - Video ~ View =

@ h @ @ » A Keyboard Layout

a2 Send Macro Ctrl+Alt+Del
# Macro Editor Alt+F4
4 Mouse Modes Alt+Tab

£ Mouse Sync
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Macro Editor

Keyboard macros ensure that keystroke combinations intended for the
target server are sent to and interpreted only by the target server.
Otherwise, they might be interpreted by your client PC.

Macros are stored on the client PC and are PC-specific. If you use
another PC, you cannot see your macros.

In addition, if another person uses your PC and logs in under a different
name, that user will see your macros since they are computer-wide.

Macros created in HKC cannot be used in other KVM clients. Macros
created in other KVM clients cannot be used in HKC.

P> To access the Macro Editor:
e Choose Inputs > Macro Editor.
e Select a macro from the Macros list to view the key combination.

Macro Editor

Name Ctri+Alt+Del
Macros Keys
Ctrl+Alt+Del - press: CTRL LEFT - Add Key
Alt+F4 press: ALT LEFT
Alt+Tab press: DELETE hij
release: CTRL LEFT
release: ALT LEFT 2

release: DELETE

- -

Delete Key

Coc o

[«

Add New Macro

» To add a new macro:
1. Choose Inputs > Macro Editor.
Click Add New Macro.

3. Enter a Name for the new macro. The name will appear in the Send
Macro menu once the macro is saved.
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4. Click Add Key, then press the key you want to add to the macro. The
key press and key release appear in the Keys list.

= Toadd more keys, click Add Key again, and press another key.
=  Toremove a key, select it in the Keys list and click Delete Key

5. To putthe key in the correct sequence, click to select a key in the
Keys list, then click the up and down arrows.

6. Click OK to save.

Macro Editor

Name Ctrl+B ‘
Macros Keys
Ctri+Alt+Del - press: CTRL LEFT - Add Key
Alt+F4 press: B —
Alt+Tab release: CTRL LEFT g
New Macro release: B >
i

Delete Key

- -

Delete a Macro

» To delete a macro:

1. Choose Inputs > Macro Editor.
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2. Select the macro, then click Delete Macro.

-

Macro Editor

Name Ctrl+B
Macros Keys
Ctrl+Alt+Del - press: CTRL LEFT - Add Key
Alt+F4 press: B
Alt+Tab release: CTRL LEFT i}
LIS — — cleass E
1
Delete Key
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Mouse Modes
You can operate in either single mouse mode or dual mouse mode.

When in a dual mouse mode, and provided the option is properly
configured, the mouse cursors align.

When controlling a target server, the Remote Console displays two
mouse cursors - one belonging to your KX IlI client workstation, and the
other belonging to the target server.

When there are two mouse cursors, the device offers several mouse
modes:

e Absolute [Mouse Synchronization)

e Intelligent (Mouse Mode)

e Standard (Mouse Mode])

When the mouse pointer lies within the KVM Client target server window,

mouse movements and clicks are directly transmitted to the connected
target server.

While in motion, the client mouse pointer slightly leads the target mouse
pointer due to mouse acceleration settings.

On fast LAN connections, you can use single mouse mode, and view only
the target server's pointer.

You can toggle between these two modes (single mouse and dual
mouse).
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Absolute Mouse Synchronization

In this mode, absolute coordinates are used to keep the client and target
cursors in synch, even when the target mouse is set to a different
acceleration or speed.

This mode is supported on servers with USB ports and is the default
mode for virtual media CIMs.

Absolute Mouse Synchronization requires the use of a virtual media CIM

e D2CIM-VUSB

e D2CIM-DVUSB

e D2CIM-DVUSB-DVI

e D2CIM-DVUSB-HDMI
e D2CIM-DVUSB-DP

> To enter Absolute Mouse Synchronization Mode:
e Choose Input > Mouse Modes > Absolute.

Input ~ Video ~ View -

A Keyboard Layout

28 Send Macro

# Macro Editor

4 Mouse Modes

Absolute ¢ ¢——
%> Mouse Sync

Intelligent
Standard

Single Mouse Mode
L]

Intelligent

In Intelligent Mouse mode, the device can detect the target mouse
settings and synchronize the mouse cursors accordingly, allowing
mouse acceleration on the target. Intelligent mouse mode is the default
for non-VM targets.

P> To enter Intelligent mouse mode:

e Choose Input > Mouse Mode > Intelligent. The mouse will synch. See
Intelligent Mouse Synchronization Conditions (on page 65).

Input ~ Video ~ View ~

A Keyboard Layout

28 Send Macro

# Macro Editor

4 Mouse Modes Absolute

2 Mouse Sync ;

Y Intelligent v g——o

Standard
Single Mouse Mode
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Standard

Standard Mouse mode uses a standard mouse synchronization algorithm.
The algorithm determines relative mouse positions on the client and
target server.

In order for the client and target mouse cursors to stay in synch, mouse
acceleration must be disabled. Additionally, specific mouse parameters
must be set correctly.

» To enter Standard mouse mode:
e Choose Input > Mouse Modes > Standard.
Input ~ Video - View =

A Keyboard Layout

28 Send Macro

# Macro Editor

4 Mouse Modes Absolute

rl
=~ Mouse Sync Intelligent

Standard v €4——
Single Mouse Mode

Single

Single Mouse mode uses only the target server mouse cursor; the client
mouse cursor no longer appears onscreen.

Note: Single mouse mode does not work on Windows or Linux targets
when the client is running on a Virtual Machine.

P> To enter Single mouse mode:
e Choose Inputs > Mouse Modes > Single.

A message appears at the top of the client window: Press Esc to
show your cursor.

Inp ' '

A Press to show your cursor
a8 Send Macro
# Macro Editor

<% Mouse Modes Absolute
% Mouse Sync

Intelligent
Standard
Single Mouse Mode #¢—
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P> To exit Single mouse mode:
e Press Esc.
e Mouse mode changes to Absolute.

Mouse Sync

In dual mouse mode, the Synchronize Mouse command forces
realignment of the target server mouse cursor with the client mouse
cursor.

Note: This option is available only in Standard and Intelligent mouse
modes.

> To synchronize the mouse cursors:
e Choose Inputs > Mouse Sync.
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Intelligent Mouse Synchronization Conditions

The Intelligent Mouse Synchronization command, available on the Mouse
menu, automatically synchronizes mouse cursors during moments of
inactivity. For this to work properly, however, the following conditions
must be met:

e The active desktop should be disabled on the target.
e No windows should appear in the top left corner of the target page.

e There should not be an animated background in the top left corner of
the target page.

e The target mouse cursor shape should be normal and not animated.

e The target mouse speeds should not be set to very slow or very high
values.

e Advanced mouse properties such as “Enhanced pointer precision” or
“Snap mouse to default button in dialogs” should be disabled.

e Choose "Best Possible Video Mode” in the Video Settings window.

e The edges of the target video should be clearly visible (that is, a
black border should be visible between the target desktop and the
remote KVM console window when you scroll to an edge of the target
video image).

e When using the intelligent mouse synchronization function, having a
file icon or folder icon located in the upper left corner of your
desktop may cause the function not to work properly. To be sure to
avoid any problems with this function, Raritan recommends you do
not have file icons or folder icons in the upper left corner of your
desktop.

After autosensing the target video, manually initiate mouse
synchronization by clicking the Synchronize Mouse button on the toolbar.
This also applies when the resolution of the target changes if the mouse
cursors start to desync from each other.

If intelligent mouse synchronization fails, this mode will revert to
standard mouse synchronization behavior.

Please note that mouse configurations will vary on different target
operating systems. Consult your OS guidelines for further details. Also
note that intelligent mouse synchronization does not work with UNIX
targets.
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Video Menu

Refresh Screen

The Refresh Screen command forces a refresh of the video screen. Video
settings can be refreshed automatically in several ways:

e The Refresh Screen command forces a refresh of the video screen.

e The Auto-Sense command automatically detects the target server's
video settings.

e The Color Calibration command calibrates the video to enhance the
colors being displayed.

e In addition, you can manually adjust the settings using the Video
Settings command.

» To force a refresh of the video screen:

e Choose Video > Refresh Video.
File ~ USB Profile ~ nput - Video ~ View ~

% h @ ‘}@ © Refresh Screen  €——

Ea Screenshot

(D Auto Sense

® Color Calibration

B \/ideo Settings

<& Clear Video Settings Cache

Screenshot

Take a screenshot of a target server using the Screenshot command.

P> To take a screenshot of the target server:

1. Choose Video > Screenshot.
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2. The screenshot file appears as a download to view or save. Exact
options depend on your client browser.

File ~ USB Profile ~ Input ~ Video ~ View ~
Help ~ © Refresh Screen

K3 =1 ol Screenshot €——
% h @@ u@ @ Auto Sense

%? & Color Calibration

"'Ecurity B<\/ideo Settings
-Cn;\"igurah‘nn <& Clear Video Settings Cache
- Wizard

s~
CyberLink
PowerDVD =

4

Desktop Size is 1024x768 2= 2 ENUMS CAPS SCRL
B screenshot_14785..png N d—— Show all X
Auto Sense

The Auto Sense command forces a re-sensing of the video settings, such
as resolution and refresh rate, and redraws the video screen.

P> To automatically re-sense the video settings:
e Choose Video > Auto Sense .
A message stating that the auto adjustment is in progress appears.

File ~ USB Profile ~ Input ~ Video ~ View ~ Help ~

% h @ “ © Refresh Screen

[l Screenshot

@ Auto Sense €¢——

® Color Calibration

B Video Settings

<& Clear Video Settings Cache

Auto adjustment in progress
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Color Calibration

The Color Calibration command optimizes the color levels, such as hue,
brightness, and saturation, of the transmitted video images.

The color settings are on a target server-basis.

Note: When color is successfully calibrated, the values are cached and
reused each time you switch to the target. Changes to the brightness and
contrast in Video Settings are not cached. Changing resolution resets the
video to the cached values again. You can clear the cached values in
Video > Clear Video Settings Cache. See Clear Video Settings Cache (on
page 60).

P> To calibrate color:
e Choose Video > Color Calibration.
A message stating that the color calibration is in progress appears.
File ~ USB Profile - Input - Video View =

S RhES R @ ©Refiesn screen

& Screenshot

 Auto Sense

® Color Calibration €——
B« \ideo Settings

<& Clear Video Settings Cache

Video Settings

Use the Video Settings command to manually adjust the video settings.

P> To change the video settings:
1. Choose Video > Video Settings to open the Video Settings dialog.

2. Adjust the following settings as required. As you adjust the settings
the effects are immediately visible:

a. PLL Settings

Clock - Controls how quickly video pixels are displayed across
the video screen. Changes made to clock settings cause the video
image to stretch or shrink horizontally. 0Odd number settings are
recommended. Under most circumstances, this setting should
not be changed because the autodetect is usually quite accurate.

Phase - Phase values range from 0 to 31 and will wrap around.
Stop at the phase value that produces the best video image for
the active target server.

b. Brightness: Use this setting to adjust the brightness of the target
server display.
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c. Brightness Red - Controls the brightness of the target server
display for the red signal.

d. Brightness Green - Controls the brightness of the green signal.

e. Brightness Blue - Controls the brightness of the blue signal.
f. Contrast Red - Controls the red signal contrast.

g. Contrast Green - Controls the green signal.

h. Contrast Blue - Controls the blue signal.

If the video image looks extremely blurry or unfocused, the
settings for clock and phase can be adjusted until a better image
appears on the active target server.

Warning: Exercise caution when changing the Clock and Phase
settings. Doing so may result in lost or distorted video and you may
not be able to return to the previous state. Contact Raritan Technical
Support before making any changes.

i. Horizontal Offset - Controls the horizontal positioning of the
target server display on your monitor.

Raritan. 13
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j. Vertical Offset - Controls the vertical positioning of the target

server display on your monitor.

Video Settings

PLL Settings
Clock 1344 1026 |
Phase 20 0
Color Settings
Brighiness Red o] o
Brighiness Grean o 1]
Erightness Blue o 1] J
Contrast Red B85 0 |
Contrast Grean ] 0 |
Confrast Blue T0 0 |
Herizontal Offset 288 4]
Vertical Offset 35 4]

W Automatic Color Calibration

Video Sensing

* Eest possible video mode

Quick senze video mode

16844

k4

127

127

127

127

127

127

255

-T68
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Clear Video Settings Cache

You can clear the video settings cache to delete old settings that do not
apply anymore, such as when a target server is replaced. When you clear
the video settings cache, the server automatically does a video
auto-sense and color calibration. The new values are cached and reused
when the target is accessed again.

P> To clear the video settings cache:
e Choose Video > Clear Video Settings Cache in the toolbar.

File ~ USB Profile ~ Input ~ Video ~ View =

S RNEE NEEQ ERereshscreen

& Screenshot

 Auto Sense

& Color Calibration

B¢ Video Settings

@ Clear Video Settings Cache 4—

View Menu
The View Menu contains options to customize your HKC display.

File ~ USB Profile ~ Input ~ Video - View «
5 A CEl @ Toolbar
% h @ @ » . @ @ ﬁ e ¥ Statusbar

¥ Scale Video

Fullscreen

» Toolbar and Statusbar:

The toolbar contains icons for some commands. The statusbar displays
screen resolution at the bottom of the client window.

> Scale Video:

Scale Video scales your video to view the entire contents of the target
server window in your HKC window. The scaling maintains the aspect
ratio so that you see the entire target server desktop without using the
scroll bar.

>  Fullscreen:

Fullscreen sets the target window to the size of your full screen,
removing your client from the view.

e Press Esc to exit fullscreen.
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Power Control Menu

Power Control is not supported in this release
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Serial Access With Dominion Serial
Access Module
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Connecting a KX Il and a Dominion Serial Access Module (DSAM]
provides serial access for the KX III.

The DSAM is a 2- or 4 port serial module that derives power from the KX
[l

Connect a maximum of 2 DSAM modules to the KX Ill using USB cables.
DSAM can be mounted in a OU configuration.

In This Chapter

Connect KX ITand DSAM ... 118
View DSAM Serial POrts.... ... 120
Configure DSAM Serial POrtS ......cocviiiiiiiicee e 120
Configure Serial Port Keyword List .......ccccooiiiiiiiiiiccccee 125
Upgrade DSAM FIrMWare .. ...ooiee et 125
Supported CLI Commands ....oeie i 127
Connect to DSAM Serial Targets with KX3 GUI ... 131
Connect to DSAM Serial Target with URL Direct Port Access ............... 132
Connect to DSAM Serial Target via SSH ..o, 133
HTML Serial Console [HSC) Help .o 134
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Connect KX Ill and DSAM

1. Connect the DSAM unit's USB cable to any USB port on the KX 1lI
device.

2. Connect the serial devices to the serial ports on the DSAM unit.

Serial Devices Serial Devices

Cath
Connections

USB
Connections

At-the-Rack

Serial over IP

DSAM LED Operation
The DSAM unit has one LED for status, and 2 LEDs on each port.

Raritan DSAM-4

©

Status 1 2 3 [

g—"‘?@‘f’”ﬁ‘ﬁ“ﬁ‘
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» Status LED:

The Status LED is labeled on the unit front. Light is on back. The Status
LED gives information at bootup and upgrade.

e Green LED - Slow blink: DSAM booting up but not controlled by KX3.
e Blue LED - Slow blink: DSAM controlled by KX3.
e Blue LED - Fast blink: Firmware upgrade in progress.

> USB Port LEDs:
Each USB port has a left Blue LED and a right Yellow LED.

e Blue LED: Portis set as DCE
e Yellow LED: Port is set as DTE
e |EDs off: Portis set as AUTO

Supported USB Device Combinations

Each USB device draws from a fixed pool of USB resources. There are
limits on the number of USB devices that can be connected to the KX Il
at the same time.

The following device combinations are supported.

X X
4-Port DSAM
X X X
4-Port DSAM
X X X
2-Port DSAM
2-Port DSAM
X X X
Keyboard and
Mouse
X X
SmartCard
X X X
Wireless Modem
8 6 6 4 2
DSAM Ports
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View DSAM Serial Ports

When a DSAM unit is connected to KX Ill, a new tab is available in the
Ports page. The View by Serial tab shows all connected serial ports.

[ Pover | il e | user Management | Devie setings | securty | Waiienance | Dia

Home = Ports

Port Access

Click on the individual port name to see allowable operations.
0/1 Remote KVM channels currently in use.

e [ View By Group| View By Search| Set scan |
Status Availability
4 ¥ DSAM4 Front DSAM up
41 DSAM4 Port 1 DCE up idle
42 DSAM4 Port 2 AUTO down idle
43 DSAMA Paort 3 AUTO down idle
4.4 DSAMA Port 4 AUTO down idle
I * 32 Rows per Page

> To view DSAM serial ports:
In the Port Access page, click the View By Serial tab.

e Ports are listed by physical USB position on the DSAM unit.

e USB Port column indicates which KX Il USB port DSAM is plugged
into.

e Type column indicates port's DTE/DCE setting.

Configure DSAM Serial Ports

The serial port configuration options are available when a DSAM unit is
connected to KX Il using a USB port.

> To configure DSAM serial ports:
1. Choose Device Settings > Serial Port Configuration.
2. Click the Port Name for the port you want to configure.

[ Port Access | Power | Virtual Media | User Management

Home = Device Settings = Serial Port Configuration

Serial Port Configuration

4.1 DSAM4 Port 1 —Bef—r—

42 DSAM4 Port 2 AUTO
43 DSAM4 Port 3 AUTO
44 DSAM4 Port 4 AUTO
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3. The Port Type is set to Serial only.

4. Enter a meaningful name for the serial target or leave the default
name.

Type:
Serial

Name:
DSAM4 Port 1

Power Association

If an outlet is connected to the same server that the port is connected to,
a power association can be made with the target device.

A port can have up to four associated outlets, and you can associate a
different rack PDU (power strip) with each. From this page, you can
define those associations so that you can power on, power off, and power
cycle the server from the Port Access page.

To use this feature, you need Raritan remote rack PDU(s).

1. Select the Power Strip Name and associate a name with each of the
power strip's outlets by selecting from the Outlet Name drop-down.

121



Chapter 6: Serial Access With Dominion Serial Access Module

2. Click OK. A confirmation message is displayed.

Power Association

Power Strip Name Qutlet Name
[Fowerstip | [New outiett
[Fowerstrip [

Powerstrip -

Serial Port Settings
Configure the remaining port settings.

1. Select the terminal emulation type from the drop-down menu in the
Emulation field. This is the terminal emulation mode used to match
the serial targets connected to the ports.

= VT100
= VT220
= VT320
= ANS|

2. Set Encoding if you want to always use a specific character encoding
for this port. Encoding overrides the global setting for the port to
whatever value you set.

= DEFAULT
= US-ASCII

= |508859-1
= |S08859-15
= UTF-8
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= Shift-JIS
= EUC-JP
= EUC-CN
= EUC-KR

In the Equipment Type field, indicate whether you want the KX Ill to
automatically detect a physical connection to the target. The default
is Auto Detection.

Force DTE causes KX Il to act as a piece of data terminal detection
equipment to detect targets connected to it.

Force DCE causes KX Il to act as a piece of data communications
equipment to detect equipment connected to it.

Note: If the target has the ability to autodetect either DTE or DCE,
you must select either Force DTE or Force DCE for the port. KX Il
does not support autodetection of both DCE and DTE on the same
port.

Select the value of Bits Per Second from the Bits Per Second
drop-down menu.

Select the Parity Bits from the Parity Bits drop-down menu.
Select the Flow Control from the Flow Control drop-down menu.
Stop Bits

If you need to configure the delay between when individual
characters are sent via the port, enter the time in milliseconds in the
Char Delay field.

To configure the delay between when lines of text are sent via the
port, enter it in the Line Delay field.

Configure the sendbreak duration by entering the send break time in
the Send Break Duration field. The send break is configurable from
Oms - 1000ms.

Select Always Active if you want to log activities coming into a port
even if no user is connected.

The default option is to not maintain port access without a connected
user, which means ignore data coming into a port when no user is
connected.

This option is for port data logs.

Note: When no users are logged into a port session, port traffic, by
default, is discarded .

If you do not want messages displayed to users connecting to KX ll|
via Direct Port Access, select the Suppress Message checkbox.

Select the Escape Mode.
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The escape sequence affects only the CLI.  When entering the
escape mode, the user is given a menu of commands that can be
performed (for example, gethistory, power commands, and so on), a
command to return to the port session, and a command to exit the
port connection.

The default is None.
Change as follows:

= Select control from the drop-down menu in the Escape Mode
field.

14. Type the character in the Escape Character field. The default for the
KX Ill'is ] (closed bracket).

Raritan recommends that you do not use [ or Ctrl-[. Either of these
may cause unintended commands, such as invoking the Escape
Command unintentionally. This key sequence is also triggered by the
arrow keys on the keyboard.

15. Type a command in the Exit Command field, such as logout.

This is the command that is sent to your system when a user with
write permission disconnects from the port.

The main function of this command is to ensure that the user's
session on the target machine is closed; however, it is not imperative
to have an Exit command configured on a port.

16. Click OK.

Apply Settings to Other Ports
Once finished, you can apply the same port settings to other ports.

1. Select the ports from the Apply Serial Port Settings To Other Ports
section of the page.

2. Click OK to apply the port configuration settings.
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Configure Serial Port Keyword List
Port keywords work as a filter. You can create port keywords and
associate them with -
e Events
e Local/remote syslog messages
e SNMP traps
If a keyword is detected -
e Acorresponding message is logged in a local/NFS port log.
e Acorresponding event is sent via SMTP (if configured).
e Acorresponding trap is sent via SNMP (if configured).

This feature is useful for notifying administrators if a particular event
occurs on a port. Using port keywords to report events does not impact
the NFS log size.

For keywords to trigger when no users are connected to a port, "Always
Active” must be selected on the port's Port Configuration page.

A list of existing port keywords is displayed on the Port Configuration
page as well.

P> To configure serial port keywords:

1. Choose Device Settings > Serial Port Keywords. The Serial Port
Keyword List page opens.

Click Add at the bottom of list on the page. The Keyword page opens.
Type a keyword in the Keyword field.

Select the Port(s) you want to associate with that keyword.

Click Add to add them to the Selected box.

Click OK.

AN N

Upgrade DSAM Firmware

DSAM firmware is upgraded automatically during KX Ill device firmware
upgrades if a new DSAM version is detected in the device firmware. You
can also upgrade your DSAM firmware manually.

P> To upgrade the DSAM firmware manually:

1. Choose Maintenance > DSAM Firmware Upgrade.
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2. Select the checkboxes for the DSAM units you want to upgrade to the
Upgrade DSAM Version listed.

DSAM Upgrade from Device Flash
DominionKX DSAMs:

Select All Deselect All

Selected 4 Port Name USB Port Current DSAM Version Upgrade DSAM Version
] 4 DSAM4 Front 021 022
A
Uparae T

3. Click Upgrade, then click OK to confirm. A progress message
appears.

Firmware Upgrade in Progress...

DSAMs on Device DominionKX are being upgraded. It may

take up to 2 minutes to upgrade the selected DSAMs. Do

not turn off the unit or remove DSAMs until the upgrade is
complete.

Progress: 0 of 1 DSAMs upgraded

| 0%

B~

When firmware upgrade completes, a success message appears.

Firmware Upgrade in Progress...

Upgrade of DSAM(s) on device, DominionKX , has
completed. You will now be redirected to the Port Access
page.

Progress: DSAM Upgrade Finished Successfully

100%

Serial Number Result

4 RKKE683758 Successful
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Supported CLI Commands
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Port Connect Commands

Connect to a serial port using port number or port name. Use double
quotes around port names that contain space symbols. For example:
"DSAM Port 1.

admin > connect <port number>

admin > connect <port name>

>  Port number example:

admin > connect 1.1

> Port name example:

admin > connect "DSAM Port 1"

Port Sub-Menu Commands

The port sub-menu can be reached using the escape key sequence.

Clear history buffer for this port.

admin > [portname] > clearhistory

Close this target connection. When a target is disconnected, the
appropriate disconnect message appears.

admin > [portname] > close, quit, g

Display the history buffer for this port.

admin > [portname] > gethistory

Get write access for the port.

admin > [portname] > getwrite

Return to the target session.

admin > [portname] > return

Send a break to the connected target.

admin > [portname] > sendbreak

Lock write access to this port.

admin > [portname] > writelock

Unlock write access to this port.

admin > [portname] > writeunlock
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Query Power status of this port.

admin > [portname] > powerstatus

Toggle Power On/Off of this port.

admin > [portname] > powertoggle

Power on the target.

admin > [portname] > poweron

Power off the target.

admin > [portname] > poweroff

Power cycle the target.

admin > [portname] > powercycle

Configure Ports Commands

Enter admin > to access the menu.

Command Description Parameters
listports List accessible ports NA

Enter admin > config > port toaccessthe menu.

Command Description Parameters

keywordlist Display all configured keywords. NA

keywordadd Add a keyword to the port. * port <number | range | *> - Single port
or range of ports (1-n or 1,3,4 or * for all
ports)

= keyword <value> - When keyword is
detected on target, notification is sent.

keyworddelete Delete an existing keyword from the = port <number |range | *> - Single port
port. or range of ports (1-n or 1,3,4 or * for all
ports)

= keyword <value> - When keyword is
detected on target, notification is sent.
config port = port <number | range | *> - Single port or
range of ports (1-n or 1,3,4 or * for all ports)
= name <port name> - Port name

= bps <1200 1800 | 2400 | 4800 | 9600 | 19200
| 38400 | 57600 | 115200 | 230400> - Port
speed in bits-per-second
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Parameters

parity <noneleven|odd> - Port parity type
flowcontrol <nonelhw|sw> - Port
flowcontrol type hw = hardware flow control
sw =X on/X off)

eqtype <autoldteldce> - Equipment type
(auto=>AUTO Detection, dte=>Force DTE,
dce=>Force DCE])

Note: If the target has the ability to
autodetect either DTE or DCE, you must
select either Force DTE or Force DCE for
the port. KX Il does not support
autodetection of both DCE and DTE on the
same port.

escapemode <nonelcontrol> - Use Ctrl-key
(escapemode=control] or single key
(escapemode=none) as escape sequence;
for example, Ctrl- =>
escapemode=control, escapechar=
escapechar char-Escape character

Raritan recommends that you do not use or
Ctrl- as the Escape command. Either of
these may cause unintended commands,
such as opening a menu, instead of invoking
the Escape Command.

emulation <vt100 | vt220 | vt320 | ansi> -
Target Emulation type

sendbreak <duration> - Duration of the
sendbreak signal in milliseconds.

exitstring <cmd #delay; > - Execute exit
string when port session closes, for
example, config port 1 exitstring logout
(execute logout on exit) config port 1
exitstring #0 (disable exit string for the
port). The delay is the amount of time to
wait after writing the command to the
target. Number in seconds up to 60.

alwaysactive <true | false> - Determine
whether data coming into a port is logged,
for example, config port 1 alwaysactive true
(always log activities coming into a port
even if no user is connected) config port 1
alwaysactive false (ignore data coming into
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Command Description Parameters

a port when no user is connected)

= suppress - Determine whether none or all
messages should be displayed during a
DPA connection, such as "Authentication
successful”

= encoding - Target Encoding type
(DEFAULT|US-ASCII|IS0-8859-1[1S0-8859-
15|UTF-8|Shift-JIS|[EUC-JP|EUC-CNIEUC-K
R

= multiwrite - Port set in Multiple Writer
Mode.

= chardelay delay - Delay inserted between
writing characters (0-9999ms)

= linedelay delay - Delay inserted between
writing lines (0-9999ms)

= stopbits - Number of bits used to signal the
end of a character (usually 1) (1/2)

= stopbits <1/2> -Number of bits used to
signal the end of a character

= chardelay - Delay inserted between
characters (0-9999) in ms

= linedelay - Delay inserted between lines
(0-9999) in ms

= escapechar - Escape character

= encoding -
<DEFAULT/US-ASCII/ISO-8859-1/1S0-8859-
15/UTF-8/Shift-JIS/EUC-JP/EUC-CN/EUC-
KR> - Target encoding type

= multiwrite <true/false> - Port set in
multiple writer mode

= suppress <true/false> - Suppress SX
messages when connecting to this
target(true/false)

= sendbreak - Duration of sendbreak signal in
ms
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Command Line Interface Shortcuts

Press the Up arrow key to display the last entry.

Press Backspace to delete the last character typed.

Press Ctrl + C to terminate a command or cancel a command if you
typed the wrong parameters.

Press Enter on your keyboard to execute the command.

Press Tab on your keyboard to complete a command. Tab also
completes parameters and values (if the value is part of an
enumerated set).

Command Line Interface High-Level Commands

The CLI is menu based. Some commands move to a menu with a
different command set.

The following common commands can be used at all levels of the
command line interface (CLI):

top - Returntothe top level of the CLI hierarchy, or the username
prompt.

history - Displays the last 200 commands the user entered into
the KX 111 CLI.

logout - Logs the user out of the current session.

quit - Moves the user back one level in the CLI hierarchy.

help - Displays an overview of the CLI syntax.

Connect to DSAM Serial Targets with KX3 GUI

Raritan.

A brand of Lllegrand

To connect to DSAM serial targets:
In the Port Access page, click the View By Serial tab to view the
serial targets.
Click the port name you want to connect to. Click Connect.
[ View By Group | View By Search| Set Scan|
Availability

4 L Front DSAM up

4.1 DCE up idle

42 AUTO down idle

43 DSAM4 Port 3 AUTO down idle

44 DSAM4 Port 4 AUTO down idle

32 Rows per Page
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3. The HTML Serial Console (HSC] window opens. See HTML Serial
Console [see "HTML Serial Console [HSC] Help" on page 134)

[ Viewy Group] View By Sear | s Scan|
4 v DsAM4 Front DSAM up
4.1 DSAM4 Port 1 DCE up connected
(@) Raritan HTML Serial Console : DSAM4 Port 1 (401) - Google Chr... L= | (). [P
A b#7%//192.168.61.14/hsc_js/hsc_js.htm|?port=401&SessionKey=3a96bdd5deeel822" @

EMULATOR EDIT POWER HELP

Successfully Connected!

h

4. To exit the serial port, hit the hot-key. Default hot key is
Scrolllock-Scrollock.

Connect to DSAM Serial Target with URL Direct Port Access
1. Choose Device Settings > Device Services, then select the Enable
Direct Port Access via URL checkbox.
2. To connect with direct port access, type the URL:

"https://<KX3 IP Address>/dpa.asp?port=<serial port
number>&username=<user name>&password=<password>"

Example:
https://192.168.51.101/dpa.asp?port=4.1&username=admin&passwo
rd=raritan0

3. HTML Serial Client (HSC) launches and connects to the serial target.

132 Raritan.

A brand of Ellegrand



Chapter 6: Serial Access With Dominion Serial Access Module

Connect to DSAM Serial Target via SSH
1. Choose Device Settings > Device Services, then select the Enable
SSH checkkbox.
Launch SSH client in client PC to connect to KX3.
After login, user will enter CLI interface.

Type command “connect <serial port number>", or type command
“connect <name of serial port>".

Example-1: connect 4.1
Example-2: connect "DSAM4 Port1”

If successful, serial target is accessed.

6. To exit serial target, type escape-key-sequence, default is Ctrl-],
then enter port sub-menu CLI interface.

7. Type "quit”, then enter main CLI interface.
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HTML Serial Console (HSC) Help

Use HSC to connect to serial targets from SX2. HSC is also launched
when accessing SX2 targets in CC-5SG. Note: HSC does not support
CC-SG's proxy mode in release 6.2.

Note: You can also access targets via Direct Port Access, command line
interface [CLI], local port GUI, and SSH.

N

[Useranagement Devie Seting [ Waintenance | Dagnostcs et
Ty, & —

Home = Ports

Time & Session:
June 09, 2016 11:37:47 Port Access

gts'f“ aadm'm'cn Click on the individual port name to see alfowable operations.
ate: & min 1dle

YourIP: 192.168.32.163

4 HNo. Nal T Statu
Last Login: Jun 09, 2016 11:24:40 e b s
1 192.168.61.142 DTE up
Device Information: @ Raritan HTML Serial Console : 192.168.61.142 (1) - Mozilla Firefox == (5] |5 u
Device Name: DominionSix - - up
IP Address: 8  hitps;//192.168.61.17/hsc_js/hsc_js.htmli?port=1&SessionKey=94a3ab631873c13¢ up
192.168.61.17
fd07:2fa:6cf2032:20d: 54f up
Firmware: 2.1.0.5.1238 EMULATOR EDIT POWER HELP
Device Model: DSX2-48 ! ue
Metwork: LAM1 up
Powerln1: on
Powerln2: on up
up
Port States: up
43 Ports: up up
47 Ports: idle
1 Port: connected up
up
Connected Users: up
admin {(192.168.60.41) up
7 min idle
admin (192.168.32.163) up
3 min idle up
up
Online Help up
up
up
up
Write Access Encoding: utf-8 Term Size: 80 x 25 up
\ up

HSC Functions

Emulator

IMPORTANT: HSC sessions are affected by the KX Il Idle Timeout.
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If you have not changed the KX Il Idle Timeout setting from the
default, your session could be closed automatically if it exceeds the
Idle Timeout period.

Change the default Idle Timeout setting and then launch the HSC.
See Login Limitations for details on changing the Idle Timeout
setting.

Access Emulator Options

1. Select the Emulator drop-down menu to display a list of options.

Q Raritan HTML Serial Console : 192.168.61.142 (1) - Mozilla Firefox = = P

@ | hitps://192.168.61.17/hsc_js/hsc_js.htmI?port=1&SessionKey=94a3ab631873c13¢

EMULATOR EDIT POWER HELP

Settings

Get History

Clear History

Get Write Lock

Write Unlock

Send Break

Connected Users...

Write Access Encoding: utf-8 Term Size: 80 x 25 I

Settings
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Note: An Administrator can set Terminal emulation settings using
Setup > Port Configuration.

Choose Emulator > Settings. The Terminal Properties dialog
displays the default settings.

Terminal Properties

Columns: |80 : Rows: 25 =
Foreground: Background:
Font size: 11 = Scrollback: 1000 <
Encoding: utf-8 v Language: English ~

Backspace Sends: Ctrl-H -

OK Cancel

Set the terminal size by selecting the number of Columns and Rows.

Default is 80 by 25.

Set the Foreground and Background colors. Default is white on
black.

Set the Font size. Default is 11.

Set the Scrollback number to indicate the number of lines available
for scrolling.

Choose one of the following from the Encoding drop-down menu:
= US-ASCII

= |S0-8859-1
= |S0-8859-15
= UTF-8

= Shift-JIS

= EUC-JP

= EUC-KR

Choose one of the following from the Language drop-down menu:
= English

= Japanese

= Korean

= Chinese

= Bulgarian

The Backspace Sends default is ASCII DEL, or you can choose
Control-H from the Backspace Sends drop-down menu.
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9. Click OK to save. If you changed the Language setting, the HSC
changes to that language when the Display Settings window is
closed.

Get History

History information can be useful when debugging, troubleshooting, or
administering a target device. The Get History feature:

o Allows you to view the recent history of console sessions by
displaying the console messages to and from the target device.

e Displays up to 512KB of recent console message history. This allows
a user to see target device events over time.

When the size limit is reached, the text wraps, overwriting the oldest
data with the newest.

Notes: History data is displayed only to the user who requested the
history.

To view the Session History, choose Emulator > Get History.

Clear History
= To clear the history, choose Emulator > Clear History.

Get Write Access

Only users with permissions to the port get Write Access. The user with
Write Access can send commands to the target device. Write Access can
be transferred among users working in the HSC via the Get Write Access
command.

To enable Write Access, choose Emulator > Click Get Write Access.
e You now have Write Access to the target device.
e When another user assumes Write Access from you:

= The HSC displays a red block icon before Write Access in the
status bar.

= A message appears to the user who currently has Write Access,
alerting that user that another user has taken over access to the
console.

Get Write Lock

Write lock prevents other users from taking the write access while you
are using it.

1. To get write lock, choose Emulator > Get Write Lock.

2. If Get Write Lock is not available, a request rejected message
appears.
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Write Unlock

To get Write Unlock, choose Emulator > Write Unlock.

Send Break

Some target systems such as Sun Solaris servers require the
transmission of a null character (Break) to generate the OK prompt. This
is equivalent to issuing a STOP-A from the Sun keyboard.

Only users with Write Access privileges can send a break.
To send an intentional “break” to a Sun Solaris server:

1. Verify that you have Write Access. If not, follow the instructions in the
previous section to obtain write access.

2. Choose Emulator > Send Break. A Send Break Ack
(Acknowledgement) message appears.

3. Click OK.

Connected Users

The Connected Users command allows you to view a list of other users
who are currently connected on the same port.

1. Choose Emulator > Connected Users.

User List

* admin

System: Auto Naming

oK

2. Astar appears in the Write column for the User who has Write
Access to the console.

Exit
1. Choose Emulator > Exit to close the HSC.
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Copy and Paste

Data on the current visible page can be selected for copying. Copy and
Paste are accessible in the HSC by right click in the terminal window.
Select Copy or Paste in the context menu that appears.

If you need to paste a large amount of data, it is better to save the data in
a file and use the Send a Text File function. Pasting a large amount of
data in a browser windows can cause the browser to hang as it
processes the data. See Send a Text File [see "Send Text File" on page
139).

When pasting data to a port, the end of a line is sent as a carriage return.
The Cut option on the right-click menu is disabled.

Do not use the Delete option that appears in the right-click menu of |E
and some versions of Firefox. This Delete option will remove display
lines entirely from the emulator window.

P> Browser-specific behaviors

When copying from |E or Edge browsers, there are no end of line
characters in the copied data. The pasted data appears to be all in one
line and contains many spaces. When pasting back into a HSC window,
the data may appear to be misaligned, but the data is complete.

Send Text File
1. Select Edit> Send Text File.
2. Inthe Send Text File dialog, click Browse to find the text file.

3. Click OK.

=  When you click OK, Raritan Serial Console (RSC) sends whatever
file you selected directly to the port.
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If there is currently no target connected, nothing is visible on the
screen.

r

.,- Raritan HTML Serial Console : 192.168.61.142 (1) - Mozilla Firefox L= =1 P

i) a8 https://192.168.61.17/hsc_js/hsc_js.html? port=1&SessionKey=50209b731d00172¢

EMULATOR EDIT POWER HELP

Send Text File

No file selected.

oK Cancel

| File Upload

==
Search 5X2 Text File R I

=- 1 e

Date modified Type

| b SX2TextFile o=

Organize ~ New folder

. i N
. Favorites i GIlc

B Deskiop

| SX2.txt 6/13/2016 5:03 PM  Text Docy

4 Downloads

% Dropbox

m

| == Recent Places

) Libraries
“ Documents
4. Music
= Pictures
%, Videos

S A 1]

File name: SX2.bxt v |Au Files ~|

[ Open H[ Cancel ]

Note, if you are using a Mac® and/or Safari®, do the following in
order to use this feature:

1. In Safari, select Preferences.

2. Under the Security tab, select "Manage Website Settings”
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3. Click on the KX Il website.
4. Select "Run in unsafe mode” from the drop-down box.
5. Restart Safari.

Power Status

Power Status in HSC shows the status of the outlet the target is plugged
into.

1. Choose Power > Power Status.
2. The Notification dialog shows the status of the outlet as ON or OFF.

@ Raritan HTML Serial Console : 192.168.61.142 (1) - Mozilla Firefox L= | (=2 [P

@ | hitps;//192.168.61.17 /hsc_js/hsc_js.htmI?port=1&SessionKey=50209b731d00172¢

EMULATOR EDIT POWER HELP

Notification

192.168.61.142(1) Power
Status : Off

Write Access Encoding: utf-8 Term Size: 80 x 25 |

Power on a Target

Use this option to power on a target from HSC.

This option is visible only when there are one or more power
associations to the target, and when you have permission to manage the
target’'s power.

1. Select Power> Power On.
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2. Click OK'in the success message.

Notification

Power operation succeeded.

oK

Power Off a Target

Use this option to power off a target from HSC.

This option is visible only when there are one or more power
associations to the target, and when you have permission to manage the
target’'s power.

1. Select Power> Power Off.
2. Click OKin the success message.

Notification

Power operation succeeded.

=

Power Cycle a Target

Power cycling allows you to turn a target off and then back on through
the outlet it is plugged into.

This option is visible only when -

e there are one or more power associations to the target

e the target is already powered on (the port status us Up)

e you have permission to manage the target's power

1. Choose Power> Power Cycle.

2. Click OKin the success message.
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Dominion KX Il User Station

To use a standalone appliance for remote access to KX Ill target servers
instead of using the VKC or AKC clients on a PC or laptop, purchase
Dominion User Stations from Raritan. The User Station is perfect for
environments like labs, studios and control rooms where a PC or laptop
is not wanted.

This chapter provides a brief introduction to the User Station. For
detailed information, refer to the user documentation from the User
Station's section on the Raritan website's Support page
(http://www.raritan.com/support/).

In This Chapter

OVEIVIBW ¢ 144
User Station Photo and Features . ... 145
Operating the User Station ... 145
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Chapter 7: Dominion KX Il User Station

Overview

The Dominion User Station (DKX3-UST] is designed to access servers
and computer devices connected to KX [ll's from your LAN/WAN
networks. ALL KX Ill models are supported. KX Ill Release 3.2 and above
is required.

One User Station can access the servers connected to multiple KX lll's so
that you can easily access a large number of servers with a single click.

Note that the User Station does NOT support the access to a target
server which is from a tiered KX Il or a blade server. Use VKC or AKC
clients to access such targets instead.

KX 11l KVM

.-......-.-@i‘?;é‘ﬂ

KX 1Il KVYM

| = ==
Jpmn- 8=

KX 11l KVYM

BRI B

i DKX3-UST

j@@%

A USB Keyboard, USB mouse, and one or two HDMI- or

A DisplayPort-interfaced monitors

B Analog or digital audio appliances

C Optional smart card reader for remote IT device authentication
D External drives as virtual media, such as CD-ROM

E USB drives for virtual media or User Station software update
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User Station Photo and Features

e Supports single or dual monitors

e Two 1080p streaming video sessions at 30 FPS
e Supports VGA, DVI, HDMI and DisplayPort video
e Favorites and hot-key switching

e Access hundreds of servers

e Ultra-fast connections and sub-second switching with the
non-blocking DKX3-808 model

e Dual Gigabit Ethernet ports
e Self-contained, low maintenance appliance
e Desktop, rack and VESA mountable

Operating the User Station

1. Have the required equipment properly connected to the User Station.
a. Power OFF all devices.

b. Connect a USB keyboard, mouse and one or two monitors to the
User Station.

c. Connect the User Station to the LAN/WAN network.
2. Power on and log in to the User Station.

= Forinitial login, use Raritan’s default username and password:
admin and raritan.

3. Add KX llI's data. See Logging In to KX Il [on page 19).
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4. The added KX llI's are displayed in the Port Navigator window.

i A ——-

Favorite Ports

Z=Raritan.

3 MainMeru | Port Navigatoe en o WS i Apr 29,0156

o 2] ©

Click a KX lll to show a list of its servers.

6. Click a target server, and a KVM Client opens, showing the target
video. Now you can control the target with the attached keyboard and
mouse.

For detailed information, refer to the user documentation from the User
Station’s section on the Raritan website's Support page
(http://www.raritan.com/support/).
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Chapter 8

Mobile KVM Client (MKC) Help
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Remotely Access Targets Using a Mobile Device

Raritan.
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KX Il supports remote access to targets from Apple® iPad® and iPhone®
with 10S 4.0 (or later).

Mobile access is provided through Mobile Access Client, which requires
the use of CommandCenter Secure Gateway (CC-SG).

Access and power control of your targets is supported using the Mobile
KVM Client (MKC].

MKC launches automatically from mobile devices. There is no
configuration or selection of MKC required. See Connect to a Target
Using the Mobile KVM Client (on page 148)

You connect to each interface using the same links as when accessing
from PC. When MKC opens, use the touch screen equivalent to each
mouse click operation for navigating. See Touch Mouse Functions (on
page 148).

The mobile device does not provide file storage for keyboard macros, so
keyboard macros that you have created and would like to use in MKC can
be stored on CC-SG with your profile data. You must import user-defined
keyboard macros, using the desktop Access Client, before they will be
available in MKC. See Manage Mobile Client Keyboard Macros (on page
152).
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Connect to a Target Using the Mobile KVM Client

Mobile access using the Mobile Access Client requires the use of
CommandCenter Secure Gateway (CC-SG]).

Enable pop-ups in your mobile device browser before accessing Mobile
KVM Client (MKC) or CC-SG Mobile Access Client.

MKC does not support connections over |IPvé.

> To connect to a target via KX Il on a mobile device:

1. Login to the Access Client using your mobile device browser.

2. Touch the node you want to access in the node list, then touch the
blue interface link in the Node Profile to the right.

3. The Mobile KVM Client opens and connects to the target.

Touch Mouse Functions

148

Use the touchscreen equivalent for each mouse function to navigate the
Mobile KVM Client (MKC) on your mobile device.

To view this chart in MKC, touch the Help icon (?) in the MKC toolbar.

Single Finger Touch
touch down - move - release

short tap
double short tap

short tap - touch down - move -
release

Two Finger Touch

touch down - move - release

touch down - change distance -
release

short tap
double short tap

short tap - touch down - move -
release

Mouse Equivalent

move mouse pointer
left click
left double-click

hold down left mouse button and
move, as in drag and drop or select

Mouse Equivalent

move screen

resize screen [short pause at 100%
zoom)

right click
right double-click

hold down right mouse button and
move, as in right drag and drop
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Using the MKC Toolbar

The MKC toolbar may not be completely visible at one time, depending
on the resolution of your mobile device.

» To view the whole toolbar:

e Touch and swipe to move the toolbar icons to the left and right,
bringing different icons into view.

> To use the keyboard button icons:

The toolbar contains icons for each keyboard button you may need.
Touch and swipe left and right to view all icons.

e Touch anicon for a button press.

e For a button hold, such as for Control and Alt used in
Control+Alt+Delete, touch the icon once to activate it. The icon color
will darken to indicate it is currently pressed. To release the icon,
touch again.

MKC Toolbar Icons

Depending on your mobile device screen size and resolution, you may not
see all toolbar icons at once. For example, on tablet device, such as an
iPad you may see F4 as the final icon to the right.

? MENU SHIFT CTRL ALT
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Touch and swipe the toolbar to the left, to view the F5 through F12 icons.
Swipe the toolbar back to the right to return to the default view.

On a mobile phone device, such as an iPhone, you will see fewer icons.
Use the same touch-and-swipe motion left and right to view additional
icons.

> Keyboard Icon

Provides access to the mobile device's native soft keyboard. See Display
Mobile Device Keyboard (on page 151).

P Shift (SHIFT) - Control (CTRL) - Alternate (ALT)

Provide the modifier keys to be used together with other keys on the
toolbar. See Using the MKC Toolbar (on page 149).

> Windows (WIN)

Provides access to the Windows Start menu. This is the equivalent of the
Windows key on a standard Windows keyboard.

> Application Key or "Right-Click” Key

Provides access to a right-click menu. This is the equivalent of the
Application key on a standard Windows keyboard. The Application key
has an image of a mouse pointer on a menu, and it is positioned between
the Alt and Ctrl keys to the right of the spacebar.

Touch the Application icon to display the selected item’s right-click
menu.

P> Left Arrow, Up Arrow, Down Arrow, Right Arrow

Provide document navigation.

> Tab (TAB]) - Escape (ESC) - Delete (DEL) - Function 1 (F1) thru
Function 12 (F12)

Provide standard press and release key operation.
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Display Mobile Device Keyboard

Toggle on and off the MKC keyboard to display or hide it.

The keyboard is configured on the mobile device. For example, on iPad
choose Settings > General > Keyboard > International Keyboards to see
the available keyboards or to add a keyboard. From the soft keyboard
touch the globe icon to toggle between available keyboards.

P> To display/hide mobile device keyboard:
e Inthe MKC toolbar, touch the keyboard icon, next to the Menu button
to display the keyboard.

e Inthe keyboard, touch the icon in the bottom right corner to hide the
keyboard.

Display Connection Info

Raritan.
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Display information about your connection to see how much bandwidth is
being used in transmitting and receiving data.

This information can be helpful in determining how much of the available
bandwidth is being consumed, the effect of selecting a lower video
quality setting, or for troubleshooting if image updates are slower than
expected. See Set Video Connection Quality (on page 155).

Incoming kpx/s pixel updates per second
kB/s bytes per second

Outgoing msg/s messages per second
kB/s bytes per second

P> To display connection info:
e |nthe MKC toolbar, touch Menu, then touch Connection Info.

The connection information appears in the viewer.

To turn off the connection information display, touch Menu, then
touch Connection Info. The display toggles off.
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Set Keyboard Type

The default keyboard in MKC is US/International English. Select the
language keyboard to match the language keyboard setting of the target
you are accessing. This is required to provide the correct keyboard
mapping in the target.

You must correctly set the keyboard type in MKC based on the language
mapping required by the target. This setting is in addition to the
keyboard language setting on your mobile device itself.

> To set keyboard type:
1. In the MKC toolbar, touch Menu, then touch Keyboard Type.
2. Touch the keyboard language to set it.

Keyboard Languages

e Danish (Denmark]

e English (UK)

e English (US/Int'l)

e French (Belgium]

e French (France)

e German (Germany)

e German (Switzerland)
e Hungarian

e ltalian (Italy)

e Japanese

e Korean (Korea)

e Norwegian (Norway)
e Portuguese (Portugal)
e Slovenian

e Spanish (Spain)

e Swedish (Sweden)

Manage Mobile Client Keyboard Macros

Each user must import their user-defined keyboard macros to make
them available for use while connected to targets using the Mobile KVM
Client (MKC).

Export the file from Virtual KVM Client (VKC], then import it using the
desktop Access Client. You cannot import macros using a mobile device.
Imported macros are available per user in MKC when you connect to a
target using your mobile device.

152 Raritan.

A brand of Hllegrand’



Chapter 8: Mobile KVM Client (MKC) Help

Launch Keyboard Macro

Pre-defined macros are always available in MKC. You must import
user-defined macros using the desktop Access Client before they are
available on MKC. See Manage Mobile Client Keyboard Macros (on
page 152).

SUN macros are available in MKC if you are connected to a target that
has the SUN CIM.

» To launch keyboard macro:
1. In the MKC toolbar, touch Menu, then touch Keyboard Macros.
2. Touch the macro you want to launch.

The macro is launched and the results display on the target.

Set Mouse Mode

When controlling a target server, the MKC displays two mouse cursors: a
red bullseye indicates where the mobile touch gestures are relative to
the target, and the cursor that belongs to the target server.

Single mouse mode is not available in MKC.

Your mouse will operate in dual mouse mode only. When properly
configured, the two mouse cursors align.

There are several mouse modes when in dual mouse mode. Mouse
modes are available based on the attached CIM and selected USB profile.

e See Absolute Mouse Mode (on page 154).
e See Intelligent Mouse Mode (on page 154).
e See Standard Mouse Mode (on page 154).

» To set mouse mode:
1. In the MKC toolbar, touch Menu, then touch Mouse.
2. Touch Mouse Made, then touch Absolute, Intelligent, or Standard.
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Absolute Mouse Mode

In this mode, absolute coordinates are used to keep the client and target
cursors in synch, even when the target mouse is set to a different
acceleration or speed.

This mode is supported on servers with USB ports and is the default
mode for virtual media CIMs.

Absolute Mouse Synchronization requires the use of a virtual media CIM
e D2CIM-VUSB

e D2CIM-DVUSB

e D2CIM-DVUSB-DVI

e D2CIM-DVUSB-HDMI

D2CIM-DVUSB-DP

Note: For KX II, Absolute Mouse Synchronization is available for use with
the virtual media-enabled USB CIM (D2CIM-VUSB and D2CIM-DVUSB]
only.

Intelligent Mouse Mode

In Intelligent Mouse mode, the device can detect the target mouse
settings and synchronize the mouse cursors accordingly, allowing
mouse acceleration on the target. Intelligent mouse mode is the default
for non-VM targets.

During synchronization, the mouse cursor does a “dance” in the top left
corner of the screen and calculates the acceleration. For this mode to
work properly, certain conditions must be met.

See the Dominion KXII User Guide for more details on Intelligent Mouse
mode.

Standard Mouse Mode

Standard Mouse mode uses a standard mouse synchronization algorithm.
The algorithm determines relative mouse positions on the client and
target server.

In order for the client and target mouse cursors to stay in synch, mouse
acceleration must be disabled. Additionally, specific mouse parameters
must be set correctly.
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Sync Mouse in Intelligent or Standard Mouse Mode

In Intelligent or Standard mouse mode, the Sync Mouse command forces
realignment of the target server mouse pointer with the MKC mouse
pointer.

> To sync mouse:
1. In the MKC toolbar, touch Menu, then touch Mouse.

2. Touch Sync Mouse. Wait several seconds while the synchronization
occurs.

Auto-Sense Video Settings
The Auto-sense Video Settings command forces a re-sensing of the video
settings [resolution, refresh rate) and redraws the video screen.

Auto-sensing video settings can eliminate target video misalignment and
sometimes mouse synchronization problems.

P> To auto-sense video settings:
1. In the MKC toolbar, touch Menu, then touch Video.
2. Touch Auto Sense Video Settings.

Set Video Connection Quality

Adjust the bandwidth consumed by the connection by setting the video
connection quality. A lower quality setting will consume less bandwidth
by providing lower video quality.

Use the connection information display to get bandwidth information to
help adjust the video connection quality. See Display Connection Info
(on page 151).

> To set video connection quality:
1. In the MKC toolbar, touch Menu, then touch Video.

2. Touch Connection Quality Settings, then touch High, Medium, or Low.
The default setting is High.
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View MKC Help

Descriptions of the touchscreen techniques can be accessed in MKC.

> To view MKC help:
e Touch the Help icon (?) icon in the toolbar. The help opens.
e See Touch Mouse Functions (on page 148) to view this information.
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Overview

When you log in to the KX Ill via a network connection, you access the
Remote Console. The first page accessed is the Port Access page.

See Logging In to the KX Il (see "Logging In to KX III" on page 19) and
Port Access Page [Remote Console Display] (on page 22)

Pawer | Virtual Media | User Management | Device Seffings | Security | Maintenance | Disgnostics | Help

Dominton® KX 11 SEEEmen EE Y e, o
Home > Parts ==
Time & Session:
December 05, 2013 142127 Port Access
Usar: admin

Click on the individual port name to see allowable operations.
0/ 4 Remeote K\VM channeis currently in use.

State: 3 min il
Wour P: 192.168.32.165
Last Login: Dec 05, 2013 11:40:42

Devies Information:

3 Availability
Device Name: Dominion KX-sample ¥ ailability
P Addrese. 192 168.61.20 1 HOMI Targ=t D I-HDRI =] ide
Firmware: 3.0.0.1.369 ini -
et H Dorinion-KX2_Port2 TVIA-DV up it
Hetworic LAN1 3 Low Cost DV [PO20540016] Duakyi ug g
Fowernt: or -

4 P
FowernZ: off findnws HPSF pei w o
Configurad Az Bage 5 DP-Daaminion-KXZ_Paort13 VIA-DP =] de
1 § Dorini DC up it

Fort States: T Domnien-Ka2_Pert? Duakh ug i
353 Ports: up - - .

54 Porie: down 8 po-kef-update Hot Avaiabl dawn e

413 Ports: die £l W KNESA-A0-224-TerS TierDevice ug e

10 b @32 50241 terd TierDevics ug ke

Connecled Users: " ¥ KXB3Z-51-14-Tiarl TiarDavica ug e

admn (Local Console )
38 min idle : 114 DM mulatorPortl29 DeW wn de
odmin (152 16832 165) 112 DC MSimulatorPorti?5 oCid up e
3 min idle
e 13 DC MSimulatarPartia? D uw de
11-4 DCMSImulatorPorti3s Do ug e
nline Halp

/
S

\
.
Favorite Devicss: [ 21 2] 5] -vewese 15 Rows per Pags[ Set

Use the Remote Console to access and scan target servers, manage
favorites, and change your password.

For more in the Remote Console interface elements, see KX I/l Remote
Console Interface (on page 21).
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Scanning Ports - Remote Console

Use the port scanning feature to search for selected targets and display
them in individual thumbnails as part of a slide show.

This feature allows you to monitor up to 32 targets at one time since you
can view each target server individually as it is displayed during the slide
show.

Connect to targets or focus on a specific target as needed.

Scans can include standard targets, blade servers, tiered Dominion
devices, and KVM switch ports.

For dual video port groups, the primary port is included in a port scan,
but the secondary port is not included when connecting from a remote
client. Both ports can be included in the scan from the Local Port.

Note: The scan port feature is available from the Remote Console and
Local Console, but the feature varies slightly.
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Scanning Ports Slide Show - Remote Console
When you start a scan, the Port Scan window opens.
As each target is found, it is displayed as a thumbnail in a slide show.

The slide show scrolls through the target thumbnails based on the
default interval of 10 seconds or according to the interval you specify.

As the scan scrolls through the targets, the target that is the focus of the
slide show displays in the center of the page.

The name of the target is displayed below its thumbnail and in the task
bar at the bottom of the window.

If a target is busy, a blank screen is displayed instead of the target server
access page.

L Port Scan - Viroual KVM Ciient S O . T s S — L,  RCtiey

Scan Options

il ® » Control Panel > All Control Panet ltems » Display » Screen Resolution

I , | L - Damiion X2 _Ports

Change the appearance of your display

[1. Rantan ant ~|

B 2-xx3 L0l Port
[1440-900

[lmds(epr

B« - T1oRE416HKCT200. .

B 5 - Dorinicn 02 _Forts
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Configure scan settings for the Remote Console from VKC, VKCS, or
AKC.

See Configuring Port Scan Settings in VKC/VKCS and AKC (on page
72)

Note: Scan port settings for the Local Console are configured on the
Local Port Settings page. See Scanning Ports - Local Console [on page
172)
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Target Status Indicators During Port Scanning - Remote Console

The status of each target is indicated by green, yellow and red lights that

are displayed below the target thumbnail.

As the target is the focus of the rotation, the indicator is in the task bar

also shows the status.

Lights for each target are gray until they are the focus of the slide show.

The status lights indicate the following:

e Green - the target is up/idle or up/connected
e Yellow - the target is down but connected

e Red - the target is down/idle, busy, or otherwise not accessible

|44 Port Scan - Virtual KVM Client i k
Scan Options

» Control Paned » Af Control Paned ltems » Display » Streen Resolution

Change the appearance of your display

Oisplay: [2. Rantan v ~|

Resclutior: [1s0x00 ~|

Crientation: ‘ Landscape

va

L ) 1 -Dominion-K32_PortS

b 2 - KX3 Local Port

B 4 - T1D0-H6+KET200. .

B 5 - Dorinicn002_Ports

2] £ -DomnionX3 Ports [
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Using Scan Port Options

Following are options available to you while scanning targets.

With the exception of the Expand/Collapse icon, all of these options are
selected from the Options menu in the upper left of the Port Scan viewer.

The options will return to their defaults when you close the window.

Note: Configure scan settings such as the display interval from either the
Virtual KVM Client (VKC] or Active KVM Client [AKC]. See Configuring
Port Scan Settings in VKC/VKCS and AKC (on page 72]

>

Hide or View Thumbnails

4
Use the Expand/Collapse icon P at the upper left of the window to
hide or view thumbnails. Expanded is the default view.

Pause the Thumbnail Slide Show

Pause thumbnails from rotating between one target and the next by
selecting Options > Pause. Rotating thumbnails is the default setting.

Resume the Thumbnail Slide Show
Resume the thumbnail rotation by selecting Options > Resume.

Size the Thumbnails in the Port Scan Viewer

Enlarge the size of the thumbnails by selecting Options > Size >
360x240.

Minimize the size of the thumbnails by selection Options > Size >
160x120. This is the default thumbnail size.

Change the Orientation of the Port Scan Viewer

View thumbnails along the bottom of the Port Scan viewer by
selecting Options > Split Orientation > Horizontal.

View thumbnails along the right of the Port Scan viewer by selecting
Options > Split Orientation > Vertical. This is the default view.

161



Chapter 9: KX Il Remote Console

|4, Port Scan - Virtual KVM Client
Scan Options

Fause
Resume
Thumbnail Size ¥
Spht Orientation »

» Control Panel » Al Control Paned ltems » Display » Screen Resolution

Change the appearance of your display 1 - Dominion-22_Ports

Display: [2 Raritan M |

D 2 -x3LozlPort

Resclutiont ‘ 1440 = 900 ']

Scan for Targets

P> To scan for targets:
1. Click the Set Scan tab on the Port Access page.

2. Select the targets you want to include in the scan by selecting the
checkbox to the left of each target, or select the checkbox at the top
of the target column to select all targets.

3. Leave the Up Only checkbox selected if you only want targets that
are up to be included in the scan. Deselect this checkbox if you want
to include all targets, whether up or down.

4. Click Scan to begin the scan.
As each target is scanned, it is displayed in slide show view on the

page.
Home » Ports Logout
Port Access
Click on the individual port name to see allowable operations.
0 /4 Remote KM channels currently in use.
ﬁ -Sl:au _Seau.'h
View By Port | View By Group | View By Search - -

Up Only Availability

& 2 Low Coat OV [PU20540016] DuskvH uo de
| 3 DA-Dominien-HX2_Porl13 DVN-OP ug itk
i 4 WinkP-C2 Duakvi up de
i 5 Daminion-+2_Ports U] up die
= ] Dominion-#242_Ports DuaH¥M ug die
X, ,
50 ann:e'Panem
- T et I S B s T A ot e W e B e S S

5. Click Options > Pause to pause the slide show and stop it from
moving between targets, click Options > Resume to resume the slide
show.

6. Click on atarget thumbnail to scan it next.
Connect to a target by double clicking on its thumbnail.
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Changing a Password

Raritan.
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P> To change your KX Ill password:

1. Choose User Management > Change Password. The Change
Password page opens.

2. Type your current password in the Old Password field.

3. Type a new password in the New Password field. Retype the new
password in the Confirm New Password field. Passwords can be up
to 64 characters in length and can consist of English alphanumeric
characters and special characters.

4. Click OK.

You will receive confirmation that the password was successfully
changed. Click OK.

Note: If strong passwords are in use, this page displays information
about the format required for the passwords. For more information
about passwords and strong passwords, see Strong Passwords in online
help.

Home = User Management = Change Fasaword

Change Password

Old Password

Hew Password

Confirm Hew Password

OK | Cancel
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Managing Favorites

A Favorites feature is provided so you can organize and quickly access
the devices you use frequently.

The Favorite Devices section is located in the lower left sidebar of the

Port Access page and provides the ability to:

Create and manage a list of favorite devices
Quickly access frequently-used devices

List your favorites either by Device Name, IP Address, or DNS

hostname

Discover KX Il devices on its subnet

Retrieve discovered KX Il devices from the connected Dominion

device

Enable Favorites

=i=Raritan.

Dommini

Time & Seasion:
January 01, 2000 22:52:18

User: admin

Siata: aciive

Your P 182 16832 179

Last Login: Jan 01, 2000 19:51:08

Click Enable in the Favorite Devices section of the left panel of the

KX lll interface.

Port Access

Cillck an the Inaivic
0/ & Remote KM ¢

Wiew By Port | "iew By
Device Information:
& Ho. 2
Davica Mame: Dominionl N Nam:
IP Address: 152.185.61.20 1 Window
Firrmwara: 3.0.0.1.444 —
Diewice Model D ’ Lowi Co
Matworks Lan 3 DA-Dom
Powserin1: on . o—
5 Draminic
a Domin
Port States: minio
5 Ports: up o Fr—
27 Poris: down
32 Poria: die & Domink
] Dominio
Connected Users: 10 Dominia
admin (182.163.32.179) 1 Cominio
actwe - p—
13 Dominio
Online Help =
4 14 Dominia
15 Domink
Favorite Devices: —
16 Dominia
Enahl= h = E—
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Access and Display Favorites

» To access a favorite KX Il devices:

e Click ona KX lll listed beneath Favorite Devices in the left of the
Remote Console.

P> To display favorite KX llls by name:
e Click Display by Name.

P> To display favorite KX llls by IP Address:
e Click Display by IP.

P> To display favorite KX llls by the host name:
e Click Display by Host Name.

Favaorite Devices:
Somerset
Tokyo
Raleigh

| Manage| | Display By Name |

[ Display By Host Name | | Display By IF |

Discovering Devices on the Local Subnet

This option discovers KX Il devices on your local subnet. This is the
subnet where the KX Il Remote Console is running.

These devices can be accessed directly from this page or you can add
them to your list of favorites.

» To discover devices on the local subnet:

1. Choose Manage > Discover Devices - Local Subnet. The Discover
Devices - Local Subnet page appears.

2. Choose the appropriate discovery port:

= To use the default discovery port, select the Use Default Port
5000 checkbox.

To use a different discovery port:

Deselect the Use Default Port 5000 checkbox.
Type the port number in the Discover on Port field.
c. Click Save.

o
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3. Click Refresh. The list of devices on the local subnet is refreshed.

> To add devices to your Favorites List:
1. Select the checkbox next to the device name/IP address.
2. Click Add.

» To access a discovered device:

e Click the device name or IP address for that device. A new browser
opens to that device.

Discovering Devices on the KX Il Subnet
This feature is only available in the Java client , RSC.

This option discovers KX IIl devices on the device subnet. This is the
subnet of the KX Ill device's IP address.

You can access these devices directly from the Subnet page or add them
to your list of favorites.

This feature allows multiple KX Ill devices to interoperate and scale
automatically.

The KX Ill Remote Console automatically discovers the KX Il devices, and
any other Raritan device, in the subnet of the KX Il1.

» To discover devices on the device subnet:

1. Choose Manage > Discover Devices - KX Ill Subnet.

Favaorite Devices:
Somerset
Tokyo
Raleigh

|

| Manage | | Display By Name |

[ Display By Host Name | | Display By IP |

The Discover Devices - KX IIl Subnet page appears.

2. Click Refresh. The list of devices on the local subnet is refreshed.

P> To add devices to your Favorites List:
1. Select the checkbox next to the device name/IP address.
2. Click Add.

Raritan.
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» To access a discovered device:

e Click the device name or IP address for that device. A new browser
opens to that device.
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KX Il Local Console

In This Chapter
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Overview

The Local Console interface provides access to the KX lll while at the
rack.

This section contains help on tasks performed by end users at the Local
Console.

Accessing a Target Server

Raritan.
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P> To access a target server:

1. Click the Port Name of the target you want to access. The Port Action
Menu is displayed.

2. Choose Connect from the Port Action menu. The video display
switches to the target server interface.
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Local Console Video Resolution Behavior

By default, monitors are typically set to the highest resolution they
support.

Once a monitor is connected to the KX Il Local Console, KX Il detects
the monitor's native resolution. As long as the native resolution is
supported by the Local Console, KX lll uses that resolution.

If the native resolution is not supported by the Local Console, and no
other resolution is supported by the monitor and Local Console, KX Il
uses the resolution of the last monitor that was connected to the Local
Console.

For example, you connect a monitor set to a resolution of
1600x1200@60Hz to the KX Il Local Console. KX Il uses that resolution
since it is supported by the Local Console.

If the next monitor you connect to the Local Console is not set to a
supported resolution, KX Il uses the resolution of 1024x768(@60.

For a list of supported Local Console video resolutions, see Supported
KX Il Local Port DVI Resolutions (see "KX Il Supported Local Port
DVI Resolutions” on page 196).

Consider reviewing Video Mode and Resolution Notes (on page 229) for
additional information.

Simultaneous Users

The KX Il Local Console provides an independent access path to the
connected KVM target servers.

Using the Local Console does not prevent other users from
simultaneously connecting over the network. And even when remote
users are connected to the KX Ill, you can still simultaneously access
your servers from the rack via the Local Console.

Local Port Hot Keys and Connect Keys

Because the KX Il Local Console interface is completely replaced by the
interface for the target device you are accessing, a hot key is used to
disconnect from a target and return to the local port GUI.

A connect key is used to connect to a target or switch between targets.

The Local Port hot key allows you to rapidly access the KX Il Local
Console user interface when a target device is currently being viewed.

See Select the Local Port Hotkey and Select the Local Port Connect Key
for more information.

Raritan. 169
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Return to the Local Console from a Target Device - Default Hot Key
e Pressthe Scroll Lock hot key twice rapidly

The video display switches from the target device interface to the KX
[Il Local Console interface.

Local Port Auto-Sense (Video Refresh] - Default Hot Key

P> To perform an auto-sense (video refresh) on the KX Ill local port
via hot key:

e Press and hold the Shift key, and quickly press the Scroll Lock key
twice, and then release.

Connect Key Examples

Standard servers

Connect key action Key sequence example

Access a port from the e Press Left ALT > Press and Release 5 > Release Left
local port ALT

Switch between ports e Press Left ALT > Press and Release 1 > Press and

Release 1 > Release Left ALT

Disconnect from a target e Double-click Scroll Lock
and return to the local port

Blade chassis

Connect key action Key sequence example
Access a port from  Access port 5, slot 2:

the local port GUI o Press Left ALT > Press and Release 5 »
Press and Release - > Press and Release
2 > Release Left ALT

Switch between Switch from target port 5, slot 2 to port 5, slot
ports 11:

e Press Left ALT > Press and Release 5 >
Press and Release - > Press and Release
1> Press and Release 1 > Release Left ALT

Disconnect from a Disconnect from target port 5, slot 11 and
target and returnto  return to the local port GUI (the page from

Raritan.
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which you connected to target):
Double Click Scroll Lock

Special Sun Key Combinations

The following key combinations for Sun™ Microsystems server’s special
keys operate on the Local Console port. These special keys are available
from the Keyboard menu when you connect to a Sun target device:

Sun key
Again
Props
Undo
Stop A
Front
Copy
Open
Find
Cut
Paste
Mute
Compose
Vol +
Vol -
Stop

Power

Raritan.
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Local port key combination
Ctrl+ Alt +F2

Ctrl + Alt +F3

Ctrl + Alt +F4
Break a

Ctrl + Alt + F5
Ctrl+ Alt + F6

Ctrl + Alt + F7

Ctrl + Alt + F9

Ctrl + Alt + F10
Ctrl + Alt + F8
Ctrl+ Alt + F12
Ctrl+ Alt + KPAD *
Ctrl + Alt + KPAD +
Ctrl + Alt + KPAD -
No key combination

No key combination
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Scanning Ports - Local Console

Use the port scanning feature to search for selected targets and display
them in individual thumbnails as part of a slide show.

This feature allows you to monitor up to 32 targets at one time since you
can view each target server individually as it is displayed during the slide
show.

Connect to targets or focus on a specific target as needed.

Scans can include standard targets, blade servers, tiered Dominion
devices, and KVM switch ports.

For dual video port groups, the primary port is included in a port scan,
but the secondary port is not included when connecting from a remote
client. Both ports can be included in the scan from the Local Port.

Click on the thumbnail of any target server to exit scan mode and
connect to the target, or use the Local Port ConnectKey sequence.

To exit scan mode, click the Stop Scan button in the thumbnail view, or
use the DisconnectKey sequence hot key.

Note: The scan port feature is available from the Remote Console and
Local Console, but the feature varies slightly. See Scanning Ports -
Remote Console (on page 158)
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Scanning Port Slide Show - Local Console
When you start a scan, the Port Scan window opens.
As each target is found, it is displayed as a thumbnail in a slide show.

The slide show scrolls through the target thumbnails based on the
default interval of 10 seconds or according to the interval you specify.

As the scan scrolls through the targets, the target that is the focus of the
slide show displays in the center of the page.

The name of the target is displayed below its thumbnail and in the task
bar at the bottom of the window.

If a target is busy, a blank screen is displayed instead of the target server
access page.

Configure the time between the slide show thumbnail rotation and the
thumbnail focus interval on the Local Port Settings page.

See Configure Local Console Scan Settings (on page 175)

Note: Configure scan settings for the Remote Console from VKC, VKCS,
or AKC. See Configuring Port Scan Settings in VKC/VKCS and AKC (on
page 72]

Connection USB Profile Keyboard Video Mouse Tools Yiew Vitusl Media Audio SmartCard Help
BREDREEAQYDO® @

i=Raritan
HEEYerErTn e ¥ 2Z202——Sameameae———————————

Scanning.

#3-6: Blade Chassis_Portd_Slots £4-1: Blade Chassis Portd_Slotl #4-2: Blade_Chassis_Portd Slot2

scanned

R

scanned connecting
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Connection USB Profile K Video Mouse Tools View Virtual Media Audio SmartCard Help

SGREIEREBEQAILOe mE

Welcome
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Target Status Indicators During Port Scanning - Local Console

In thumbnail view on the Local Console, the status of each target is
indicated below the thumbnail on the page until it is the focus of the slide
show view.

The scanning status of each target is displayed as:

e not scanned
e connecting
e scanned

e skipped

Connection USB Profile Keyboard Video Mouse Tools View Virtual Media Audic SmartCard Help

B REHEKEEQDDE B @

=Z=Raritan.

Scanning...

#3-6: Blade_Chassis_Port4_Slot6 #4-1: Blade_Chassis_Port4_Slotl #4-2: Blade_Chassis_Port4_Slot2

scanned ! scanned connecting !

=] =]

Configure Local Console Scan Settings

Do the following to configure Local Console scan port options.

Note: Configure scan settings for the Remote Console from VKC, VKCS,
or AKC. See Configuring Port Scan Settings in VKC/VKCS and AKC (on
page 72)

P> To configure the Local Console scan port settings:
1. Onthe Local Console, select Device Settings.
In the Local Port Settings section, select Local Port Scan Mode.

3. Change the display interval as needed:
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= Display Interval - changes the scan display interval.

= |Interval Between Ports - change interval between switching
different port during scan.

Scan for Targets - Local Console

P> To scan for targets:
1. Click the Set Scan tab on the Port Access page.

2. Select the targets you want to include in the scan by selecting the
checkbox to the left of each target, or select the checkbox at the top
of the target column to select all targets.

3. Leave the Up Only checkbox selected if you only want targets that
are up to be included in the scan. Deselect this checkbox if you want
to include all targets, whether up or down.

4. Click Scan to begin the scan.

As each target is scanned, it is displayed in slide show view on the
page.
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Local Console Smart Card Access

Raritan.
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To use a smart card to access a server at the Local Console, plug a USB
smart card reader into the KX Ill using one of the USB ports located on
the KX1I1.

Once a smart card reader is plugged in or unplugged from the KX IlI, the
KX Ill autodetects it.

For a list of supported smart cards and additional system requirements,
see Supported Smart Card Readers (on page 206), Unsupported Smart
Card Readers (on page 207) and Smart Card Minimum System
Requirements (on page 205).

When mounted onto the target server, the card reader and smart card
will cause the server to behave as if they had been directly attached.

Removal of the smart card or smart card reader will cause the user
session to be locked or you will be logged out depending on how the card
removal policy has been setup on the target server 0S.

When the KVM session is terminated, either because it has been closed
or because you switch to a new target, the smart card reader will be
automatically unmounted from the target server.

P> To mount a smart card reader onto a target via the KX Il Local
console:

1. Plug a USB smart card reader into the KX Il using one of the USB
ports located on the device. Once attached, the smart card reader
will be detected by the KX Il1.

From the Local Console, click Tools.

3. Select the smart card reader from the Card Readers Detected list.
Select None from the list if you do not want a smart card reader
mounted.

4. Click OK. Once the smart card reader is added, a message will
appear on the page indicating you have completed the operation
successfully. A status of either Selected or Not Selected will appear
in the left panel of the page under Card Reader.
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> To update the Card Readers Detected list:

e Click Refresh if a new smart card has been mounted. The Card
Readers Detected list will be refreshed to reflect the newly added
smart card reader.

Select Card Reader

Card Readers Detected

USE SmartCard Reader {Gemplus)

0K Refresh | Cancel |

Local Console USB Profile Options

From the USB Profile Options section of the Tools page, you can choose
from the available USB profiles.

The ports that can be assigned profiles are displayed in the Port Name
field and the profiles that are available for a port appear in the Select
Profile To Use field after the port is selected. The profiles selected for
use with a port appear in the Profile In Use field.

> To apply a USB profile to a local console port:

1. In the Port Name field, select the port you want to apply the USB
profile to.

2. Inthe Select Profile To Use field, select the profile to use from
among those available for the port.
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3. Click OK. The USB profile will be applied to the local port and will
appear in the Profile In Use field.

USB Profile Options

Port Name Select Profile To Use

No Port Selected = | Genenc

1

A _s-’\,"'\ \: 7 "\ e A0

Mac 05-X (104 9 and laten)

HP Proliant DL360/DL380 G4 (Windows 2003 Server

CR

Profile In Use

l

ox| Refresh | Cancel |

p "

‘--""‘"""‘“‘\‘““’M'A.“;r"‘\“- ) “’_‘____J.A' ‘.,._. --r~~-- -,’ ,;u\.J;.A«..-

KX 1l Local Console Factory Reset

Raritan.
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Note: It is recommended that you save the audit log prior to performing a
factory reset.

The audit log is deleted when a factory reset is performed and the reset
event is not logged in the audit log. For more information about saving
the audit log, see Audit Log.

> To perform a factory reset:
1. Choose Maintenance > Factory Reset. The Factory Reset page opens.
2. Choose the appropriate reset option from the following options:

= Full Factory Reset

Removes the entire configuration and resets the appliance
completely to the factory defaults.

Note that any management associations with CommandCenter
will be broken.

Because of the complete nature of this reset, you will be
prompted to confirm the factory reset.

= Network Parameter Reset

Resets the network parameters of the appliance back to the
default values (click Device Settings > Network Settings to access
this information).
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3. Click Reset to continue. You will be prompted to confirm the factory
reset because all network settings will be permanently lost.

4. Click OK proceed. Upon completion of full factory reset, the KX 1lI
device is automatically restarted.

Resetting the KX Ill Using the Reset Button on the Device

On the back panel of the device, there is a Reset button. It is recessed to
prevent accidental resets (you need a pointed object to press this
button).

The actions that are performed when the Reset button is pressed are
defined on the Encryption & Share page. See Encryption & Share.

Note: It is recommended that you save the audit log prior to performing a
factory reset.

The audit log is deleted when a factory reset is performed and the reset
event is not logged in the audit log. For more information about saving
the audit log, see Audit Log.

> To reset the device:
1. Power off the KX III.
Use a pointed object to press and hold the Reset button.

3. While continuing to hold the Reset button, power the KX Il device
back on.

4. Continue holding the Reset button for 10 seconds.

L) " " ” ” - 13 - » » w » » » L L)
" " -~ ey -

" " » n n n 4
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Appendix A Connecting a KX Ill and Cat5 Reach

DVI - Provide Extended Local Port
Functionality

An extended local port extends the reach of the local port beyond the
rack the KX Ill is located, for example to another KVM switch.

This can be achieved by configuring a KX lll to work with a Raritan Catb
Reach DVI transmitter and receiver, which are then connected to a
remote console or other device.

Once connected to the Catb Reach DVI, the KX Il can be accessed up 500
feet (152 m) away.

Connecting the KX Il to the Cat5 Reach DVI by daisy chaining Ethernet
switches extends can extend the KX llI's reach up to 3000 feet (914 m).

In This Chapter

About the Cath ReaCh DVl ... e 181
Connect Catbh Reach DVl and Catb Reach DVI ..o 182

About the Cat5 Reach DVI

Raritan.

A brand of Lllegrand

For details on the Cat5 Reach DVI, see the Cat5 Reach DVI online help
available on the Raritan Support page
http://www.raritan.com/support.

Contact Raritan (http://www.raritan.com/contact-us/) for additional
information on the Cat5 Reach DVI, or for information on purchasing.
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Connect Catb Reach DVI and Catb Reach DVI

Note: The images used in the diagrams are not specific to Cath Reach
DVI but the connections are accurate.

This section introduces three scenarios involving KVM switches.

e Connect the Cat5 Reach DVI between any KVM switch and its local
console.

e Connect the Cath Reach DVI between two KVM switches.

e Connect the Cath Reach DVI between a computer/server and a KVM
switch.

Turn off all devices before making the connections.

For detailed information on setting up the local and remote consoles,
see Connecting a Keyboard/Mouse/Video Source in Catb Reach DVI
Help for more information.

» To connect Catb Reach DVI and Cath Reach DVI:

1. If you have not already done so, set up the local and remote consoles
with the Cat5 Reach DVI transmitter and receiver, respectively.
See Basic Installation in Catb Reach DVI Help for more
information.
Use a Catbe/6 cable to connect the transmitter and receiver.

3. Connect the transmitter and receiver to an appropriate power source
respectively.

4. Connect the local console ports of the KVM switch to the transmitter.
a. Plug one end of the Raritan-provided DVI cable into the DVI-I IN

port on the transmitter, and the other end into the KVM switch's
video port.

b. Plug the USB-B connector of the Raritan-provided USB cable
into the USB-B port on the transmitter, and the other end into
the KVM switch's local USB-A port.
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5. Turn on the KVYM switch.
KVM

CYEDe
(=@ -

B8 ST

1]

io

[l |

L=
e
_ e g

Tip: The local or remote console can be equipped with a KVM drawer
instead of a set of keyboard, mouse and monitor. See the illustration
below.

[ T T S T A ] O O 3

» Toincrease the distance between two tiered KVM switches:
1. Setup aremote console by connecting the receiver to a KYM switch.
a. Connecta USB CIM to the receiver.

b. Connect this USB CIM to any channel port on the KVM switch via
a Catb cable.

Use a Catbe/6 cable to connect the transmitter and receiver.

3. Connect the transmitter and receiver to an appropriate power source
respectively.

4. Connect the KVM switch to the transmitter.
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5. Turn on both KVM switches.

||||||||

111

H { s as

- 00 I
)

> Toincrease the distance between any computer and a KVM
switch:

Set up an optional local console with the transmitter.
Set up aremote console by connecting the receiver to a KVM switch.
Use a Catbe/6 cable to connect the transmitter and receiver.

Mo~

Connect the transmitter and receiver to an appropriate power source
respectively.

Connect the computer to the transmitter.
Turn on the computer.
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Appendix B Accessing a Paragon Il from the KX

In This Chapter

OVBIVIBW ettt ettt ettt et e et e et e e ee e e smte e emteeenneeesnneeeneeas 185
Supported Paragon || CIMS and Configurations ........ccccoceeviiiiieiiiennnn 186
Connecting the Paragon 11 to the KX 1. 191

Overview
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Connect the Paragon Il system to a KX Ill device that is managed by
CC-SG so that Paragon Il is accessible from CC-SG.

This diagram indicates the configuration integrating KX I1I.

Note: The images are for example purposes only, and may not look
exactly like your device.

GRS

HE SSHEssnaing

0 The Paragon Il system involving Paragon |l switches,

servers and user stations

(2] The user station with a DCIM-USB G2 attached
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(3] KX 111

When you access the Paragon Il system from KX Il or CC-SG [if the KX IlI
is managed by CC-SG), the Paragon Il OSUI login screen appears for you
to log in.

In this integration, you can perform any OSUI functions implemented
with current Paragon Il firmware or any KX Il function implemented with
current KX Il firmware except for the virtual media feature.

When accessing the Paragon [ OSUI through KX III, DO NOT attempt to
synchronize the mouse manually. A mouse is not necessary on the OSUI
screen and mouse synchronization will delay the keyboard response for
seconds.

See Supported Paragon Il CIMS and Configurations (on page 186) for
additional information.

Supported Paragon Il CIMS and Configurations

The KX Il supports the P2CIM-APS2DUAL and P2CIM-AUSBDUAL CIMs,
which provide two RJ45 connections to different KVM switches.

Support of these CIMs provides a second path to access the target in the
event that one of the KVM switches is blocked or fails.

Paragon CIM Supports Does not support

P2CIM-APS2DUAL e Servers with IBM® e Virtual media
PS/2-type keyboard e  Smart cards

and mouse ports e Absolute Mouse

e Automatic skew mode
compensation (when  §  jse with blade
the CIMs are chassis
connected to Paragon Cascaded KVM
I, not from a KX Il1) - -

configurations

e Intelligent Mouse
mode

e Standard Mouse
mode
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Paragon CIM
P2CIM-AUSBDUAL

Appendix B: Accessing a Paragon Il from the KX Il

Supports

Servers with USB- or
Sun™ USB-type
keyboard and mouse
ports

Automatic skew
compensation (when
the CIMs are
connected to Paragon
[, not from a KX II1)

Intelligent Mouse
mode

Standard Mouse
mode

Does not support

Virtual media
Smart cards
Absolute Mouse
mode

Use with blade
chassis
Cascaded KVM
configurations
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KX I11-to-KX Il Paragon CIM Guidelines

The following system configuration guidelines should be followed when
you are using Paragon CIMs in a KX IlI-to-KX Il configuration:

Concurrent Access

Both KX 1lIl KVM switches should be configured with the same policy for
concurrent access to targets - both PC-Share or both Private.

If Private access to targets is required, both KVM switches must be
configured accordingly:

e From Security > Security Settings > Encryption & Share, set PC
Share Mode to ‘Private’

This guarantees that concurrent access to targets is prohibited, for all
targets by all user groups.

The KX Il allows for more granular control of concurrent access to
targets on a per user group basis. This is done by setting the user
group’s PC Share permissions. However, this is only enforced within
the boundary of a KX Ill.  User Group PC Share permissions must not be
relied on if Privacy must be guaranteed when using the
P2CIM-APS2DUAL or P2CIM-AUSBDUAL with the KX III.

CIM Name Updates

The P2CIM-APS2 and P2CIM-AUSB names are stored within the CIM’s
memory. There are two memory locations provided to accommodate
the Paragon naming convention (12 characters) and the KX IIl naming
convention (32 characters).

When first connected to a KX lIl, the Paragon name will be retrieved from
memory and written into the CIM memory location used by KX [l1.
Subsequent queries for the CIM name or updates to the CIM name from
the KX Il will be made to the memory location used by the KX III.
Updates will not be made by the KX Il to the memory location used by
Paragon 1.

When the CIM name is updated by one KX III, the other KX Ill will detect
and retrieve the updated name on the next attempt to connect to that
target. Until that time, the name will not be updated on the other KX III.

Port Status and Availability

The port status, displayed on the KX Il Port Access page as either Up or
Down, is updated to show whether the CIM is powered up and connected
to the KX IIl port.

The port availability, as displayed on the KX |ll Port Access page as Idle,
Busy or Connected, is only updated to reflect activity on a target that has
been initiated from that same KX II1.
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If a connection to the target is in place from the other KX III, the
availability is checked when a connection is attempted. Access is denied
or allowed consistent with the PC-Share policy in place for the KX III.
Until that time, the availability is not be updated on the other KX III.

If access is denied because the target is busy, a notification is displayed.
Working from CC-SG

Operations initiated from CC-SG are based on the Status, Availability and
CIM name reported by the managed KX Ill. When the target is connected
to two managed KX Ills and the devices are added to CC-SG, two nodes
will be created. Each node will have its own oob-kvm interface
associated with it. Alternatively, a single node can be configured with an
oob-kvm interface from each KX III.

If the KX Ills are configured for ‘Private’ mode, when a second connection
is attempted the user is notified that they cannot connect and access is
denied.

When a port name change is initiated via the CC-SG Port Profile pane,
the changed name is pushed to the managed KX Ill. The corresponding
port name of the other KX Il will not be updated in CC-SG until a
connection is attempted to the target port via the other KX IlI's oob-kvm
interface.

KX Ill-to-Paragon Il Guidelines

The P2CIM-APS2DUAL or P2CIM-AUSBDUAL can be connected to a KX IlI
and Paragon Il.

Concurrent Access

The KX Il and Paragon Il must be configured with the same policy for
concurrent access to targets.

Paragon I Mode description Supported?

operation mode

Private A server or other device Supported.
on a specific channel Paragon Il and the KX Il
port can be accessed must be set to Private. The
excluswely by onlyone  private setting is applied on
user at a time. to KX Ill device, not per user

group.

The Paragon Il uses Red to
indicate ‘busy’ or Green to
indicate ‘available’.

PC Share A server or other device  Supported.
on a specific channel However, PC Share Idle
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Paragon I Mode description Supported?

operation mode
port can be selected and Timeout, which is configured
controlled by more than  on the Paragon I, is not
one user, but only one supported. Both users will
user has keyboard and  have concurrent keyboard
mouse control at any and mouse control.

one time. The Paragon Il uses Green to
indicate ‘available’. This
will also be true if another
user is already accessing the

target.
Public View While one user is Not supported.
accessing aserveror This mode cannot be used
other _deV'Ce ona when connecting the CIM to
specific channelport, 3 paragon Il and the KX Il.

other users can select
that channel port and
view the video output
from that device.
However, only the first
user will have keyboard
and mouse control until
they disconnect or
switch away.

The Paragon Il uses Yellow
to indicate it is in P-View
mode.

CIM Name Updates

e CIM names updated from Paragon Il are stored and retrieved from
the CIM memory location corresponding to the Paragon naming
convention.

e CIM names updated from the KX Ill are stored and retrieved from the
CIM memory location corresponding to the KX Ill naming convention.

e CIM name updates do not propagate between the Paragon Il and the
KX 1.
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Appendix B: Accessing a Paragon Il from the KX |1

Supported Connection Distances Between Paragon Il and KX 11l

When using KX lll as the front end of a Paragon Il system, you should
restrict the cable length (distance) for good video quality.

Supported distance from the Paragon Il user station to the target server
is 500 cable feet (152 m). Greater distances may result in video
performance that may or may not be acceptable to you.

Supported distance from KX Ill to the Paragon Il user station is up to 150
cable feet (45 m).

Connecting the Paragon Il to the KX IlI

Raritan.

A brand of Lllegrand

>

1.

To connect the Paragon Il system to a KX IlI:

Check whether the Paragon Il user station that you want to connect
to the KX Ill is implemented with version 4.6 firmware (or later]. If
not, upgrade it.

The Paragon Il user station can be one of these:

= P2-UST
= P2-EUST
= P2-EUST/C

See Paragon Il Help for information on upgrading.

Plug a compatible DCIM-USB into the USB and video ports on the

Paragon Il user station.

If the system is a two- or three-tier system, ensure the Paragon I

user station is connected to the base KX IIl device (first tier).

Connect the Paragon Il user station to a KX lll device via a Cat5 UTP

cable up to 150 feet (45 m).

= Plug one end of the cable to the DCIM's RJ-45 port and the other
end to one of the channel ports on the KX Ill device.

If you want to have more paths to access the same Paragon Il system
in KX 11l or CC-SG, repeat Steps 1 to 3 to connect additional user
stations to the KX III.
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Hardware
KX Il Dimensions and Physical Specifications
Dominion KX Description Power & Dimensions Weight Operating Humidity
Il model heat (WxDxH) temp
dissipation
DKX3-108 * 8server Dual Power 17.3"x 8.60lbs  0°-45°C  0-85% RH
ports 110V/240V,  13.15" x
= 1remote 50-60Hz 1.73"
user 1.8A60W D2 4394334x44 3.9kg  320-113°
= T local KCAL mm F
port for
use at
the rack
DKX3-116 * léserver Dual Power 17.3"x 8.60lbs  0°-45°C  0-85% RH
ports 110V/240V,  13.15" x
= ]remote 50-60Hz 1.73"
user 1.8A 60W 52 4394334x44  3.9kg 320 - 1130
= 1 local KCAL mm F
port for
use at
the rack
DKX3-132 = 32server Dual Power 17.3"x 8.60lbs  0°-45°C 0-85% RH
ports 110V/240V,  13.15" x
= 1remote 50-60Hz 1.73"
user 1.8A 60W 52 439y334x44  3.9kg 320 - 1130
= 1 local KCAL mm F
port for
use at
the rack
DKX3-216 = 16 server Dual Power 17.3"x 9.08lbs  0°-45°C  0-85% RH
ports 110V/240V,  13.15" x
= 2remote 50-60Hz 1.73"
Raritan. 192



Dominion KX

11l model

DKX3-232

DKX3-416

DKX3-432

DKX3-464

Raritan.
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Description

users

= 1 local
port for
use at
the rack

= 32 server
ports

= 2remote
users

= 1 local
port for
use at
the rack

= 16 server
ports

= 4 remote
users

= 1 local
port for
use at
the rack

= 32server
ports

= 4 remote
users

= 1 local
port for
use at
the rack

= b4 server
ports

= 4 remote
users

= 1 local
port for
use at
the rack

Power &
heat
dissipation
1.8A 60W 52
KCAL

Dual Power
110V/240V,
50-60Hz

1.8A 60W 52
KCAL

Dual Power
110V/240V,
50-60Hz

1.8A 60W 52
KCAL

Dual Power
110V/240V,
50-60Hz

1.8A 60W 52
KCAL

Dual Power
110V/240V,
50-60Hz

1.8A 60W 52
KCAL

Dimensions Weight

(WxDxH])

439x334x44
mm

17.3" x
13.15" x
1.73"

439x334x44
mm

17.3" x
13.15" x
1.73"

439%x334x44
mm

17.3" x
13.15" x
1.73"

439x334x44
mm

17.3"x 13.3"

x 3.5"

439x338x89
mm

4.12kg

9.08lbs

4.12kg

9.08lbs

4.12kg

9.08lbs

4.12kg

12.39lbs

5.62kg

Appendix C: Specifications

Operating
temp
32°-113°
F
0°-45°C
320 -113°
F
0°-45°C
320 -113°
F
00-45°C
320 -113°
F
0°-45°C
320 -113°
F

Humidity

0-85 % RH

0-85 % RH

0-85 % RH

0-85 % RH
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Dominion KX
11l model

DKX3-808

DKX3-832

DKX3-864

Description

= 8server
ports

= 8remote
users

= 1 local
port for
use at
the rack

= 32 server
ports

= 8remote
users

= 1 local
port for
use at
the rack

= b4 server
ports

= 8remote
users

= 1 local
port for
use at
the rack

Power &
heat
dissipation
Dual Power
110V/240V,
50-60Hz

1.8A 60W 52
KCAL

Dual Power
110V/240V,
50-60Hz

1.8A 60W 52
KCAL

Dual Power
110V/240V,
50-60Hz

1.8A 60W 52
KCAL

Dimensions
(WxDxH])

17.3" x
13.15" x
1.73"

439x334x44
mm

17.3" x
13.15" x
1.73"

439%x334x44
mm

17.3" x 13.3"
x 3.5"

439x338x89
mm

Weight

9.96lbs

4.52kg

9.96lbs

4.52kg

12.391bs

5.62kg

Operating
temp

0° - 45° C

320 -113°
F

0° - 450 C

32°-113°

F

0° - 450 C

320 -113°
F

Humidity

0-85 % RH

0-85 % RH

0-85 % RH
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KX I1l Supported Target Server Video Resolutions

When using digital CIMs, you set the target’s video resolution to match
your monitor's native display resolution. The native display resolution is
set when configuring ports for digital CIMs (see Configure the CIM Target
Settings).

Following is a complete list of KX Il supported video resolutions when
accessing a target from the Remote Console.

e 640x350(d70Hz

e 640x350(d85Hz

e 640x400(@56Hz

e 640x400(@84Hz

e 640x400(d85Hz

o 640x480[@60Hz

o 640x480(66.6Hz

o 640x480[d72Hz

o 640x480[@75Hz

o 640x480(d85Hz

e 720x400@70Hz

e 720x400(d84Hz

e 720x400(d85Hz

e 800x600@56Hz

e 800x600(d60Hz

e 800x600@70Hz

e 800x60072Hz

e 800x600@75Hz

e 800x600@85Hz

e 800x600d90Hz

e 800x600@100Hz

o 832x624(d75.1Hz

o 1024x768(d60Hz

e 1024x768(@70Hz

o 1024x768@72Hz

o 1024x768(d85Hz

e 1024x768@75Hz

o 1024x768(d90Hz

e 1024x768@100Hz

e 1152x864(d60Hz

e 1152x864(d70Hz

e 1152x864@75Hz
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1152x864(d85Hz
1152x870(@75.1Hz
1280x720(@60Hz
1280x960(@60Hz
1280x960(d85Hz
1280x1024@60Hz
1280x1024@75Hz
1280x1024@85Hz
1360x768(@60Hz
1366x768(d60Hz
1368x768(d60Hz
1400x1050(@60Hz
1440x900(@60Hz
1600x1200(@60Hz
1680x1050@60Hz
1920x1080(@60Hz

1920x1200@60Hz (Requires Reduced Blanking Time)

For 1920x1200(d60Hz, you must use a digital CIM and set the CIM's

preferred resolution to 1920x1200(@60Hz.

KX Il Supported Local Port DVI Resolutions

Following are the resolutions supported when connecting to a DVI

monitor from the Local port.

1920x1080@60Hz
1280x720(@60Hz

1024x768@60Hz (default)

1024x768(@75Hz
1280x1024@60Hz
1280x1024@75Hz
1600x1200@60Hz
800x480(@60Hz
1280x768(d60Hz
1366x768(d60Hz
1360x768(d60Hz
1680x1050@60Hz
1440x900(@60Hz

Raritan.
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Target Server Video Resolution Supported Connection Distances and
Refresh Rates

The maximum supported distance is a function of many factors including
the type/quality of the Catb cable, server type and manufacturer, video
driver and monitor, environmental conditions, and user expectations.

The following table summarizes the maximum target server distance for
various video resolutions and refresh rates:

Target server video resolution Maximum distance
1024x768{60Hz (and below]) 150" (45 m])
1280x1024@60Hz 100" (30 m]
1280x720@60Hz 75" (22 m)
1600x1200@60Hz 50" (15 m)
1920x1080@60Hz 50" (15 m)

See KX Ill Supported Target Server Video Resolutions (on page 195)
for the video resolutions supported by the KX III.

Note: Due to the multiplicity of server manufacturers and types, 0S5
versions, video drivers, and so on, as well as the subjective nature of
video quality, Raritan cannot guarantee performance across all distances
in all environments.

Supported Computer Interface Module (CIMs) Specifications

Digital CIMs support Display Data Channels (DDC) and Enhanced Extended Display
Identification Data (E-EDID).

Note: Both plugs must be plugged in for the HDM! and DVI CIMs.

CIM model Description Dimensions Weight
(WxDxH)
D2CIM-DVUSB Dual USB CIM for: = 1.7"x3.5"x0.8" = 0.25lb
= 0Svirtual media = 43x90x19mm = 0.11kg
* Smartcard/CAC
= Audio

= Absolute Mouse Synchronization
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CIM model Description Dimensions Weight
(WxDxH)
L1 B B
D2CIM-VUSB USB CIM for: = 1.3"x3.0"x0.6" = 0.20lb

= 0OSvirtual media 33x76x15mm = 0.09kg

= Absolute Mouse Synchronization

D2CIM-DVUSB-DP  Digital CIM that provides = 1.7"x3.5"x0.8" = 0.25lb
digital-to-analog conversion and = 43x90x19mm = 0.11kg
support for:

=  0Svirtual media

* Smartcard/CAC

= Audio

= Absolute and Relative Mouse
Synchronization

TR |
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CIM model

D2CIM-DVUSB-HDM
[

D2CIM-DVUSB-DVI

Raritan.
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Description

Digital CIM that provides
digital-to-analog conversion and
support for:

0S virtual media
Smartcard/CAC
Audio

Absolute and Relative Mouse
Synchronization

Digital CIM that provides
digital-to-analog conversion and
support for:

0S virtual media
Smartcard/CAC
Audio

Absolute and Relative Mouse
Synchronization

://-. x
A
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Dimensions
(WxDxH)

1.7"x3.5"x0.8"

43 x 90 x 19mm

1.7" x3.5" x 0.8"

43 x 90 x 19mm

Weight

0.25Lb
0.11kg

0.25lb
0.11kg
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CIM model Description Dimensions Weight
(WxDxH)
DCIM-PS2 CIM for PS2 = 1.3"x3.0"x0.6" = 0.20lb

= 33x76x15mm = 0.09kg

DCIM-USBG2 CIM for USB and Sun USB = 1.3"x3.0"x0.6" = 0.20lb
= 33x76x15mm = 0.09kg

Supported Digital Video CIMs for Mac

Use a digital video CIM to connect to the following Mac® ports:

Mac port CIM
DVI D2CIM-DVUSB-DVI
HDMI D2CIM-DVUSB-HDMI

DisplayPort or Thunderbolt D2CIM-DVUSB-DP

If the Mac's HDMI or DisplayPort video has a mini connector, a passive
adapter cable may be required to connect to the full sized HDMI and
DisplayPort plugs on the digital CIMs.

Alternatively, use the Mac VGA adapter with the D2CIM-VUSB or
D2CIM-DVUSB. Note that this may be less reliable and the video quality
may suffer.

For information on established modes supported by the KX IIl 2.5.0 (and
later] for Mac, see Digital CIM Established and Standard Modes (on
page 201).
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Digital CIM Timing Modes

Following are the default timing modes that are used when the KX |l|
communicates with a video source via a digital CIM.

The timing mode that is used is dependent on the native resolution of the
video source.

e 1024x768@60Hz

e 1152x864(d60Hz

e 1280x720@60Hz

e 1280x960(@60Hz

e 1280x1024(@60Hz (default resolution applied to digital CIMs)
o 1360x768(d60Hz

e 1400x1050@60Hz

o 1440x900@60Hz

e 1600x1200@60Hz

e 1680x1050(@60Hz

e 1920x1080@60Hz

e 1920x1200(@60Hz

See Configuring CIM Ports in online help for more information.

Digital CIM Established and Standard Modes

The following additional established and standard resolutions and timing
modes are supported by the KX |11 3.0.0 (and later).

Raritan. 201
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Digital CIM Established Modes

e 720x400(@70Hz IBM, VGA

o 640x480(@60Hz IBM, VGA

o 640x480(@67Hz Apple Mace I
o 640x480@72Hz VESA

e 640x480(@75Hz VESA

e 800x600@56Hz VESA

e 800x600@60Hz VESA

e 800x600@72Hz VESA

e 800x600@75Hz VESA

o 832x624(d75Hz Apple Mac Il
e 1024x768@60Hz VESA

o 1024x768(@70Hz VESA

o 1024x768(@75Hz VESA

e 1280x1024@75Hz VESA

e 1152x870@75Hz Apple Mac

Digital CIM Standard Modes

e 1152x864(@75Hz VESA
o 1280x960(@60Hz VESA
e 1280x1024(@60Hz VESA
e 1360x768(d60Hz VESA
e 1400x1050@60Hz VESA
e 1440x900(@60Hz VESA
e 1600x1200 (@60Hz VESA
e 1680x1050@60Hz VESA
e 1920x1080(@60Hz VESA

DVI Compatibility Mode

DVI Compatibility Mode may be required if you are using an HDMI CIM to
connect to a Dell Optiplex target with an Intel video card, or a Mac® Mini
with an HDMI video port.

Selecting this mode ensures a good video quality from the targets.

See Configuring CIM Ports in online help.
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Supported Remote Connections

Remote
connection

Network

Protocols

Details

10BASE-T, 100BASE-T, and 1000BASE-T (Gigabit)

Ethernet

TCP/IP, UDP, SNTP, HTTP, HTTPS, RADIUS,
LDAP/LDAPS

Network Speed Settings

KX Il network speed setting

Network
switch port
setting

Raritan.
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Auto
Auto
1000/Full
100/Full

100/Half
100/Half
10/Full

10/Half
10/Half

1000/Full 100/Full 100/Half
100/Half
No No
Communica | Communica
tion tion
100/Half
No No No
Communica [Communica |Communica
tion tion tion
No No No
Communica [Communica |Communica
tion tion tion

10/Full 10/Half

10/Half
No No
Communica |Communica
tion tion
No No
Communica |Communica
tion tion
No No
Communica |Communica
tion tion
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Legend:

Does not function as expected

Supported

Functions; not recommended

NOT supported by Ethernet specification; product will
communicate, but collisions will occur

Per Ethernet specification, these should be “no
communication,” however, note that the KX lll behavior
deviates from expected behavior

Note: For reliable network communication, configure the KX Il and the
LAN switch to the same LAN Interface Speed and Duplex. For example,
configure the KX Il and LAN Switch to Autodetect ([recommended), or set
both to a fixed speed/duplex such as 100MB/s/Full.

Dell Chassis Cable Lengths and Video Resolutions

In order to maintain video quality, Raritan recommends using the
following cable lengths and video resolutions when you are connecting to
Dell® blade chassis from the KX IlI:

Video resolution Cable length
1024x768(d60Hz 50" (15.24 m)
1280x1024@60Hz 50" (15.24 m)

1600x1200(@60Hz 30' (9.14 m)
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Smart Card Minimum System Requirements

Local Port Requirements

The basic interoperability requirement for local port attachment to the
KX 1l is:

e All devices (smart card reader or token] that are locally attached
must be USB CCID-compliant.

Target Server Requirements

When using smart card readers, the basic requirements for
interoperability at the target server are:

e The IFD (smart card reader) Handler must be a standard USB CCID
device driver [comparable to the generic Microsoft® USB CCID
driver).

e Adigital CIM or D2CIM-DVUSB (Dual-VM CIM] is required and must
be using firmware version 3A6E or later.

e Blade chassis server connections, where a CIM per blade is used,
are supported.

e Blade chassis server connections, where a CIM per chassis is used,
is only supported for IBM® BladeCenter® models H and E with
auto-discovery enabled.

Windows XP Targets

Windows XP® operating system targets must be running Windows XP SP3
in order to use smart cards with the KX I1.

Linux Targets

If you are using a Linux® target, the following requirements must be met
to use smart card readers with the Raritan device.

e CCID Requirements

If the Raritan D2CIM-DVUSB VM/CCID is not recognized as a smart
card reader by your Linux target, you may need to update the CCID
driver version to 1.3.8 or above and update the driver configuration
file (Info.plist).

Operating system CCID requirements
RHEL 5 ccid-1.3.8-1.el5

SuSE 11 pcsc-ccid-1.3.8-3.12
Fedora® Core 10 ccid-1.3.8-1.fc10.i386
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Remote Client Requirements

The basic requirements for interoperability at the remote client are:

e The IFD [smart card reader) Handler must be a PC/SC compliant
device driver.

e The ICC (smart card) Resource Manager must be available and be
PC/SC compliant.

e The JRE® Java™ 1.7 with smart card APl must be available for use by
the Raritan client application.

Remote Linux Client Requirements

If you are using a Linux® client, the following requirements must be met
to use smart card readers with the Raritan device.

Note: User login to client, on smart card insertion, may take longer when
1 or more KVM sessions are actively in place to targets. As the login
process to these targets is also under way.

e PC/SC Requirements

Operating system Required PC/SC

RHEL 5 pcsc-lite-1.4.4-0.1.el5

SuSE 11 pcsc-lite-1.4.102-1.24
Fedora® Core 10 pcsc-lite-1.4.102.3.fc10.i386

e Create a Java® Library Link
A soft link must be created to the libpcsclite.so after upgrading RHEL
4, RHEL 5 and FC 10. For example, In -s /usr/lib/libpcsclite.so.1
/usr/lib/libpcsclite.so, assuming installing the package places the
libraries in /usr/lib or /user/local/lib

e PC/SC Daemon

When the pcsc daemon (resource manager in framework] is
restarted, restart the browser

Supported Smart Card Readers

Type Vendor Model Verified
USB SCM Microsystems SCR331 Verified on local and
remote

206 Raritan.
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Type
USB

USB

USB

USB

USB Keyboard/Card

reader combo

USB Keyboard/Card

reader combo

USB reader for
SIM-sized cards

Integrated (Dell
Latitude D620)

PCMCIA
PCMCIA

Raritan.
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Vendor

SCM Microsystems

Activldentity®

Activldentity

Gemalto®

Dell®

Cherry GmbH

Omnikey

02Micro

Activldentity

SCM Microsystems

Model
SCR331

Activldentity USB Reader v2.0
Activldentity USB Reader v3.0
GemPC USB-SW

USB Smart Card Reader
Keyboard

G83-6744 SmartBoard

6121

07776

Activldentity PCMCIA Reader
SCR243
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Verified

Verified on local and
remote

Verified on local and
remote

Verified on local and
remote

Verified on local and
remote

Verified on local and
remote

Verified on local and
remote

Verified on local and
remote

Remote only

Remote only

Remote only

Note: SCM Microsystems SCR331 smart card readers must be using
SCM Microsystems firmware v5.25.

Unsupported Smart Card Readers

This table contains a list of readers that Raritan has tested and found not
to work with the Raritan device, therefore they are unsupported.

If a smart card reader does not appear in the supported smart card
readers table or in the unsupported smart card readers table, Raritan
cannot guarantee it will function with the device.

Type

USB Keyboard/Card

reader Combo

USB Keyboard/Card

reader Combo

Vendor Model
HPe ED707A
SCM SCR338

Microsystems

Notes

No interrupt endpoint
=> not compatible with
Microsoft® driver

Proprietary card
reader
implementation (not
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208

Type Vendor Model Notes
CCID-compliant]
USB Token Aladdin® eToken Proprietary
PRO™ implementation

Audio Playback and Capture Recommendations and Requirements

Audio Level
e Set the target audio level to a mid-range setting.
For example, on a Windows® client, set the audio to 50 or lower.

This setting must be configured through the playback or capture audio
device, not from the client audio device control.

Recommendations for Audio Connections when PC Share Mode is Enabled

If you are using the audio feature while running PC Share mode, audio
playback and capture are interrupted if an additional audio device is
connected to the target.

For example, User A connects a playback device to Target1 and runs an
audio playback application then User B connects a capture device to the
same target. User A's playback session is interrupted and the audio
application may need to be restarted.

The interruption occurs because the USB device needs to be
re-enumerated with the new device configuration.

It may take some time for the target to install a driver for the new device.

Audio applications may stop playback completely, go to the next track, or
just continue playing.

The exact behavior is dependent on how the audio application is designed
to handle a disconnect/reconnect event.

Bandwidth Requirements

The table below details the audio playback and capture bandwidth
requirements to transport audio under each of the selected formats.

Audio format Network bandwidth requirement
441 KHz, 16bit stereo 176 KB/s
44.1 KHz, 16bit mono 88.2 KB/s
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Audio format Network bandwidth requirement
2.05 KHz, 16bit stereo 88.2 KB/s
22.05 KHz, 16bit mono 441 KB/s

11.025 KHz, 16bit stereo 44.1 KB/s
11.025 KHz, 16bit mono Audio 22.05 KB/s

In practice, the bandwidth used when an audio device connects to a
target is higher due to the keyboard and video data consumed when
opening and using an audio application on the target.

A general recommendation is to have at least a 1.5MB connection before
running playback and capture.

However, high video-content, full-color connections using high-target
screen resolutions consume much more bandwidth and impact the
quality of the audio considerably.

To help mitigate quality degeneration, there are a number of
recommended client settings that reduce the impact of video on audio
quality at lower bandwidths:

e Connect audio playback at the lower quality formats. The impact of
video consuming bandwidth is much less notable at 11k connections
than at 44k

e Set the connection speed under Connection Properties to a value
that best matches the client to server connection

e Under Connection Properties, set the color depth to as low a value as
possible. Reducing the color depth to 8 bit color considerably
reduces the bandwidth consumed

e Set Smoothing, to High. This will improve the appearance of the
target video by reducing displayed video noise

e Under Video settings, set the Noise Filter to its highest setting of 7
(highest value] so less bandwidth is used for target screen changes

Audio in a Mac Environment

Following are known issues in a Mac® environment.

e On Mac clients, only one playback device is listed on the Connect
Audio panel when accessing the device through the Virtual KYM
Client (VKC]. The device listed is the default and is displayed on the
Connect Audio panel as Java Sound Audio Engine.

e Using audio on a Mac target through Skype® may cause the audio to
be corrupted.
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Number of Supported Audio/Virtual Media and Smartcard
Connections

Following are the number of simultaneous Audio/Virtual Media and
Smartcard connections that can be made from a client to a target:
e 1 smartcard

e Tvirtual media

e 1 Smartcard and 1 virtual media

e 2virtual media

Certified Modems

e USRobotics® 56K 5686E

e Z00Mev90

e Z00MV92

e USRobotics Sportster® 56K
e USRobotics Courier™ 56K

KX I1l Supported Keyboard Languages

The KX Il provides keyboard support for the languages listed in the
following table.

Note: You can use the keyboard for Chinese, Japanese, and Korean for
display only; local language input is not supported at this time for the KX
Il Local Console functions. For more information about non-US
keyboards, see Informational Notes (on page 219).

Note: Raritan strongly recommends that you use
system-config-keyboard to change languages if you are working in a
Linux environment.

Language Regions Keyboard layout

US English United States of America and US Keyboard layout
most of English-speaking
countries: for example, Canada,
Australia, and New Zealand.

US English United States of America and US Keyboard layout
International most of English-speaking
countries: for example,

Netherlands
UK English United Kingdom UK layout keyboard
Chinese Hong Kong S. A. R., Republic of  Chinese Traditional

Raritan.
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Keystroke

Press C during
startup

Raritan.
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Language
Traditional

Chinese
Simplified

Korean
Japanese

French

German

French
Norwegian
Danish
Swedish
Hungarian
Slovenian
Italian

Spanish

Portuguese

Regions
China (Taiwan]

Mainland of the People’s
Republic of China

South Korea
Japan

France

Germany and Austria

Belgium
Norway
Denmark
Sweden
Hungary
Slovenia
ltaly

Spain and most Spanish
speaking countries

Portugal

Appendix C: Specifications

Keyboard layout

Chinese Simplified

Dubeolsik Hangul
JIS Keyboard

French (AZERTY)
layout keyboard.

German keyboard
(QWERTZ layout]

Belgian
Norwegian
Danish
Swedish
Hungarian
Slovenian
Italian

Spanish

Portuguese

Mac Mini BIOS Keystroke Commands

The following BIOS commands have been tested on Intel-based Mac®
Mini target servers and Mac Lion® servers running Mac Snow Leopard®.
The servers were attached to a KX Ill with D2CIM-DVUSB and
D2CIM-VUSB CIMs. See below for the supported keys and any notes.

Description

Start up from a

Virtual Media CIM Dual Virtual
Media CIM

Yes

bootable CD or DVD,
such as the Mac 0S X

Install disc

Mac Lion Server

HDMI CIM

Yes
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Keystroke

Press D during
startup

Press Option-
Command-P-R
until you hear
startup sound a
second time.

Press Option during

startup

Press Eject, F12, or
hold the mouse
button

Press N during
startup

Press T during
startup

Press Shift during
startup

Press Command-V
during startup

Press Command-S
during startup

Press Option-N
during startup

Press Command-R

212

Description

Start up in Apple
Hardware Test (AHT)

Reset NVRAM

Start up in Startup
Manager, where you
can select a Mac 0S X
volume to start from

Ejects any removable
media, such as an
optical disc

Start up from a
compatible network
server (NetBoot])

Start up in Target Disk
mode

Start up in Safe Boot
mode and temporarily
disable login items

Start up in Verbose
mode.admin

Start up in Single-User
mode

Start from a NetBoot
server using the default
boot image

Start from Lion

Virtual Media CIM Dual Virtual

Yes

May need BIOS
Mac profile for the
mouse to work

Yes

Yes

Yes

Yes

Yes

Yes

Yes

N/A

Media CIM

Yes

May need BIOS
Mac profile for
mouse to work

Yes

Yes

Yes

Yes

Yes

Yes

Yes

Yes

N/A

Mac Lion Server

HDMI CIM
Yes

May need BIOS
Mac profile for
the mouse to
work

Yes

Yes

Yes

Yes

Known issue with
LION to boot to
safe mode. "Safe
Mode" in red
does not appear
for Lion

Yes

Yes

Yes

Yes
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Keystroke

during startup

Port
HTTP, Port 80

HTTPS, Port 443

KX IIl (Raritan
KVM-over-IP)
Protocol,
Configurable Port
5000

SNTP (Time Server)
on Configurable
UDP Port 123

LDAP/LDAPS on
Configurable Ports

Raritan.
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Description Virtual Media CIM Dual Virtual Mac Lion Server
Media CIM
HDMI CIM

Recovery1

Using a Windows Keyboard to Access Mac Targets

A Windows® keyboard can be used to access a Mac® connected to a KX III.
Windows keys are then used to emulate the special Mac keys. This is the
same as connecting a Windows keyboard directly to the Mac.

TCP and UDP Ports Used

Description

This port can be configured as needed. See HTTP and HTTPS Port
Settings.

By default, all requests received by the KX Ill via HTTP (port 80) are
automatically forwarded to HTTPS for complete security.

The KX Il responds to Port 80 for user convenience, relieving users
from having to explicitly type in the URL field to access the KX I, while
still preserving complete security.

This port can be configured as needed. See HTTP and HTTPS Port
Settings.

By default, this port is used for multiple purposes, including the web
server for the HTML client, the download of client software (Virtual KYM
Client (VKC)) onto the client's host, and the transfer of KVYM and virtual
media data streams to the client.

This port is used to discover other Dominion devices and for
communication between Raritan devices and systems, including CC-5G
for devices that CC-SG management is available.

By default, this is set to Port 5000, but you may configure it to use any
TCP port not currently in use. For details on how to configure this
setting, see Network Settings.

The KX IIl offers the optional capability to synchronize its internal clock
to a central time server.

This function requires the use of UDP Port 123 (the standard for SNTP),
but can also be configured to use any port of your designation. Optional

If the KX Il is configured to remotely authenticate user logins via the
LDAP/LDAPS protocol, ports 389 or 636 will be used, but the system
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Port
389 or 636

RADIUS on
Configurable Port
1812

RADIUS Accounting
on Configurable Port
1813

SYSLOG on
Configurable UDP
Port 514

SNMP Default UDP
Ports

Description
can also be configured to use any port of your designation. Optional

If the KX IIl is configured to remotely authenticate user logins via the
RADIUS protocol, either port 1812 will be used, but the system can also
be configured to use any port of your designation. Optional

If the KX IIl is configured to remotely authenticate user logins via the
RADIUS protocol, and also employs RADIUS accounting for event
logging, port 1813 or an additional port of your designation will be used
to transfer log notifications.

If the KX Il is configured to send messages to a Syslog server, then the
indicated port(s] will be used for communication - uses UDP Port 514.

Port 161 is used for inbound/outbound read/write SNMP access and
port 162 is used for outbound traffic for SNMP traps. Optional

TCP Port 22 Port 22 is used for the KX lll command line interface (when you are
working with Raritan Technical Support).

SSH (Secure Shell) SSH port can be configured. The default is port 22.

Software

Operating Systems
Windows 10

Windows 7° Home Premium SP1 64-bit
Windows 7 Ultimate SP1 64-bit
Windows 7 Ultimate 32-bit

Windows 8¢ 64-bit

Supported Operating Systems, Browsers and Java Versions

Browsers Java

Windows Edge Java 1.7 or later

Internet Explorere 11 for VKC

Chrome 46 Java 1.8.0_40 or

Firefox® 41 later for VKCs

Internet Explorer® 10, 11 Java 1.7 or later

Firefox® 29.0.1, 30, 40 for VKC

Chrome® 35, 45 Java 1.8.0_40or
later for VKCs

Safari® 7.0.3, 7.0.5
Edge

Windows XP® Home Edition with SP 3

Windows Server 2012¢ Standard 64-bit

Windows Server 2008 @

214
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Operating Systems Browsers Java
Windows Server 2003

openSUSE® 11.4 Celadon (x86_64) Firefox 16.0.2
openSUSE® 13.2 Firefox 33
Fedora® 18 (Spherical Cow] Firefox 24
Fedora © 22 Firefox 38
RHEL® 6.4 Firefox 21
Mac® 0S X Mountain Lion® 10.7.5 Firefox 25
Safari 6.0.5
Mac 0S X Mountain Lion 10.8.5 * Firefox 25
Safari 6.1.1
Mac 10.10.4 Safari 9.0.1
Chrome 45
Mac 10.10.5 Safari 9.0.1
Chrome 46
Solaris® 10 64-bit Firefox 3.6.23

*Note: Upon upgrading from 0S X 10.8.2 to 0S X 10.8.3, Safari® may block
Java®.
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JRE Requirements and Browser Considerations for Mac

Java Runtime Environment Requirements for Mac

Install Java Runtime Environment 8 (JRE)® on PCs and Macs® when using
the Virtual KVM Client (VKC] to access target devices via KX lI1.

This ensures in order to provide high performance, KVM-over-IP video
processing when remotely accessing target devices/PCs/Macs.

The latest version of JRE for Mac can be downloaded from the Oracle
Support website.

Browser Considerations for Mac

Java may be disabled by default in certain browsers. Enable Java and
accept all security warnings in order to use KX III.

Certain versions of Safari® block Java for security reasons. Since Java is
required to use KX Ill, Raritan recommends you use Firefox® instead.

Additionally, you may be required to navigate through a number of
messages. Select ‘Do Not Block' if these messages are displayed.

Virtual KVM Client (VKC), VKCS, and Active KVM Client (AKC)
Requirements

Microsoft .NET® 4.0 (or later] is required to use KX Il with the Microsoft
Windows®-based Active KVM Client (AKC).

Java™ 1.7 is required to use the Java-based . Java 1.8.0_40 is required to
use the VKCS.

Java 1.8.0_40 or later is required for VKCS, the standalone VKC client
used on Chrome.

KX Il checks your current Java version and prompts you to update it if it
is not compatible.

VKC can only be launched from a 32-bit browser, or 64-bit browser.

Following are the Java 32-bit and 64-bit Windows operating system
requirements.

Mode Operating system Browser
Windows x64  Windows XP® e Internet Explorer® 7.0,
32-bit mode 9.0,10.00r 11.0

o Firefox® 1.06 - 4 or later

Raritan.
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Mode Operating system Browser
Windows Server 2003

Internet Explorer 6.0
SP1++,9.0,10.0 0or 11.0

e Firefox 1.06 -3

Windows Vista® e Internet Explorer 9.0,
10.00r 11.0
Windows 7¢ e Internet Explorer 9.0,
10.00r 11.0
e Firefox 1.06 - 4 or later
Windows x64  Windows XP 64bit 0S, 32bit browsers:
b4-bit mode Windows XP e Internet Explorer 6.0

SP1+, 7.0 0r 8.0
e Firefox 1.06 - 4 or later

64bit mode, 64bit browsers:
Windows Vista .

Professional®
Windows XP Tablet®
Internet Explorer 7.0, 8.0,
Windows Server 2003 9.0,10.0 0r 11.0

Windows Server 2008

Windows 7

Note that a JRE™ plug-in is available for the Windows® 32-bit and 64-bit
operating systems.

See Java Runtime Environment [JRE) Notes (on page 219) for
additional information.

Multi-Language Keyboard JRE Requirement

In order for multi-language keyboards to work in the KX Ill and Virtual
KVM Client (VKC), install the multi-language version of JRE™.
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Events Captured in the Audit Log and Syslog

Following is a list and description of the events that are captured by the
KX Il audit log and syslog:

218

Access Login - A user has logged in to the KX IlI

Access Logout - A user has logged out of the KX Il

Active USB Profile - The USB profile is active

CIM Connected - A CIM was connected

CIM Disconnected - A CIM was disconnected

Connection Lost - The connection to the target was lost
Disconnected User - A user was disconnected from a port

Duplicate CIM Serial - A CIM has same serial number with other
CIM.

End CC Control - CC-SG management ended

Login Failed - User login failed

Password Changed - Password change occurred

Port Connect - Port was connected

Port Disconnect - Port was disconnected

Port Status Change - Change in the port status

Scan Started - A target scan was started

Scan Stopped - A target scan was stopped

Session Timeout - A session timeout occurred

USB Profile Set Modify Failed - Failed to change USB Profile Set.
USB Profile Set Modified - USB Profile Set was modified.
USB Net Present - A broadband modem is plugged in.
USB Net Absent - A broadband modem is unplugged.
VM Image Connected - A VM image was connected

VM Image Disconnected - A VM image was disconnected
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Overview

This section includes important notes on KX Il usage. Future updates
will be documented and available online through the Help link in the KX
[l Remote Console interface.

Note: Some topics in this section reference other multiple Raritan
appliances because various appliances are impacted by the information.

Java Runtime Environment (JRE) Notes

Raritan.
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Disable Java Caching and Clear the Java Cache

It is highly recommended that you disable Java caching in Microsoft
Windows®, and clear the Java™ cache.

P To disable Java caching and clear the cache:
1. From the Windows Start menu, click Control Panel.

2. Double-click on the Java icon to launch it. The Java Control Panel
dialog appears.

3. Todisable Java caching:

a. From the General tab, click the Settings button. The Temporary
Files Settings dialog appears.
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b. Click the View Applets button. The Java Applet Cache Viewer
opens.

c. Deselect the Enable Caching checkbox if it is already checked.
d. Click OK.
4. To clear the Java cache:

a. From the Temporary Files Settings dialog, click the Delete Files
button. The Delete Temporary Files dialog appears.

b. Select the temporary files that you want to delete.
c. Click OK.

Java Not Loading Properly on Mac

If you are using a Mac® and see the following message when connecting
to a device from the KX Il Port Access Table, Java™is not loaded
properly:

"Error while getting the list of open targets, please try again in a few
seconds”.

If this occurs, check your Java installation from this website:
http://www.java.com/en/download/testjava.jsp
http://www.java.com/en/download/testjava.jsp

If your Java applet is inactive, it can be enabled from this page. If it is not
installed correctly, a message lets you know and you can then reinstall
Java.
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IPvé6 Support Notes
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Operating System IPv6 Support Notes

Java

Java™ 1.7 supports |Pvé for the following:

e Solaris™ 10 (and later)

e Linux® kernel 2.1.2 (and later)/RedHat 6.1 (and later)
e Solaris 10 (and later])

e  Windows XP® SP1 and Windows 2003®, Windows Vista®, Windows 7¢,
Windows 8®, and Windows 10, operating systems

Linux
e |tisrecommended that Linux kernel 2.4.0 or higher is used when
using IPvé.

e An IPvé-enabled kernel will need to be installed or the kernel will
need to be rebuilt with IPvé options enabled.

e Several network utilities will also need to be installed for Linux when
using IPvé6. For detailed information, refer to
http://www.bieringer.de/linux/IPv6/IPv6-HOWTO/IPv6-HOWTO.html

Windows

e  Windows XP and Windows 2003 users will need to install the
Microsoft IPvé service pack to enable IPvé.

e For AKC with IPvé on Windows XP, add the executable kxgui.exe to
your firewall exception list. View your log file on the client to identify
the full path for the location of the file kxgui.exe.

Samba
e |Pvéis not supported for use with virtual media when using Samba.

AKC Download Server Certification Validation IPvé6 Support Notes

If you are connecting to a KX Il standalone device and support for AKC
download server certificate validation is enabled, the valid IPvé format to
generate the certificate is either:

e CN =[fd07:02fa:6cff:2500:020d:5dff:£e00:01c0] when
there is a leading 0
or

e CN =[fd07:02fa:6cf£:2500:020d:5df£:0000:01c0] when
there is no zero compression
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Dual Stack Login Performance Issues

If you are using the KX Ill in a dual stack configuration, it is important you
configured the domain system (DNS) correctly in the KX Il in order to
avoid delays when logging in.

See Tips for Adding a Web Browser Interface for information on
configuring your DNS in KX III.

CIM Notes

Windows 3-Button Mouse on Linux Targets

When using a 3-button mouse on a Windows® client connecting to a
Linux® target, the left mouse button may get mapped to the center
button of the Windows client 3-button mouse.
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Windows 2000 Composite USB Device Behavior for Virtual Media

The Windows 2000° operating system does not support USB composite
devices, like Raritan’s D2CIM-VUSB, in the same manner as
non-composite USB devices.

As a result, the "Safely Remove Hardware” system tray icon does not
appear for drives mapped by the D2CIM-VUSB and a warning message
may appear when disconnecting the device. Raritan has not observed
any problems or issues from this message, however.

Raritan’s US engineering department has developed a configuration
which supports the “Safely Remove Hardware” icon and avoids this
Windows message. This configuration requires the use of the
D2CIM-DVUSB virtual media adapter and the Troubleshooting 3 USB
Profile that configures the D2CIM-DVUSB as a non-composite USB
device supporting a single virtual media connection. Raritan has
successfully tested this configuration in the US and Japan.

Connection BEEERZGHEE Keyboard Video Mouse Tools View Mirtual Media Help

| ® Generic g
HP Proliant DL360/DL380 G4 (HP SmartStart CD)
Other Profiles Linux

| Mac 0S¥ (10.4.9 and later)

HP Proliant DL360/DL380 G4 {Windows 2003 Server Installation)

BIOS 18M Thinkcentre Lenovo

RUBY Industrial Mainboard {AwardBIOS)

BIOS Dell PowerEdge Keyboard Only

Supermicro Mainboard (Phoenix AwardBIOS)

SuSE Linux 9.2

BIOS Mac

BIOS Lenovo ThinkPad T61 and X61

BIOS HP Compaq DC7100/DC7600

Use Full Speed for Virtual Media CIM

BIOS Generic

Troubleshoating 1

Help on USE Profiles

Troubleshoating 2

Troubleshooting 3

BIOS HP Proliant DL145

BIOS Dell PowerEdge 1950/2950/2970/6950/R200
BIOS Dell Optiplex Keyboard Only

BIOS Asus P4C800 Motherboard

18M BladeCenter H with AMM

P

oo
-5 T
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Target Video Picture Not Centered (Mouse Out of Synch)

At certain resolutions when using an HDMI or DVI CIM with the KX III:

e The video display may not be centered properly - black rectangles
can be seen at the edges of the screen

e The mouse on the target may appear to be slightly out of synch

If either or both of these occur, you may be able to correct this by

adjusting the display scaling options from the target computer’s video
controller software.

For example, if your target computer uses the Catalyst Control Center
video controller, adjust the Underscan/Overscan setting as needed.

Powerstrip is not detected

When the PowerCIM-PDU is disconnected physically from the KX3, the
PDU is still listed in the PowerStrip Device drop-down list with a
"Powerstrip is not detected, please check!" message that does not
disappear.

» To solve:

In the port configuration page for the port, click Reset To Default.

Virtual Media Notes

224

Cannot Connect to Drives from Linux Clients

If you cannot connect to a virtual media drive on a target server when you
connect from a client running Linux® Fedora™ 18 with Java™ 1.7 (update
45 and later], disable SELinux in Fedora 18 on the client to resolve the
problem.

Cannot Write To/From a File from a Mac Client

If you are connecting to the KX Il from a Mac® 10.8.5 client running
Safari with Java™ 1.7 and cannot write to/from a file on a KX2 or KX3
target server or access virtual media, do the following to correct this:

1. In Safari, select Preferences.

2. Under the Security tab, select Manage Website Settings.
3. Click on "Website for KX2 or KX3".
4.

Select "Run in unsafe mode” from the drop-down.

Note: In Safari 10.0, “"Run in safe mode" is now hidden as an option
for Plugin-Settings. Hold the Mac Option/Alt key while clicking on the
site to list the option.
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If running MacOS Sierra 10.12, Java version must be 1.8.0.1217 or
higher.

5. Restart Safari.

Virtual Media via VKC and AKC in a Windows Environment

Windows XP® operating system administrator and standard user
privileges vary from those of the Windows Vista® operating system and
the Windows 7® operating system.

When enabled in Vista or Windows 7, User Access Control (UAC) provides
the lowest level of rights and privileges a user needs for an application.
For example, a Run as Administrator option is provided for Internet
Explorer® for Administrator level tasks; otherwise these are not
accessible even though the user has an Administrator login.

Both features affect the types of virtual media that can be accessed in
VKC, VKCS, and AKC. See your Microsoft® help for additional information
on these features and how to use them.

Following is a list virtual media types users can access via VKC and AKC
when running in a Windows environment. The features are broken down
by client and the virtual media features that are accessible to each
Windows user role.

Windows XP

If you are running VKC and AKC in a Windows XP environment, users
must have Administrator privileges to access any virtual media type
other than CD-ROM connections, I1SOs and I1SO images.

Windows Vista and Windows 7

If you are running VKC and AKC in a Windows Vista or Windows 7
environment and UAC is enabled, the following virtual media types can
be accessed depending on the user’'s Windows role:

Client Administrator Standard User
AKC and Access to: Access to:
VKC e Fixed drives and fixed e Removable drives
drive partitions e CD/DVD drives
e Removable drives e ISOimages
e CD/DVD drives e Remote ISO images

e |SOimages
e Remote ISO images
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Virtual Media Support on Windows 10, Windows 7, Windows 2008 and
Windows XP Targets

Virtual media is not supported on a Windows 10, Windows 7, Windows
2008 or Windows XP target server when connecting via VKC and AKC
from Windows 10, Windows 2008, Windows 2012.

Virtual Media Not Refreshed After Files Added

After a virtual media drive has been mounted, if you add a file(s) to that
drive, those files may not be immediately visible on the target server.
Disconnect and then reconnect the virtual media connection.

Virtual Media Linux Drive Listed Twice

For KX I, users who are logged in to Linux™ clients as root users, the
drives are listed twice in the Local Drive drop-down.

For example, you will see eg /dev/sdc and eg /dev/sdc1 where the first
drive is the boot sector and the second drive is the first partition on the
disk.

Accessing Virtual Media on a Windows 2000

Avirtual media local drive cannot be accessed on a Windows 2000®
server using a D2CIM-VUSB.

Disconnecting Mac and Linux Virtual Media USB Drives

In a Linux® or Mac® environment:

e For Linux users, if there is /dev/sdb and /dev/sdb1, the client only
uses /dev/sdb1 and advertise it as removable disk

e /dev/sdb is not available for the user.

e For Linux users, if there is /dev/sdb but no /dev/sdb1, /dev/sdb is
used as a removable device

e For Mac users, /dev/disk1 and /dev/disk1s1 is used

Target BIOS Boot Time with Virtual Media

The BIOS for certain targets may take longer to boot if media is mounted
virtually at the target.

» To shorten the boot time:

1. Close the Virtual KVM Client to completely release the virtual media
drives.

2. Restart the target.
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Virtual Media Connection Failures Using High Speed for Virtual
Media Connections

Under certain circumstances it may be necessary to select the "Use Full
Speed for Virtual Media CIM" when a target has problems with "High
Speed USB" connections or when the target is experiencing USB
protocol errors caused by signal degradation due to additional
connectors and cables (for example, a connection to a blade server via a
dongle]).

USB Port and Profile Notes

Raritan.
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VM-CIMs and DL360 USB Ports

HPe DL360 servers have one USB port on the back of the device and
another on the front of the device. With the DL360, both ports cannot be
used at the same time. Therefore, a dual VM-CIM cannot be used on
DL360 servers.

However, as a workaround, a USB2 hub can be attached to the USB port
on the back of the device and a dual VM-CIM can be attached to the hub.

Help Choosing USB Profiles

When you are connected to a KVM target server via the Virtual KVM
Client (VKC], you can view information about USB profiles via the Help on
USB Profiles command on the USB Profile menu.

v HF Proliant DL2E0OL380 G4 (HP SmartStart COY

Generic

Troubleshooting 1
Trouhleshooting 2
Trouhleshooting 3

Add Other Profiles »

Help on LISE Profiles
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USB profile help appears in the USB Profile Help window. For detailed
information about specific USB profiles, see Available USB Profiles.

Raritan provides a standard selection of USB configuration profiles for a
wide range of operating system and BIOS level server implementations.
These are intended to provide an optimal match between remote USB
device and target server configurations.

The ‘Generic’ profile meets the needs of most commonly deployed target
server configurations.

Additional profiles are made available to meet the specific needs of other
commonly deployed server configurations (for example, Linux®, Mac 0S
Xe).

There are also a number of profiles (designated by platform name and
BIOS revision) that have been tailored to enhance the virtual media
function compatibility with the target server, for example, when
operating at the BIOS level.

‘Add Other Profiles’ provides access to other profiles available on the
system. Profiles selected from this list will be added to the USB Profile
Menu. This includes a set of ‘trouble-shooting’ profiles intended to help
identify configuration limitations.

The USB Profile Menu selections are configurable via the Console Device
Settings > Port Configuration page.

Should none of the standard USB profiles provided by Raritan meet your
target server requirements, Raritan Technical Support can work with you
to arrive at a solution tailored for that target. Raritan recommends that
you do the following:

1. Check the most recent release notes on the Raritan website
(www.raritan.com) on the Firmware Upgrade page to see if a
solution is already available for your configuration.

2. If not, please provide the following information when contacting
Raritan Technical Support:

a. Target server information, manufacturer, model, BIOS,
manufacturer, and version.

b. The intended use (e.g. redirecting an image to reload a server’s
operating system from CD].
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Changing a USB Profile when Using a Smart Card Reader

There may be certain circumstances under which you will need to
change the USB profile for a target server. For example, you may need to
change the connection speed to "Use Full Speed for Virtual Media CIM"
when the target has problems with the "High Speed USB" connection
speed.

When a profile is changed, you may receive a New Hardware Detected
message and be required to log in to the target with administrative
privileges to reinstall the USB driver. This is only likely to occur the first
few times the target sees the new settings for the USB device. Afterward,
the target will select the driver correctly.

Video Mode and Resolution Notes
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Video Image Appears Dark when Using a Mac

If you are using a Mac® with an HDMI video port and the video seems too
dark, enable DVI Compatibility Mode on the CIM to help resolve the issue.

See Configuring CIM Ports

Video Shrinks after Adjusting Target Clock

On HP® Proliant® DL380p G8 target servers, certain resolutions cause
the target video to shrink. This is caused when the server’s clock
attempts to auto-adjust and detects the wrong active line length.

Depending on the resolution the target is set to, this occurs when
connecting to the HP target from the KX Ill Remote Console or Local Port,
or both the Remote Console and Local Port. This issue was detected at
the following resolutions:

Target resolution Issue seen on Issue seen from
Local Port Remote Console
1440x900(@60Hz Yes Yes
1400x1050@60Hz No Yes
1152x864@60Hz No Yes
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Black Stripe/Bar(s) Displayed on the Local Port

Certain servers and video resolutions may display on the local port with
small black bars at the edge of the screen.

If this occurs:
1. Try a different resolution, or

2. If using a digital CIM, then change the Display Native Resolution on
the Port Configuration page to another resolution, or

3. Ifusing the HDMI CIM, use the DVI Compatibility Mode.

Contact Raritan Technical Support for additional assistance.

Sun Composite Synch Video

Sun™ composite synch video is not supported.

SUSE/VESA Video Modes

The SuSE X.org configuration tool SaX2 generates video modes using
modeline entries in the X.org configuration file. These video modes do
not correspond exactly with VESA video mode timing (even when a VESA
monitor is selected). The KX IIl, on the other hand, relies on exact VESA
mode timing for proper synchronization. This disparity can result in
black borders, missing sections of the picture, and noise.

P> To configure the SUSE video display:

1. The generated configuration file /etc/X11/xorg.conf includes a
Monitor section with an option named UseModes. For example,
UseModes "Modes[0]"

2. Either comment out this line (using #) or delete it completely.
3. Restart the X server.

With this change, the internal video mode timing from the X server is
used and corresponds exactly with the VESA video mode timing,
resulting in the proper video display on the KX III.
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Keyboard Notes
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French Keyboard

Caret Symbol [Linux Clients Only)

The Virtual KVM Client (VKC) do not process the key combination of Alt
Gr + 9 as the caret symbol (*) when using French keyboards with Linux®
clients.

» To obtain the caret symbol:

From a French keyboard, press the * key (to the right of the P key), then
immediately press the space bar.

Alternatively, create a macro consisting of the following commands:
1. Press Right Alt

2. Press?.

3. Release 9.

4. Release Right Alt.

Note: These procedures do not apply to the circumflex accent [above
vowels]. In all cases, the * key (to the right of the P key] works on French
keyboards to create the circumflex accent when used in combination
with another character.

Accent Symbol (Windows XP Operating System Clients Only)

From the Virtual KVM Client (VKC), the key combination of Alt Gr + 7
results in the accented character displaying twice when using French
keyboards with Windows XP® clients.

Note: This does not occur with Linux® clients.

Numeric Keypad

From the Virtual KVM Client [VKC), the numeric keypad symbols display
as follows when using a French keyboard:

Numeric Displays
keypad as
symbol

/ ;
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Tilde Symbol

From the Virtual KVM Client (VKC), the key combination of Alt Gr + 2 does
not produce the tilde (~] symbol when using a French keyboard.

P> To obtain the tilde symbol:

Create a macro consisting of the following commands:
e Pressright Alt

e Press?

e Release?

e Release right Alt

Keyboard Language Preference (Fedora Linux Clients)

Because the Sun™ JRE™ on Linux® has problems generating the correct
KeyEvents for foreign-language keyboards configured using System
Preferences, Raritan recommends that you configure foreign keyboards
using the methods described in the following table.

Language Configuration method

US Intl Default

UK System Settings (Control Center)
French Keyboard Indicator

German Keyboard Indicator

Hungarian System Settings (Control Center)
Spanish System Settings (Control Center)

Swiss-German  System Settings (Control Center)

Norwegian Keyboard Indicator
Swedish Keyboard Indicator
Danish Keyboard Indicator
Japanese System Settings (Control Center)
Korean System Settings (Control Center)
Slovenian System Settings (Control Center)
ltalian System Settings (Control Center)
Portuguese System Settings (Control Center)

Raritan.
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Note: The Keyboard Indicator should be used on Linux systems using
Gnome as a desktop environment.

When using a Hungarian keyboard from a Linux client, the Latin letter U
with Double Acute and the Latin letter O with Double Acute work only
with JRE 1.6 (and later).

There are several methods that can be used to set the keyboard
language preference on Fedora® Linux clients. The following method
must be used in order for the keys to be mapped correctly from the
Virtual KVM Client (VKC).

P> To set the keyboard language using System Settings:
From the toolbar, choose System > Preferences > Keyboard.
Open the Layouts tab.

Add or select the appropriate language.

Click Close.

ML~ -

P> To set the keyboard language using the Keyboard Indicator:
1. Right-click the Task Bar and choose Add to Panel.

2. Inthe Add to Panel dialog, right-click the Keyboard Indicator and
from the menu choose Open Keyboard Preferences.

3. Inthe Keyboard Preferences dialog, click the Layouts tab.
Add and remove languages as necessary.

Macros Not Saving on Linux Targets

If you receive the following error message when you create and then
save a macro on a target server running Linux® Fedora™ 18 with Java™
1.7.0 (update 45 and later), disable SELinux in Fedora 18 on the target
server to resolve the problem.

"An error occurred attempting to write the new keyboard
macros. Macro was not added"
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Mac Keyboard Keys Not Supported for Remote Access

When a Mac® is used as the client, the following keys on the Mac®
keyboard are not captured by the Java™ Runtime Environment (JRE™):

e [9

[ ] F1O

[ ] F11

o Fl14

[ ] F15

e Volume Up

e Volume Down
e Mute

e FEject

As a result, the Virtual KVM Client (VKC] are unable to process these
keys from a Mac client's keyboard.

234

Mouse Notes

Mouse Pointer Synchronization (Fedora)

When connected in dual mouse mode to a target device running Fedora®
7, if the target and local mouse pointers lose synchronization, changing
the mouse mode from or to Intelligent or Standard may improve
synchronization.

Single mouse mode may also provide for better control.

> To resynchronize the mouse cursors:
e Use the Synchronize Mouse option from the Virtual KVM Client (VKC).

Single Mouse Mode when Connecting to a Target Under CC-SG
Control

When using Firefox® to connect to a KX Il target under CC-SG control
using DCIM-PS2 or DCIM-USBG2, if you change to Single Mouse Mode in
the Virtual KVM Client (VKC], the VKC window will no longer be the focus
window and the mouse will not respond.

If this occurs, left click on the mouse or press Alt+Tab to return the focus
to the VKC window.

Mouse Sync Issues in Mac 0S 10

In Mac 0S 10, if mouse sync is an issue at some resolutions, use USB
profile "General” and Absolute mouse mode.
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Audio
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Audio Playback and Capture Issues
Features that May Interrupt an Audio Connection

If you use any of the following features while connected to an audio
device, your audio connection may be interrupted. Raritan recommends
you do not use these features if you are connected to an audio device:

e Video Auto-Sense
e Extensive use of the local port
e Adding users

Issues when Using a Capture Device and Playback Device
Simultaneously on a Target

On some targets, the simultaneous connection of capture devices and
playback devices may not work due to the USB hub controller and how it
manages the USB ports. Consider selecting an audio format that
requires less bandwidth.

If this does not resolve the issue, connect the D2CIM-DVUSB CIM's
keyboard and mouse connector to a different port on the target. If this
does not solve the problem, connect the device to a USB hub and connect
the hub to the target.

Audio in a Linux Environment

The following are known issues when using the audio feature in a Linux®
environment.

e Linux® users, use the default audio device for playback. Sound may
not come through if a non-default sound card is selected.

e SuSE 11 clients require Javas_1_6_0-sun-alsa (ALSA support for
java-1_6_0-sun) to be installed via YAST.

e For Logitech® headsets with a built in a mic, only the Mono Capture
option is available.

e Inorder to display the device, if you are running SUSE 11 and an
ALSA driver, log out of KX IlI, then log back in.
Additionally, if you connect and disconnect the audio device a number
of times, the device may be listed several times vs. just once as it
should.

e Using the audio feature with a Fedora Core® 13 target set to mono 16
bit, 44k may cause considerable interference during playback.
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Audio in a Windows Environment

On Windows® 64-bit clients, only one playback device is listed on the
Connect Audio panel when accessing the device through the Virtual KYM
Client (VKC].

The audio device is the default device, and is listed on the Connect Audio
panel as Java Sound Audio Engine.

Smart Card Notes

Virtual KVM Client (VKC) Smart Card Connections to Fedora Servers

If you are using a smart card to connect to a Linux® Fedora® server via
Virtual KVM Client (VKC) upgrade the pcsc-lite library to 1.4.102-3 or
above.

CC-5SG Notes

Virtual KVM Client Version Not Known from CC-SG Proxy Mode

When the Virtual KVM Client [VKC] is launched from CommandCenter
Secure Gateway (CC-SG]J in proxy mode, the VKC version is unknown.

In the About Raritan Virtual KVM Client dialog, the version is displayed as
“Version Unknown”.

Moving Between Ports on a Device

If you move a between ports on the same Raritan device and resume
management within one minute, CC-SG may display an error message.

If you resume management, the display will be updated.

Browser Notes

Resolving Issues with Firefox Freezing when Using Fedora

If you are accessing Firefox® and are using a Fedora® server, Firefox may
freeze when it is opening.

To resolve this issue, install the libnpjp2.so Java™ plug-in on the server.
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Question
What is Dominion KX [11?

Answer

Dominion KX lll is a third-generation digital
KVM (keyboard, video, mouse] switch that
enables one, two, four or eight IT
administrators to access and control 8, 16, 32
or 64 servers over the network with BIOS-level
functionality. Dominion KX Il is completely
hardware- and 0S-independent; users can
troubleshoot and reconfigure servers even
when servers are down.

At the rack, Dominion KX IIl provides the same
functionality, convenience, and space and cost
savings as traditional analog KVM switches.
However, Dominion KX Ill also integrates the
industry’s highest performing KVM-over-IP
technology, allowing multiple administrators to
access server KVM consoles from any
networked workstation as well as from the
iPhone® and iPade.
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How is KX III
7
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different from KX

Appendix E: Frequently Asked Questions

Answer

The KX Il is the next generation version of the
KX II.  Featuring a modern hardware design
with increased computing power and storage,
the KX IIl provides KVM-over-IP access for IT
administration, as well as high performance IP
access for broadcast applications. KXl
includes virtually all KX Il features with the
following advancements:

The KX IlI's new video processing engine
supports a broad range of applications from
traditional computer applications to the most
dynamic broadcast applications requiring 30
frames-per-second 1920x1080 video, 24 bit
color, digital audio, dual monitors and DVI,
HDMI, DisplayPort and VGA video.

With the industry's first DVI-based local port,
the KX IlI's common user interface provides
new levels of productivity and performance for
at-the-rack administration and server access.

ALL KX IIl models feature a tiering port to
connect multiple Dominion KX Il switches
together and access the attached servers. Up
to 1024 servers can be accessed via a
consolidated port list.

KX Il supports all Dominion and Paragon I
CIMs supported by KX II.
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Question Answer
How does Dominion KX Il differ When using Dominion KX Il remotely, the
from remote control software? interface, at first glance, may seem similar to

remote control software such as
pcAnywhere™, Windows® Terminal
Services/Remote Desktop, VNC, etc. However,
because Dominion KX Ill is not a software but a
hardware solution, it's much more powerful:

Hardware- and 0S-independent - Dominion KX
[Il can be used to manage servers running
many popular 0Ss, including Intel®, Sune,
PowerPC running Windows, Linux®, Solaris™,
etc.

State-independent/Agentless - Dominion KX
IIKX Il does not require the managed server
0S to be up and running, nor does it require
any special software to be installed on the
managed server.

Out-of-band - Even if the managed server’s
own network connection is unavailable, it can
still be managed through Dominion KX III.

BIOS-level access - Even if the server is hung
at boot up, requires booting to safe mode, or
requires system BIOS parameters to be
altered, Dominion KX III still works flawlessly
to enable these configurations to be made.

Can the Dominion KX Il be rack Yes. The Dominion KX Il ships standard with
mounted? 19" rack mount brackets. It can also be reverse
rack mounted so the server ports face forward.

How large is the Dominion KX IlI?  Dominion KX Ill is only 1U high (except the
KX3-864 and KX3-464, which are 2U), fits in a
standard 19" rack mount and is only 11.4" (29
cm) deep. The Dominion KX3-832 and KX3-864
are 13.8" (36 cm) deep.

Remote Access
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Question

How many users can remotely
access servers on each Dominion
KX 1117

Can | remotely access servers
from my iPhone or iPad?

Can two people look at the same
server at the same time?

Can two people access the same
server, one remotely and one from
the local port?
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Answer

Dominion KX [ll models offer remote
connections for up to eight users per user
channel to simultaneously access and control
a unique target server. For one-channel
appliances like the DKX3-116, up to eight
remote users can access and control a single
target server. For two-channel appliances, like
the DKX3-216, up to eight users can access
and control the server on channel one and up
to another eight users on channel two. For
four-channel appliances, up to eight users per
channel, for a total of 32 (8 x 4) users, can
access and control four servers. Likewise, for
the eight-channel appliances, up to eight users
can access a single server, up to an overall
maximum of 32 users across the eight
channels.

Yes. Users can access servers connected to
the KX Il using their iPhone or iPad.

Mobile access is provided through Mobile
Access Client, which requires the use of
CommandCenter Secure Gateway (CC-SG).

Yes. Actually, up to eight people can access
and control any single server at the same time.

Yes. The local port is completely independent
of the remote "ports.” The local port can
access the same server using the PC-Share
feature.
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Question Answer

In order to access Dominion KX Il Because Dominion KX Il is completely

from a client, what hardware, Web-accessible, it doesn’t require customers
software or network configuration to install proprietary software on clients used
is required? for access.

Dominion KX [l can be accessed through major
Web browsers, including: Internet Explorer®
and Firefox®. Dominion KX Ill can be accessed
on Windows®, Linux® and Mac® desktops, via
Raritan's Windows Client, and the Java™-based
Virtual KVM Client™.

Dominion KX IIl administrators can also
perform remote management (set passwords
and security, rename servers, change IP
address, etc.) using a convenient
browser-based interface.

What is the file size of the applet The Virtual KVM Client (VKC) applet used to

that's used to access Dominion KX access Dominion KX Ill is approximately 500KB

117 How long does it take to in size. The following chart describes the time

retrieve? required to retrieve Dominion KX III's applet at
different network speeds:

100Mbps Theoretical .05 seconds
100Mbit network
speed

60Mbps Likely practical .08 seconds
100Mbit network
speed

10Mbps Theoretical 10Mbit .4 seconds
network speed

6Mbps Likely practical .8 seconds
10Mbit network
speed

512Kbps Cable modem 8 seconds
download speed
(typical)
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Question

Do you have a Windows KVM
Client?

Do you have a non-Windows KVM
Client?

Do your KVM Clients have
multi-language support?

Do your KVM Clients support dual
LCD monitors?

Do you support servers with dual
video cards?

How do | access servers connected

to Dominion KX Il if the network
ever becomes unavailable?

Appendix E: Frequently Asked Questions

Answer

Yes. We have a native .NET Windows Client
called the Raritan Active KVM Client (AKC]). See
Active KVM Client [AKC] Help (on page 90)

Yes. The Virtual KVM Client (VKC) allows
non-Windows users to connect to target
servers in the data center. See Virtual KVM
Client [VKC] Help (see "Virtual KVM Client
[VKC and VKCs] Help" on page 45)

Yes. The Dominion KX III's remote HTML User
Interface and the KVM Clients support the
Japanese, Simplified Chinese and Traditional
Chinese languages. This is available
stand-alone as well as through CC-SG.

Yes. For customers wishing to enhance their
productivity by using multiple LCD monitors on
their desktops, the Dominion KX Il can launch
KVM sessions to multiple monitors, either in
full screen or standard modes.

Yes, dual video cards are supported with an
extended desktop configuration available to the
remote user.

You can access servers at the rack or via
modem.

Dominion KX Ill offers a dedicated modem port
for attaching an external modem.

Universal Virtual Media

Question

Which Dominion KX Ill models
support virtual media?

Which types of virtual media does
the Dominion KX Il support?

Raritan.
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Answer

All Dominion KX Ill models support virtual
media. It is available stand-alone and through
CommandCenter® Secure Gateway, Raritan’s
centralized management appliance.

Dominion KX Il supports the following types of
media: internal and USB-connected CD/DVD
drives, USB mass storage devices, PC hard
drives and ISO images.
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Question

What is required for virtual media?

Is virtual media secure?

Does virtual media really support
audio?

What is a USB profile?

244

Answer

A Dominion KX Il virtual media CIM is required.
There are two VGA-based CIMs: a D2CIM-VUSB
or D2CIM-DVUSB.

The D2CIM-VUSB has a single USB connector
and is for customers who will use virtual media
at the 0S level.

The D2CIM-DVUSB has dual USB connectors
and should be purchased by customers who
wish to utilize virtual media at the BIOS level.
The D2CIM-DVUSB is also required for smart
card authentication, tiering/cascading and
digital audio.

Both support virtual media sessions to target
servers supporting the USB 2.0 interface.
Available in economical 32 and 64 quantity CIM
packages, these CIMs support Absolute Mouse
Synchronization™ as well as remote firmware
updates.

Our CIMs have traditionally supported analog
VGA video. Three new dual virtual media CIMs
support digital video formats, including DVI,
HDMI and DisplayPort. These are the
D2CIM-DVUSB-DVI, D2CIM-DVUSB-HDMI and
D2CIM-DVUSB-DP.

Yes. Virtual media sessions are secured using
256-bit AES or 128-bit AES encryption.

Yes. Audio playback and recording to a server
connected to the Dominion KX lll is supported.
You can listen to sounds and audio playing on a
remote server in the data center using the
speakers connected to your desktop PC or
laptop. You can also record on the remote
server using a microphone connected to your
PC or laptop. A digital CIM or D2CIM-DVUSB
dual virtual media CIM is required.

Certain servers require a specifically configured
USB interface for USB-based services such as
virtual media. The USB profile tailors the KX lll's
USB interface to the server to accommodate
these server-specific characteristics.
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Question Answer

Why would | use a USB profile? USB profiles are most often required at the
BIOS level where there may not be full support
for the USB specification when accessing virtual
media drives. However, profiles are sometimes
used at the OS level, for example, for mouse
synchronization for Mac and Linux servers.

How is a USB profile used? Individual ports or groups of ports can be
configured by the administrator to use a specific
USB profile in the KX III's port configuration
page. A USB profile can also be selected in the
KX Il Client when required. See the user guide
for more information.

Do | always need to set a USB No. In many cases, the default USB profile is

profile when | use virtual media?  sufficient when using virtual media at the 0S
level or operating at the BIOS level without
accessing virtual media.

What profiles are available? Where Consult the user guide for the available profiles
can | find more information? and for more information.

Bandwidth and KVM-over-IP Performance
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Question Answer
How is bandwidth used in Dominion KX III offers totally new video
KVM-over-IP systems? processing that provides flexible, high

performance video, efficient use of bandwidth
and anytime/anywhere access via LAN, WAN or
Internet.

The Dominion KX IIl digitizes, compresses and
encrypts the keyboard, video and mouse
signals from the target server and transmits IP
packets over the IP network to the remote
client to create the remote session to the user.
The KX Il provides an at-the-rack experience
based on its industry-leading video processing
algorithms.

Screen changes, i.e., video accounts for the
majority of the bandwidth used - and keyboard
and mouse activity are significantly less.

It is important to note that bandwidth is only
used when the user is active. The amount of
bandwidth used is based on the amount of

change to the server’s video display screen.

If there are no changes to the video - the user
is not interacting with the server - there is
generally little to no bandwidth used. If the
user moves the mouse or types a character,
then there is a small amount of bandwidth
used. If the display is running a complex
screen saver or playing a video, then there can
be a larger amount of bandwidth used.

How does bandwidth affect In general, there is a trade-off between

KVM-over-IP performance? bandwidth and performance. The more
bandwidth available, the better performance
can be. In limited bandwidth environments,
performance can degrade. The Dominion KX [l|
has been optimized to provide strong
performance in a wide variety of environments.
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Question
What factors affect bandwidth?

How much bandwidth does KX Il
use for common tasks?
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Answer

There are many factors that determine how
much bandwidth will be used. The primary
factor, noted above, is the amount of change in
the target server’s video display. This is
dependent on the user’s task and actions.

Other factors include the server’s video
resolution, networking speed and
characteristics, the KYM Client Connection
Properties, client PC resources and video card
noise.

Bandwidth primarily depends on the user’s
task and actions. The more the server’s video
screen changes, the more bandwidth is
utilized.
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Question

How do | optimize performance
and bandwidth?

| want to connect over the Internet.
What type of performance should |
expect?

Answer

KX Il provides a variety of settings in our
remote clients for the user to optimize
bandwidth and performance. The default
settings will provide an at-the-rack level of
performance in standard LAN/WAN
environments with economical use of
bandwidth.

Optimize For. Use this setting to configure
the video engine for standard IT/computer
applications or for video/broadcast
applications.

Compression. Move the slider to the left for
the highest possible video quality and to the
right for the least amount of bandwidth.

Noise Filter. In most cases, the default
setting will work best, however you can move
to the left for more responsive video and to the
right for lower bandwidth.

Other tips to decrease bandwidth include:

= Use a solid desktop background instead of a
complex image

= Disable screensavers

= Use a lower video resolution on the target
server

= Uncheck the "Show window contents while
dragging” option in Windows

= Use simple images, themes and desktops
(e.g., Windows Classic]

It depends on the bandwidth and latency of the
Internet connection between your remote
client and the KX Ill. With a cable modem or
high speed DSL connection, your performance
can be very similar to a LAN/WAN connection.
For lower speed links, use the suggestions
above to improve performance.
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Question

| have a high bandwidth
environment. How can | optimize
performance?

What is the maximum remote
(over IP) video resolution
supported?

How much bandwidth is used for
audio?

What about servers with DVI ports?
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Answer

The default settings will work well. You can
move the Connection Properties settings to the
left for increased video performance.

The Dominion KX Il is the first and only
KVM-over-IP switch to support full high
definition (HD) remote video resolution -
1920x1080 at frame rates up to 30 frames per
second with digital audio.

In addition, popular widescreen formats are
supported, including 1600x1200, 1680x1050
and 1440x900, so remote users can work with
today’s higher resolution monitors.

It depends on the type of audio format used,
but to listen to CD quality audio, approximately
1.5 Mbps is used.

Servers with DVI ports that support DVI-A
(analog) and DVI-I (integrated analog and
digital) can use Raritan’s ADVI-VGA
inexpensive, passive adapter to convert the
server’s DVI port to a VGA plug that can be
connected to a KX Il CIM's VGA plug.

Servers with DVI ports that support DVI-I or
DVI-D (digital) can use the new
D2CIM-DVUSB-DVI CIM.

IPv6 Networking
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Question

What is IPv6?

250

Why does KX Il support IPvé
networking?

What is "dual stack” and why
is it required?

How do | enable IPvé on the
KX 1117

What if | have an external
server with an IPvé6 address

that | want to use with my KX
?

What if my network doesn’t
support IPv6?

Answer

[Pvé is the acronym for Internet Protocol Version 6.
IPv6 is the "next generation™ IP protocol which will
replace the current IP Version 4 (IPv4) protocol.

IPvé6 addresses a number of problems in [Pv4, such
as the limited number of IPv4 addresses. It also
improves IPv4 in areas such as routing and network
auto-configuration. IPvé is expected to gradually
replace IPv4, with the two coexisting for a number of
years.

IPvé treats one of the largest headaches of an IP
network from the administrator’s point of view -
configuring and maintaining an IP network.

U.S. government agencies and the Department of
Defense are now mandated to purchase
IPvé6-compatible products. In addition, many
enterprises and foreign countries, such as China, will
be transitioning to IPvé6 over the next several years.

Dual stack is the ability to simultaneously support
IPv4 and IPv6 protocols. Given the gradual transition
from IPv4 to IPvé, dual stack is a fundamental
requirement for IPvé support.

Use the "Network Settings” page, available from the
“Device Settings"” tab. Enable IPv6 addressing and
choose manual or auto-configuration. Consult the
user guide for more information.

The KX Il can access external servers via their IPvé
addresses, for example, an SNMP manager, syslog
server or LDAP server.

Using the KX llI's dual-stack architecture, these
external servers can be accessed via: (1) an IPv4
address, (2) IPvé address or (3) hostname. So, the KX
[l supports the mixed IPv4/IPvé environment many
customers will have.

The KX III's default networking is set at the factory for
IPv4 only. When you are ready to use IPvé, then follow
the above instructions to enable IPv4/IPvé dual-stack
operation.
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Question Answer

Where can | get more See www.ipvé.org for general information on IPvé.

information on IPv6? The KX Il user guide describes the KX III's support for
[Pvé.

Servers

Question Answer

Does Dominion KX Ill depend on a
Windows server to operate?

What should | do to prepare a
server for connection to Dominion
KX 1117

What about mouse
synchronization?

What comes in the Dominion KX IlI
box?

Absolutely not. Because users depend on the
KVM infrastructure to always be available in
any scenario whatsoever (as they will likely
need to use the KYM infrastructure to fix
problems), Dominion KX Il is designed to be
completely independent from any external
server.

Set the mouse parameter options to provide
users with the best mouse synchronization and
turn off screensavers and any power
management features that affect screen
display.

In the past, KYM-over-IP mouse
synchronization was a frustrating experience.
The Dominion KX III's Absolute Mouse
Synchronization provides for a tightly
synchronized mouse without requiring server
mouse setting changes on Windows and Apple®
Mac servers. For other servers, the Intelligent
Mouse mode or the speedy, single mouse
mode can be used to avoid changing the server
mouse settings.

The following is included: (1) Dominion KX IlI
appliance, (2) Quick Setup Guide, (3) standard
19" rack mount brackets, (4) user manual
CD-ROM, (6) localized AC line cord and (7)
warranty certificate and other documentation.

Blade Servers
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Question

Can | connect blade servers to the
Dominion KX 1?7

Which blade servers are
supported?

Which CIM should | use?

Which types of access and control
are available?

Do | have to use hotkeys to switch
between blades?

Can | access the blade server’s
management module?

How many blade servers can |
connect to a Dominion KX 11?7

Answer

Yes. Dominion KX Il supports popular blade
server models from the leading blade server
manufacturers: HP®, IBM®, Dell® and Cisco®.

The following models are supported: Dell
PowerEdge® 1855, 1955 and M1000e; HP
BladeSystem c3000 and c7000; IBM
BladeCenter® H, E and S; and Cisco UCS
B-Series.

It depends on the type of KVM ports on the
specific make and model of the blade server
you are using. The following CIMs are
supported: DCIM-PS2, DCIM-USBG2,
D2CIM-VUSB and D2CIM-DVUSB.

The Dominion KX Il provides automated and
secure KVM access: (1) at the rack, (2)
remotely over IP, (3) via CommandCenter and
(4) by modem.

Some blade servers require you to use hotkeys
to switch between blades. With the Dominion
KX 111, you don’t have to use these hotkeys. Just
click on the name of the blade server, and the
Dominion KX Il will automatically switch to
that blade without the explicit use of the
hotkey.

Yes. You can define the URL of the
management module and access it from the
Dominion KX Il or from our CommandCenter
Secure Gateway. If configured, one-click
access is available.

For performance and reliability reasons, you
can connect up to eight blade chassis to a
Dominion KX I, regardless of model. Raritan
recommends connecting up to two times the
number of remote connections supported by
the device. For example, with a KX3-216 with
two remote channels, we recommend
connecting up to four blade server chassis. You
can, of course, connect individual servers to
the remaining server ports.
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Question

I’'m an enterprise customer using
CommandCenter Secure Gateway.
Can | access blade servers via
CommandCenter Secure Gateway?

What if | also want in-band or
embedded KVM access?

I'm running VMware® on some of
my blade servers. Is this
supported?

Is virtual media supported?

Is Absolute Mouse Synchronization
supported?

Is blade access secure?

Does the Dominion KSX Il or the KX
[11-101 support blade servers?

Appendix E: Frequently Asked Questions

Answer

Yes. Once blade servers are configured on the
Dominion KX Ill, the CommandCenter Secure
Gateway user can access them via KVM
connections. In addition, the blade servers are
organized by chassis as well as
CommandCenter Secure Gateway custom
views.

In-band and embedded access to blade servers
can be configured within CommandCenter
Secure Gateway.

Yes. With CommandCenter Secure Gateway,
you can display and access virtual machines
running on blade servers.

This depends on the blade server. HP blades
can support virtual media. The IBM
BladeCenter (except for BladeCenter T)
supports virtual media if configured
appropriately. A virtual media CIM -
D2CIM-VUSB or D2CIM-DVUSB - must be
used.

Servers with internal KVM switches inside the
blade chassis typically do not support absolute
mouse technology. For HP blade and some
Dell blade servers, a CIM can be connected to
each blade, so Absolute Mouse
Synchronization is supported.

Yes. Blade access uses all of the standard
Dominion KX Il security features such as
128-bit or 256-bit encryption. In addition, there
are blade-specific security features such as
per blade access permissions and
hotkey-blocking that eliminates unauthorized
access.

At this time, these products do not support
blade servers.

Installation
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Question

Besides the appliance itself, what
do | need to order from Raritan to
install Dominion KX [11?

Which kind of Cat5 cabling should
be used in my installation?

Which types of servers and PCs

can be connected to Dominion KX
[11?

How do | connect servers to
Dominion KX 11?7

How far can my servers be from
Dominion KX 1117

254

Answer

Each server that connects to Dominion KX ||
requires a Dominion or Paragon computer
interface module (CIM), an adapter that
connects directly to the keyboard, video and
mouse ports of the server.

Dominion KX Il can use any standard UTP
(unshielded twisted pair) cabling, whether
Catb, Catbe or Caté. Often in our manuals and
marketing literature, Raritan will simply say
“Catb" cabling for short. In actuality, any brand
UTP cable will suffice for Dominion KX I11.

Dominion KX Il is completely vendor
independent. Any server with
standards-compliant keyboard, video and
mouse ports can be connected. In addition,
servers with serial ports can be controlled
using the P2CIM-SER CIM.

Servers that connect to the Dominion KX Il
require a Dominion or Paragon CIM, which
connects directly to the keyboard, video and
mouse ports of the server. Then, connect each
CIM to Dominion KX Il using standard UTP
(unshielded twisted pair) cable such as Cat5,
Catbe or Caté.

In general, servers can be up to 150 feet (45 m)
away from Dominion KX Ill, depending on the
type of server. (See Target Server Video
Resolution Supported Connection Distances
and Refresh Rates (on page 197)) For the
D2CIM-VUSB CIMs that supports virtual media
and Absolute Mouse Synchronization, a
100-foot (30 m] range is recommended.
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Question

Some operating systems lock up
when | disconnect a keyboard or
mouse during operation. What
prevents servers connected to
Dominion KX Ill from locking up
when | switch away from them?

Are there any agents
that must be installed on servers
connected to Dominion KX 11?7

How many servers can be
connected to each Dominion KX Il
appliance?

What happens if | disconnect a
server from Dominion KX Il and
reconnect it to another Dominion
KX Il appliance, or connectitto a
different port on the same
Dominion KX Il appliance?
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Answer

Each Dominion computer interface module
(DCIM] dongle acts as a virtual keyboard and
mouse to the server to which it is connected.
This technology is called KME
(keyboard/mouse emulation). Raritan’s KME
technology is data center grade, battle-tested
and far more reliable than that found in
lower-end KVM switches: it incorporates more
than 15 years of experience and has been
deployed to millions of servers worldwide.

Servers connected to Dominion KX Il do not
require any software agents to be installed
because Dominion KX Il connects directly via
hardware to the servers’ keyboard, video and
mouse ports.

Dominion KX Il models range from 8, 16 or 32
server ports in a 1U chassis, to 64 server ports
in a 2U chassis. This is the industry’s highest
digital KVM switch port density.

Dominion KX Il will automatically update the
server port names when servers are moved
from port to port. Furthermore, this automatic
update does not just affect the local access
port, but propagates to all remote clients and
the optional CommandCenter Secure Gateway
management appliance.
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Question Answer

How do | connect a serially If there are only a few serially controlled
controlled (RS-232] device, such as devices, they may be connected to a Dominion
a Ciscorouter/switch or a headless KX Il using Raritan's P2CIM-SER serial

Sun server, to Dominion converter.

KX 1117 Customers can also consider deploying the
Dominion KSX II, an integrated KVM and serial
switch. The DKSX-144 features four
KVM-over-IP ports and four serial ports.

The DKSX-188 features eight KVM-over-IP
ports and eight serial ports.

However, if there are many serially controlled
devices, we recommend the use of Raritan’s
Dominion SX line of secure console servers.
Dominion SX offers more serial functionality at
a better price point than Dominion KX IIl. This
SXis easy to use, configure and manage, and
can be completely integrated with a Dominion
series deployment.

Local Port - KX Il

Question Answer

Can | access my servers directly Yes. At the rack, Dominion KX Ill functions just

from the rack? like a traditional KVM switch - allowing control
of up to 64 servers using a single keyboard,
monitor and mouse. You can switch between
servers by the browser- based user interface or
via a hotkey.

Can | consolidate the local ports of Yes. You can connect the local ports of multiple

multiple KX llls? KX Il switches to another KX Il using the
“tiering” feature of the KX lll. You can then
access the servers connected to your KX llI
appliances from a single point in the data center
via a consolidated port list.
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Question

When | am using the local port, do
| prevent other users from
accessing servers remotely?

Can | use a USB keyboard or
mouse at the local port?

Is there an onscreen display (0SD)
for local, at-the-rack access?

How do | select between servers
while using the local port?

How do | ensure that only
authorized users can access
servers from the local port?

Appendix E: Frequently Asked Questions

Answer

No. The Dominion KX Ill local port has a
completely independent access path to the
servers. This means a user can access servers
locally at the rack - without compromising the
number of users that access the rack remotely
at the same time.

Yes. The Dominion KX Ill has USB keyboard and
mouse ports on the local port. Dominion KX IlI
switches do not have PS/2 local ports.
Customers with PS/2 keyboards and mice
should utilize a PS/2 to USB adapter.

Yes, but Dominion KX IlI's at-the-rack access
goes way beyond conventional OSDs. Featuring
the industry’s first browser-based interface for
at-the-rack access, Dominion KX IlI's local port
uses the same interface for local and remote
access. Moreover, most administrative
functions are available at the rack.

The local port displays the connected servers
using the same user interface as the remote
client. Users connect to a server with a simple
click of the mouse or via a hotkey.

Users attempting to use the local port must
pass the same level of authentication as those
accessing remotely. This means that:

If the Dominion KX Ill is configured to interact
with an external RADIUS, LDAP or Active
Directory® server, users attempting to access
the local port will authenticate against the same
server.

If the external authentication servers are
unavailable, Dominion KX Ill fails over to its own
internal authentication database.

Dominion KX Il has its own stand-alone
authentication, enabling instant, out-of-the-box
installation.

Extended Local Port
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Question

What is the extended local port?

Answer

The Dominion KX2-808, KX2-832 and KX2-864
featured an extended local port. The
corresponding Dominion KX [l models do not
have an extended local port. Instead all KX IlI
models have a tiering port.

To extend the KX IlI's digital local port, you can
use the Raritan Cat5 Reach DVI product for
local and remote access up to 500 meters.

See Connecting a KX Il and Catb Reach DVI -

Provide Extended Local Port Functionality
(on page 181)

Dual Power Supplies

Question

Does Dominion KX Il have a dual
power option?

Does the power supply used by
Dominion KX Il automatically
detect voltage settings?

If a power supply or input fails, will
| be notified?

Answer

Yes. All Dominion KX Ill models come equipped
with dual AC inputs and power supplies with
automatic failover. Should one of the power
inputs or power supplies fail, then the KX 1l will
automatically switch to the other.

Yes. Dominion KX III's power supply can be used
in AC voltage ranges from 100-240 volts, at
50-60 Hz.

The Dominion KX III front panel LED will notify
the user of a power failure. An entry will also be
sent to the audit log and displayed on the KX
remote client user interface. If configured by the
administrator, then SNMP or syslog events will
be generated.

Intelligent Power Distribution Unit (PDU) Control
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Question

What type of remote power control
capabilities does Dominion KX Il
offer?

What type of power strips does
Dominion KX IIl support?

How many PDUs can be connected
to a Dominion KX 1117

How do | connect the PDU to the
Dominion KX 1?7

Does Dominion KX Il support
servers with multiple power
supplies?

Does the Dominion KX Il display
statistics and measurements from
the PDU?

Does remote power control
require any special configuration
of attached servers?

What happens when | recycle
power to a server?

Raritan.
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Answer

Raritan’s intelligent PDUs can be connected to
the Dominion KX Il to provide power control of
target servers and other equipment. For
servers, after a simple one-time configuration
step, just click on the server name to power on,
off or to recycle a hung server.

Raritan's Dominion PX™ and Remote Power
Control (RPC) power strips.

These come in many outlet, connector and amp
variations. Note that you should not connect
the PM series of power strips to the Dominion
KX Il as these power strips do not provide
outlet-level switching.

Up to eight PDUs can be connected to a
Dominion KX Il appliance.

The D2CIM-PWR is used to connect the power
strip to the Dominion KX IIl. The D2CIM-PWR
must be purchased separately; it does not
come with the PDU.

Yes. Dominion KX Il can be easily configured to
support servers with multiple power supplies
connected to multiple power strips. Four
power supplies can be connected per target
server.

Yes. PDU-level power statistics, including
power, current and voltage, are retrieved from
the PDU and displayed to the user.

Some servers ship with default BIOS settings
such that the server does not automatically
restart after losing and regaining power. For
these servers, see the server’'s documentation
to change this setting.

Note that this is the physical equivalent of
unplugging the server from the AC power line,
and reinserting the plug.
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Ethernet and IP Networking

Question

What is the speed of Dominion KX
[II's Ethernet interfaces?

Can | access Dominion
KX Il over a wireless connection?

Does the Dominion KX Il offer dual
gigabit Ethernet ports to provide
redundant failover or load
balancing?

Can | use Dominion KX Il with a
VPN?

Can | use KX Il with a proxy
server?

How many TCP ports must be open
on my firewall in order to enable
network access to Dominion KX [11?

Are these ports configurable?

Answer

Dominion KX Il supports gigabit as well as
10/100 Ethernet. KX Il supports two
10/100/1000 speed Ethernet interfaces, with
configurable speed and duplex settings (either
auto detected or manually set).

Yes. Dominion KX Il not only uses standard
Ethernet, but also very conservative bandwidth
with very high quality video. Thus, if a wireless
client has network connectivity to a Dominion
KX 1ll, servers can be configured and managed
at the BIOS level wirelessly.

Yes. Dominion KX IIl features dual gigabit
Ethernet ports to provide redundant failover
capabilities. Should the primary Ethernet port
(or the switch/router to which it is connected])
fail, Dominion KX Il will failover to the
secondary network port with the same IP
address - ensuring that server operations are
not disrupted. Note that automatic failover must
be enabled by the administrator.

Yes. Dominion KX Il uses standard Internet
Protocol (IP) technologies from Layer 1 through
Layer 4. Traffic can be easily tunneled through
standard VPNs.

Yes. KX Il can be used with a SOCKS proxy
server, assuming the remote client PC is
configured appropriately. Contact the user
documentation or online help for more
information.

Two ports are required: TCP port 5000 to
discover other Dominion appliances and for
communication between Raritan appliances and
CC-SG; and, of course, port 443 for HTTPS
communication.

Yes. Dominion KX [II's TCP ports are
configurable by the administrator.
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Question

Can Dominion KX Il be used with
Citrixe?

Can the Dominion KX Il use
DHCP?

I’'m having problems connecting to
the Dominion KX Ill over my IP
network. What could be the
problem?

Appendix E: Frequently Asked Questions

Answer

Dominion KX IIl may work with remote access
products like Citrix if configured appropriately,
but Raritan cannot guarantee it will work with
acceptable performance. Customers should
realize that products like Citrix utilize video
redirection technologies similar in concept to
digital KVM switches so that two KVM-over-IP
technologies are being used simultaneously.

DHCP addressing can be used; however, Raritan
recommends fixed addressing since the
Dominion KX Il is an infrastructure appliance
and can be accessed and administered more
effectively with a fixed IP address.

The Dominion KX Il relies on your LAN/WAN
network. Some possible problems include:

= Ethernet auto-negotiation. On some
networks, 10/100 auto-negotiation does not
work properly, and the Dominion KX IlI
appliance must be set to 100 Mb/full duplex
or the appropriate choice for its network.

= Duplicate IP address. If the IP address of the
Dominion KX Il is the same as another
appliance, network connectivity may be
inconsistent.

= Port 5000 conflicts. If another appliance is
using port 5000, the Dominion KX lll default
port must be changed (or the other
appliance must be changed).

= When changing the IP address of a Dominion
KX 111, or swapping in a new Dominion KX IlI,
sufficient time must be allowed for its IP and
Mac® addresses to be known throughout the
Layer 2 and Layer 3 networks.

Local Port Consolidation, Tiering and Cascading
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Question Answer

How do | physically connect To physically connect multiple KX Il appliances
multiple Dominion KX Il appliances together for consolidated local access, you can
together into one solution? connect the Tiering ports of multiple "tiered”

(or "cascaded"] KX IIl switches to a "base” KX
[l using the Tiering port of the KX III. You can
then access the servers connected to your KX
[Il appliances from a single point in the data
center via a consolidated port list.

The Tiering port must be used to connect the
tiered KX lll switch to the base switch.

Access via the consolidated port list is
available in the data center or even from a
remote PC. All servers connected to the tiered
KX llls can be accessed via a hierarchical port
list or via search (with wildcards).

Two levels of tiering are supported; up to 1024
appliances can be accessed in a tiered
configuration. Remote power control is also
supported.

Virtual media, smart card and blade server
access via tiered access will be supported in a
future release. Of course these features are
available when accessed via a standard remote
connection.

While remote IP server access via the
consolidated port list is available as a
convenience, remote accessing a tiered server
from CommandCenter or via the KX Il the
server is connected to, is recommended for
optimal performance.
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Question

Do I have to physically connect
Dominion KX Il appliances
together?

Is CC-SG required?
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Answer

Multiple Dominion KX Il appliances do not
need to be physically connected together.
Instead, each Dominion KX Il appliance
connects to the network, and they
automatically work together as a single
solution if deployed with Raritan’s
CommandCenter Secure Gateway (CC-SG)
management appliance.

CC-SG acts as a single access point for remote
access and management.

CC-SG offers a significant set of convenient
tools, such as consolidated configuration,
consolidated firmware update and a single
authentication and authorization database.

Customers using CC-SG for centralized remote
access can make good use of the KX llI's
tiering (cascading) feature to consolidate the
local ports of multiple KX Il switches and
locally access up to 1024 servers from a single
console when in the data center.

For customers wanting stand-alone usage
(without a central management system),
multiple Dominion KX Il appliances still
interoperate and scale together via the IP
network. Multiple Dominion KX Il switches can
be accessed from the KX Il Web-based user
interface.
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Question Answer
Can | connect an existing analog Yes. Analog KVM switches can be connected to
KVM switch to Dominion KX I117? one of Dominion KX III's server ports. Simply

use a USB computer interface module (CIM],
and attach it to the user ports of the existing
analog KVM switch.

Analog KVM switches supporting hotkey-based
switching on their local ports can be tiered to a
Dominion KX Il switch and switched via a
consolidated port list, both remotely and in the
data center.

Please note that analog KVM switches vary in
their specifications and Raritan cannot
guarantee the interoperability of any particular
third-party analog KVM switch. Contact Raritan
technical support for further information.

Computer Interface Modules (CIMs)

Question Answer

What type of video is supported by  Our CIMs have traditionally supported analog

your CIMs? VGA video. Three new CIMs support digital
video formats, including DVI, HDMI and
DisplayPort. These are the D2CIM-DVUSB-DVI,
D2CIM-DVUSB-HDMI and D2CIM-DVUSB-DP.
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Question

Can | use computer interface
modules (CIMs) from Paragon,
Raritan’s analog matrix KVM
switch, with Dominion KX [I1?

Does Dominion KX Il support
Paragon Dual CIMs?

Appendix E: Frequently Asked Questions

Answer

Yes. Certain Paragon computer interface
modules (CIMs] may work with Dominion KX
IKX 1111. (Please check the Raritan Dominion KX
Il Release Notes on the website for the latest
list of certified CIMs.]

However, because Paragon CIMs cost more
than Dominion KX Il CIMs (as they incorporate
technology for video transmission of up to
1,000 feet [304 m]), it is not generally advisable
to purchase Paragon CIMs for use with
Dominion KX Ill. Also note that when connected
to Dominion KX III, Paragon CIMs transmit
video at a distance of up to 150 feet (46 m], the
same as Dominion KX IIl CIMs - not at 1,000
feet (304 m), as they do when connected to
Paragon.

Yes. The Dominion KX Il supports Paragon Il
Dual CIMs (P2CIM-APS2DUAL and
P2CIM-AUSBDUALJ, which can connect servers
in the data center to two different Dominion KX
[l switches.

If one KX Il switch is not available, the server
can be accessed through the second KX Il
switch, providing redundant access and
doubling the level of remote KVM access.

Please note these are Paragon CIMs, so they
do not support the KX Ill advanced features
such as virtual media, absolute mouse, audio,
etc.

Security
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Question

Is the Dominion KX Il FIPS 140-2
Certified?

What kind of encryption does
Dominion KX Il use?

Does Dominion KX Ill support AES
encryption as recommended by the
U.S. government’s NIST and FIPS
standards?

Does Dominion KX Il allow
encryption of video data? Or does it
only encrypt keyboard and mouse
data?

How does Dominion KX IlI
integrate with external
authentication servers such as
Active Directory, RADIUS or LDAP?
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Answer

The Dominion KX Il uses an embedded FIPS
140-2 validated cryptographic module running
on a Linux platform per FIPS 140-2
implementation guidelines. This cryptographic
module is used for encryption of KVM session
traffic consisting of video, keyboard, mouse,
virtual media and smart card data.

Dominion KX Ill uses industry-standard (and
extremely secure] 256-bit AES, 128-bit AES or
128-bit encryption, both in its SSL
communications as well as its own data
stream. Literally no data is transmitted
between remote clients and Dominion KX 1
that is not completely secured by encryption.

Yes. The Dominion KX Il utilizes the Advanced
Encryption Standard (AES) for added security.
256-bit and 128-bit AES is available.

AES is a U.S. government-approved
cryptographic algorithm that is recommended
by the National Institute of Standards and
Technology (NIST) in the FIPS Standard 197.

Unlike competing solutions, which only encrypt
keyboard and mouse data, Dominion KX Il
does not compromise security - it allows
encryption of keyboard, mouse, video and
virtual media data.

Through a very simple configuration, Dominion
KX Il can be set to forward all authentication
requests to an external server such as LDAP,
Active Directory or RADIUS. For each
authenticated user, Dominion KX Il receives
from the authentication server the user group
to which that user belongs. Dominion KX 11
then determines the user’'s access
permissions depending on the user group to
which he or she belongs.
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Question

How are usernames and
passwords stored?

Does Dominion KX Il support
strong passwords?

Can | upload my own digital
certificate to the Dominion KX [IKX
[1?

Does the KX Ill support a
configurable security banner?

My security policy does not allow
the use of standard TCP port
numbers. Can | change them?

Appendix E: Frequently Asked Questions

Answer

Should Dominion KX III's internal
authentication capabilities be used, all
sensitive information, such as usernames and
passwords, is stored in an encrypted format.
Literally no one, including Raritan technical
support or product engineering departments,
can retrieve those usernames and passwords.

Yes. The Dominion KX Il has
administrator-configurable, strong password
checking to ensure that user-created
passwords meet corporate and/or government
standards and are resistant to brute force
hacking.

Yes. Customers can upload self-signed or
certificate authority-provided digital
certificates to the Dominion KX Il for enhanced
authentication and secure communication.

Yes. For government, military and other
security-conscious customers requiring a
security message before user login, the KX |lI
can display a user-configurable banner
message and optionally require acceptance.

Yes. For customers wishing to avoid the
standard TCP/IP port numbers to increase
security, the Dominion KX III allows the
administrator to configure alternate port
numbers.

Smart Cards and CAC Authentication

Question

Does Dominion KX Il support smart
card and CAC authentication?
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Answer

Yes. Smart cards and DoD common access
cards (CAC) authentication to target servers
is supported.

267



Appendix E: Frequently Asked Questions

Question
What is CAC?

Which KX IIl models support smart
cards/CAC?

Do enterprise and SMB customers use
smart cards, too?

Which CIMs support
smart card/CAC?

Which smart card readers are
supported?

Can smart card/CAC authentication
work on the local port and via
CommandCenter?

Answer

Mandated by Homeland Security
Presidential Directive 12 (HSPD-12), CAC is
a type of smart card created by the U.S.
government and used by U.S. military and
government staff. The CAC card is a
multitechnology, multipurpose card; the
goal is to have a single identification card.
For more information, see the FIPS 201
standards.

All Dominion KX lll models are supported.
The Dominion KX I11-101T models do not
currently support smart cards and CAC.

Yes. However, the most aggressive
deployment of smart cards is in the U.S.
federal government.

The D2CIM-DVUSB, D2CIM-DVUSB-DVI,
D2CIM-DVUSB-HDMI and
D2CIM-DVUSB-DP are the required CIMs.

The required reader standards are USB
CCID and PC/SC. Consult the user
documentation for a list of certified readers
and more information.

Yes. Smart card/CAC authentication works
on both the local port and via
CommandCenter. For the local port,
connect a compatible smart card reader to
the USB port of the Dominion KX III.

Manageability
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Question

Can Dominion KX Ill be remotely
managed and configured via Web
browser?

Can | back up and restore
Dominion KX IlI's configuration?

What auditing or logging does
Dominion KX Il offer?

Can Dominion KX Ill integrate with
syslog?

Can Dominion KX Ill integrate with
SNMP?

Can an administrator log-off a
user?

Raritan.
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Appendix E: Frequently Asked Questions

Answer

Yes. Dominion KX Il can be completely
configured remotely via Web browser. Note
that this does require that the workstation
have an appropriate Java Runtime
Environment [JRE) version installed. Besides
the initial setting of Dominion KX lI's IP
address, everything about the solution can be
completely set up over the network. (In fact,
using a crossover Ethernet cable and Dominion
KX IlI's default IP address, you can even
configure the initial settings via Web browser.)

Yes. Dominion KX III's appliance and user
configurations can be completely backed up for
later restoration in the event of a catastrophe.

Dominion KX IlI's backup and restore
functionality can be used remotely over the
network, or through your Web browser.

For complete accountability, Dominion KX III
logs all major user events with a date and time
stamp. For instance, reported events include
(but are not limited to): user login, user logout,
user access of a particular server,
unsuccessful login, configuration changes, etc.

Yes. In addition to Dominion KX III's own
internal logging capabilities, Dominion KX Il
can send all logged events to a centralized
syslog server.

Yes. In addition to Dominion KX IlI's own
internal logging capabilities, Dominion KX Il
can send SNMP traps to SNMP management
systems. SNMP v2 and v3 are supported.

Yes, administrators can view which users are
logged into which ports and can log-off a user
from a specific port or from the appliance if
required.
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Question

Can Dominion KX IlI's internal
clock be synchronized with a
timeserver?

Answer

Yes. Dominion KX Il supports the
industry-standard NTP protocol for
synchronization with either a corporate
timeserver, or with any public timeserver
(assuming that outbound NTP requests are
allowed through the corporate firewall).

270

Documentation and Support

Question
Is online help available?

Where do | find documentation on
the Dominion KX I11?

What documentation is available?

What CIM should | use for a
particular server?

How long is the hardware warranty
for the KX I11?

Answer

Yes. Online help is available from the KX Il
user interface, and at raritan.com with the
documentation.

Online help includes KX Il administration and
end user information on using the Remote
Console, Virtual KVM Client (VKC] Active KVM
Client (AKC) and Local Console, as well KX IlI
specifications, informational notes, using KX Il
with Paragon Il, connecting KX Ill to the Cat5
Reach DVI, connecting KX Il to the T1700-LED,
and so on.

The documentation is available at raritan.com.
The documentation is listed by firmware
release.

A Quick Setup Guide, online help, a PDF
version of the help in the form of an
Administrators Guide and a Users Guide, as
well as Release Notes and other information
are available.

Consult the CIM Guide available with the KX Il
documentation. Note that DVI, HDMI and
DisplayPort video standards are supported
with the digital video CIMs.

The Dominion KX IIl comes with a standard
two-year warranty, which can be extended to 5
years of warranty coverage.
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Appendix E: Frequently Asked Questions

Miscellaneous

Question

What is Dominion KX IlI's default
|P address?

What is Dominion KX llI's default
username and password?

| changed and subsequently forgot
Dominion KX [II's administrative
password; can you retrieve it for
me?

How do | migrate from the
Dominion KX Il to Dominion KX [11?

Will my existing KX Il CIMs work
with Dominion KX III switches?

Raritan.
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Answer
192.168.0.192

The Dominion KX IlI’s default username and
password are admin/raritan. However, for the
highest level of security, the Dominion KX Il
forces the administrator to change the
Dominion KX Il default administrative
username and password when the appliance is

first booted up. Username is not case sensitive.

Dominion KX Il contains a hardware reset
button that can be used to factory reset the
appliance, which will reset the administrative
password on the appliance to the default
password.

In general, KX Il customers can continue to use
their existing switches for many years. As their
data centers expand, customers can purchase
and use the new KX Ill models. Raritan’s
centralized management appliance,
CommandCenter Secure Gateway (CC-SG)
Release 6.0 supports KX Il and KX Ill switches
seamlessly.

Yes. Existing KX || CIMs will work with the
Dominion KX Il switch. In addition, select
Paragon CIMs will work with the KX III. This
provides an easy migration to KX IlI for
Paragon Il customers who wish to switch to
KVM over IP. However, you may want to
consider the D2CIM-VUSB and D2CIM-DVUSB
CIMs that support virtual media, audio and
Absolute Mouse Synchronization. Additionally,
digital video CIMs supporting DVI, HDMI, and
Display Port are also available.
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Access and Copy Connection Information e 50,
53
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Accessing a Target Server o 168
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226
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90
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Allow Cookies ® 91
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Audio © 81, 235
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Authentication When Accessing a Smart Card
Reader ¢ 78
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Auto-Sense Video Settings ¢ 59, 155

B

Bandwidth and KVM-over-IP Performance e
245

Bandwidth Requirements ¢ 83, 208
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Port e 230

Blade Chassis - Port Access Page ¢ 23
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Browser Notes e 236
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224
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® 224
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CC-SG Notes @ 236
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Changing a Password ® 163
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CIM Notes e 222

CIMs Required for Virtual Media e 33

Clear Video Settings Cache ¢ 60, 112, 115

Client Launch Settings ¢ 70

Collect a Diagnostic Snapshot from VKC, VKCS,
and AKC ¢ 74
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*73

Color Accuracy e 50, 97
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Configuring Connection Properties ® 49, 53
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Connect ¢ 25
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182
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(VKC], Standalone VKC (VKCs), or Active
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Connect to a Target Using the Mobile KYM
Client e 147, 148

Connect to DSAM Serial Target via SSH e 133

Connect to DSAM Serial Target with URL
Direct Port Access o 132

Connect to DSAM Serial Targets with KX3 GUI
* 131

Connect to Virtual Media ¢ 77

Connecting a KX Ill and Catb Reach DVI -
Provide Extended Local Port Functionality e
181, 258

Connecting and Disconnecting from a Digital
Audio Device » 85, 86

Connecting and Disconnecting from Virtual
Media ¢ 36

Connecting the Paragon Il to the KX Il e 191

Connecting to Multiple Targets from a Single
Remote Client » 85, 86

Connection Info e 99

Connection Information e 53

Connection Properties e 95

Converting a Binary Certificate to a
Baseé4-Encoded DER Certificate (Optional)
° 17

Copy and Paste ¢ 139
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Default Connection Properties ¢ 96, 99

Default Connection Property Settings -
Optimized for Best Performance ¢ 49

Delete a Macro ¢ 103

Dell Chassis Cable Lengths and Video
Resolutions e 204

Digital Audio * 81

Digital Audio VKC and AKC Icons e 82

Digital CIM Established and Standard Modes
200, 201

Digital CIM Established Modes ¢ 202

Digital CIM Standard Modes ¢ 202

Digital CIM Timing Modes e 201

Disable Java Caching and Clear the Java
Cache ¢ 219

Disable ‘Protected Mode' ¢ 92

Disconnect e 26

Disconnect from an Audio Device ¢ 87

Disconnect from Virtual Media Drives ¢ 38

Disconnecting Mac and Linux Virtual Media
USB Drives ® 226

Discovering Devices on the KX Il Subnet 166

Discovering Devices on the Local Subnet e 165

Display Connection Info e 151, 155

Display Mobile Device Keyboard e 150, 151

DKX3-808 Fast Switching e 28

Documentation and Support ¢ 270

Dominion KX Il User Station e 8, 20, 143

Dominion KX3-832 5

Dominion KX3-864 ¢ 6

Drive Partitions ® 39, 41

DSAM LED Operation ¢ 118

Dual Mouse Modes © 64

Dual Port Video Groups - Port Access Page e
23

Dual Power Supplies ¢ 258

Dual Stack Login Performance Issues o 222

DVI Compatibility Mode e 202

E

Emulator e 134
Enable AKC Download Server Certificate
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Enable Favorites e 164

Enter Intelligent Mouse Mode e 64

Ethernet and IP Networking ¢ 260

Events Captured in the Audit Log and Syslog e

218
Example 1
Import the Certificate into the Browser e 13,

16

Example 2

Add the KX Ill to Trusted Sites and Import

the Certificate ¢ 15

Export Macros e 58

Extended Local Port e 257

F

Factory Default Login Information e 10
French Keyboard e 231

Frequently Asked Questions e 237
Full Screen Mode e 77

G

General FAQs ¢ 237
General Settings e 67
Get Started Using KX Il ¢ 10

H

Hardware ¢ 2, 192
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Informational Notes 210, 219

Input Menu » 100
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Installation e 253
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> U.S./Canada/Latin America

Monday - Friday
8a.m.-6p.m. ET
Phone: 800-724-8090 or 732-764-8886

For CommandCenter NOC: Press 6, then Press 1
For CommandCenter Secure Gateway: Press 6, then Press 2

Fax: 732-764-8887

Email for CommandCenter NOC: tech-ccnoc(@raritan.com

Email for all other products: tech@raritan.com

» China

Beijing

Monday - Friday

9a.m. - 6 p.m. local time
Phone: +86-10-88091890

Shanghai

Monday - Friday

9a.m. - 6 p.m. local time
Phone: +86-21-5425-2499

GuangZhou
Monday - Friday
9a.m. - 6 p.m. local time
Phone: +86-20-8755-5561

> India

Monday - Friday
9a.m. - 6 p.m. local time
Phone: +91-124-410-7881

> Japan

Monday - Friday

9:30 a.m. - 5:30 p.m. local time
Phone: +81-3-5795-3170

Email: support.japan(@raritan.com

> Europe

Europe

Monday - Friday

8:30 a.m. - 5 p.m. GMT+1 CET
Phone: +31-10-2844040

Email: tech.europef@raritan.com

United Kingdom
Monday - Friday

8:30 a.m. to 5 p.m. GMT
Phone +44(0)20-7090-1390

France

Monday - Friday

8:30a.m. - 5 p.m. GMT+1 CET
Phone: +33-1-47-56-20-39

Germany

Monday - Friday

8:30 a.m. - 5:30 p.m. GMT+1 CET
Phone: +49-20-17-47-98-0
Email: rg-support(@raritan.com

» Melbourne, Australia

Monday - Friday
9:00 a.m. - 6 p.m. local time
Phone: +61-3-9866-6887

P> Taiwan

Monday - Friday

9a.m. - 6 p.m. GMT -5 Standard -4 Daylight
Phone: +886-2-8919-1333

Email: support.apac(@raritan.com
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